aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authort3sserakt <t3ss@posteo.de>2022-01-06 15:36:17 +0100
committert3sserakt <t3ss@posteo.de>2022-01-06 15:36:17 +0100
commit0ddc76385bb8c29389bcfad9f5737c518861a42c (patch)
tree1fa88d770b335aba192af1813e4271b9d7f65cee /src/transport/Makefile.am
parent85697ed9ad40cdeffc642ccd6d63811cbd91c9b1 (diff)
downloadgnunet-0ddc76385bb8c29389bcfad9f5737c518861a42c.tar.gz
gnunet-0ddc76385bb8c29389bcfad9f5737c518861a42c.zip
- changed makefile to add the test for seting up of the backchannel key material
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 751bc40c1..ed5a2ef54 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -609,6 +609,7 @@ libgnunet_plugin_transport_https_server_la_CFLAGS = \
609 $(MHD_CFLAGS) $(AM_CFLAGS) -DBUILD_HTTPS 609 $(MHD_CFLAGS) $(AM_CFLAGS) -DBUILD_HTTPS
610 610
611check_PROGRAMS = \ 611check_PROGRAMS = \
612test_transport_hmac_calculation \
612 test_transport_address_switch_tcp \ 613 test_transport_address_switch_tcp \
613 test_transport_testing_startstop \ 614 test_transport_testing_startstop \
614 test_transport_testing_restart \ 615 test_transport_testing_restart \
@@ -696,6 +697,7 @@ endif
696if ENABLE_TEST_RUN 697if ENABLE_TEST_RUN
697AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 698AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
698TESTS = \ 699TESTS = \
700 test_transport_hmac_calculation \
699 test_transport_address_switch_tcp \ 701 test_transport_address_switch_tcp \
700 $(HTTP_SWITCH) \ 702 $(HTTP_SWITCH) \
701 $(HTTPS_SWITCH) \ 703 $(HTTPS_SWITCH) \
@@ -1363,6 +1365,12 @@ test_transport_api_bluetooth_LDADD = \
1363endif 1365endif
1364endif 1366endif
1365 1367
1368test_transport_hmac_calculation_SOURCES = \
1369 test_transport_hmac_calculation.c
1370test_transport_hmac_calculation_LDADD = \
1371 $(top_builddir)/src/util/libgnunetutil.la \
1372 $(LIBGCRYPT_LIBS)
1373
1366test_transport_address_switch_tcp_SOURCES = \ 1374test_transport_address_switch_tcp_SOURCES = \
1367 test_transport_address_switch.c 1375 test_transport_address_switch.c
1368test_transport_address_switch_tcp_LDADD = \ 1376test_transport_address_switch_tcp_LDADD = \