aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2018-11-14 14:35:49 +0100
committerChristian Grothoff <christian@grothoff.org>2018-11-14 14:35:49 +0100
commit2f3c9c69f7b6cea83930e8c927d35b519a5655a0 (patch)
treeea14909067617f9d6e50a430239a17d567f8401b /src/transport/Makefile.am
parent291828d5f645106866ef5dbcef847672f6fa47ba (diff)
downloadgnunet-2f3c9c69f7b6cea83930e8c927d35b519a5655a0.tar.gz
gnunet-2f3c9c69f7b6cea83930e8c927d35b519a5655a0.zip
add first sketch of libgnunettransportmonitor.so implementation
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 92b53137f..2a549d413 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -151,6 +151,7 @@ endif
151lib_LTLIBRARIES = \ 151lib_LTLIBRARIES = \
152 libgnunettransport.la \ 152 libgnunettransport.la \
153 libgnunettransportcommunicator.la \ 153 libgnunettransportcommunicator.la \
154 libgnunettransportmonitor.la \
154 $(TESTING_LIBS) 155 $(TESTING_LIBS)
155 156
156libgnunettransporttesting_la_SOURCES = \ 157libgnunettransporttesting_la_SOURCES = \
@@ -200,6 +201,17 @@ libgnunettransportcommunicator_la_LDFLAGS = \
200 $(GN_LIB_LDFLAGS) $(WINFLAGS) \ 201 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
201 -version-info 0:0:0 202 -version-info 0:0:0
202 203
204
205libgnunettransportmonitor_la_SOURCES = \
206 transport_api2_monitor.c
207libgnunettransportmonitor_la_LIBADD = \
208 $(top_builddir)/src/util/libgnunetutil.la \
209 $(GN_LIBINTL)
210libgnunettransportmonitor_la_LDFLAGS = \
211 $(GN_LIB_LDFLAGS) $(WINFLAGS) \
212 -version-info 0:0:0
213
214
203libexec_PROGRAMS = \ 215libexec_PROGRAMS = \
204 $(WLAN_BIN) \ 216 $(WLAN_BIN) \
205 $(WLAN_BIN_DUMMY) \ 217 $(WLAN_BIN_DUMMY) \