aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorMatthias Wachs <wachs@net.in.tum.de>2012-08-28 11:43:40 +0000
committerMatthias Wachs <wachs@net.in.tum.de>2012-08-28 11:43:40 +0000
commit415c261ba0169b53235d5e96da4d058e5e1f2d00 (patch)
tree262d87a0bf229e8a97f10f6a68371797b31fcf28 /src/transport/Makefile.am
parent2ec32745cf8b61bb257f4cb159f0d0ff83246e77 (diff)
downloadgnunet-415c261ba0169b53235d5e96da4d058e5e1f2d00.tar.gz
gnunet-415c261ba0169b53235d5e96da4d058e5e1f2d00.zip
tests
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am96
1 files changed, 20 insertions, 76 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index a2fa0f0e9..d4f16379a 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -34,22 +34,12 @@ if HAVE_LIBCURL
34 34
35 35
36 HTTPS_API_TEST = test_transport_api_https 36 HTTPS_API_TEST = test_transport_api_https
37endif
38endif
39
40if FALSE
41
42 HTTP_REL_TEST = test_transport_api_reliability_http
43 HTTP_NAT_REL_TEST = test_transport_api_reliability_http_nat
44
45 HTTPS_NAT_API_TEST = test_transport_api_https_nat
46 HTTPS_API_TIMEOUT_TEST = test_transport_api_timeout_https 37 HTTPS_API_TIMEOUT_TEST = test_transport_api_timeout_https
47 HTTPS_REL_TEST = test_transport_api_reliability_https 38 HTTPS_REL_TEST = test_transport_api_reliability_https
48 HTTPS_NAT_REL_TEST = test_transport_api_reliability_https_nat
49 HTTPS_QUOTA_TEST = test_quota_compliance_https \ 39 HTTPS_QUOTA_TEST = test_quota_compliance_https \
50 test_quota_compliance_https_asymmetric 40 test_quota_compliance_https_asymmetric
51endif 41endif
52 42endif
53 43
54if USE_COVERAGE 44if USE_COVERAGE
55 AM_CFLAGS = --coverage -O0 45 AM_CFLAGS = --coverage -O0
@@ -705,6 +695,21 @@ test_quota_compliance_http_asymmetric_LDADD = \
705 $(top_builddir)/src/util/libgnunetutil.la \ 695 $(top_builddir)/src/util/libgnunetutil.la \
706 $(top_builddir)/src/transport/libgnunettransporttesting.la 696 $(top_builddir)/src/transport/libgnunettransporttesting.la
707 697
698test_quota_compliance_https_SOURCES = \
699 test_quota_compliance.c
700test_quota_compliance_https_LDADD = \
701 $(top_builddir)/src/transport/libgnunettransport.la \
702 $(top_builddir)/src/hello/libgnunethello.la \
703 $(top_builddir)/src/util/libgnunetutil.la \
704 $(top_builddir)/src/transport/libgnunettransporttesting.la
705
706test_quota_compliance_https_asymmetric_SOURCES = \
707 test_quota_compliance.c
708test_quota_compliance_https_asymmetric_LDADD = \
709 $(top_builddir)/src/transport/libgnunettransport.la \
710 $(top_builddir)/src/hello/libgnunethello.la \
711 $(top_builddir)/src/util/libgnunetutil.la \
712 $(top_builddir)/src/transport/libgnunettransporttesting.la
708 713
709# HTTPS tests 714# HTTPS tests
710test_transport_api_https_SOURCES = \ 715test_transport_api_https_SOURCES = \
@@ -714,40 +719,15 @@ test_transport_api_https_LDADD = \
714 $(top_builddir)/src/hello/libgnunethello.la \ 719 $(top_builddir)/src/hello/libgnunethello.la \
715 $(top_builddir)/src/util/libgnunetutil.la \ 720 $(top_builddir)/src/util/libgnunetutil.la \
716 $(top_builddir)/src/transport/libgnunettransporttesting.la 721 $(top_builddir)/src/transport/libgnunettransporttesting.la
717 722
718if FALSE
719
720test_transport_api_timeout_https_SOURCES = \ 723test_transport_api_timeout_https_SOURCES = \
721 test_transport_api_timeout.c 724 test_transport_api_timeout.c
722test_transport_api_timeout_https_LDADD = \ 725test_transport_api_timeout_https_LDADD = \
723 $(top_builddir)/src/transport/libgnunettransport.la \ 726 $(top_builddir)/src/transport/libgnunettransport.la \
724 $(top_builddir)/src/hello/libgnunethello.la \ 727 $(top_builddir)/src/hello/libgnunethello.la \
725 $(top_builddir)/src/util/libgnunetutil.la \ 728 $(top_builddir)/src/util/libgnunetutil.la \
726 $(top_builddir)/src/transport/libgnunettransporttesting.la 729 $(top_builddir)/src/transport/libgnunettransporttesting.la
727 730
728test_transport_api_http_nat_SOURCES = \
729 test_transport_api.c
730test_transport_api_http_nat_LDADD = \
731 $(top_builddir)/src/transport/libgnunettransport.la \
732 $(top_builddir)/src/hello/libgnunethello.la \
733 $(top_builddir)/src/util/libgnunetutil.la \
734 $(top_builddir)/src/transport/libgnunettransporttesting.la
735
736test_transport_api_reliability_http_nat_SOURCES = \
737 test_transport_api_reliability.c
738test_transport_api_reliability_http_nat_LDADD = \
739 $(top_builddir)/src/transport/libgnunettransport.la \
740 $(top_builddir)/src/hello/libgnunethello.la \
741 $(top_builddir)/src/util/libgnunetutil.la \
742 $(top_builddir)/src/transport/libgnunettransporttesting.la
743
744test_transport_api_https_nat_SOURCES = \
745 test_transport_api.c
746test_transport_api_https_nat_LDADD = \
747 $(top_builddir)/src/transport/libgnunettransport.la \
748 $(top_builddir)/src/hello/libgnunethello.la \
749 $(top_builddir)/src/util/libgnunetutil.la \
750 $(top_builddir)/src/transport/libgnunettransporttesting.la
751 731
752test_transport_api_reliability_https_SOURCES = \ 732test_transport_api_reliability_https_SOURCES = \
753 test_transport_api_reliability.c 733 test_transport_api_reliability.c
@@ -757,42 +737,6 @@ test_transport_api_reliability_https_LDADD = \
757 $(top_builddir)/src/util/libgnunetutil.la \ 737 $(top_builddir)/src/util/libgnunetutil.la \
758 $(top_builddir)/src/transport/libgnunettransporttesting.la 738 $(top_builddir)/src/transport/libgnunettransporttesting.la
759 739
760test_transport_api_reliability_https_nat_SOURCES = \
761 test_transport_api_reliability.c
762test_transport_api_reliability_https_nat_LDADD = \
763 $(top_builddir)/src/transport/libgnunettransport.la \
764 $(top_builddir)/src/hello/libgnunethello.la \
765 $(top_builddir)/src/util/libgnunetutil.la \
766 $(top_builddir)/src/transport/libgnunettransporttesting.la
767
768test_quota_compliance_http_SOURCES = \
769 test_quota_compliance.c
770test_quota_compliance_http_LDADD = \
771 $(top_builddir)/src/transport/libgnunettransport.la \
772 $(top_builddir)/src/hello/libgnunethello.la \
773 $(top_builddir)/src/util/libgnunetutil.la \
774 $(top_builddir)/src/transport/libgnunettransporttesting.la
775
776
777test_quota_compliance_https_SOURCES = \
778 test_quota_compliance.c
779test_quota_compliance_https_LDADD = \
780 $(top_builddir)/src/transport/libgnunettransport.la \
781 $(top_builddir)/src/hello/libgnunethello.la \
782 $(top_builddir)/src/util/libgnunetutil.la \
783 $(top_builddir)/src/transport/libgnunettransporttesting.la
784
785test_quota_compliance_https_asymmetric_SOURCES = \
786 test_quota_compliance.c
787test_quota_compliance_https_asymmetric_LDADD = \
788 $(top_builddir)/src/transport/libgnunettransport.la \
789 $(top_builddir)/src/hello/libgnunethello.la \
790 $(top_builddir)/src/util/libgnunetutil.la \
791 $(top_builddir)/src/transport/libgnunettransporttesting.la
792
793
794endif
795
796test_transport_api_unreliability_unix_SOURCES = \ 740test_transport_api_unreliability_unix_SOURCES = \
797 test_transport_api_unreliability.c 741 test_transport_api_unreliability.c
798test_transport_api_unreliability_unix_LDADD = \ 742test_transport_api_unreliability_unix_LDADD = \