aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2021-08-24 15:21:32 +0200
committerChristian Grothoff <christian@grothoff.org>2021-08-24 15:21:32 +0200
commit5bb46d9a3ab568145f594c5a3cfa31ead3df38eb (patch)
tree021dd56b9a4fd7d349139a844635bb1675b80167 /src/transport/Makefile.am
parent5ddaa3f8eb5e01882540f21ddf237f3a41311e8a (diff)
downloadgnunet-5bb46d9a3ab568145f594c5a3cfa31ead3df38eb.tar.gz
gnunet-5bb46d9a3ab568145f594c5a3cfa31ead3df38eb.zip
-remove dead ats-tests, fix strange Debian build issues
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am29
1 files changed, 13 insertions, 16 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index afa37bac5..70687f7b5 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -156,13 +156,6 @@ libgnunettransporttesting_la_LIBADD = \
156 $(top_builddir)/src/testing/libgnunettesting.la \ 156 $(top_builddir)/src/testing/libgnunettesting.la \
157 $(top_builddir)/src/arm/libgnunetarm.la \ 157 $(top_builddir)/src/arm/libgnunetarm.la \
158 $(GN_LIBINTL) 158 $(GN_LIBINTL)
159libgnunettransporttesting_la_DEPENDENCIES = \
160 libgnunettransport.la \
161 $(top_builddir)/src/hello/libgnunethello.la \
162 $(top_builddir)/src/ats/libgnunetats.la \
163 $(top_builddir)/src/util/libgnunetutil.la \
164 $(top_builddir)/src/testing/libgnunettesting.la \
165 $(top_builddir)/src/arm/libgnunetarm.la
166libgnunettransporttesting_la_LDFLAGS = \ 159libgnunettransporttesting_la_LDFLAGS = \
167 $(GN_LIB_LDFLAGS) 160 $(GN_LIB_LDFLAGS)
168 161
@@ -190,7 +183,8 @@ libgnunettransporttesting2_la_LIBADD = \
190 $(top_builddir)/src/util/libgnunetutil.la 183 $(top_builddir)/src/util/libgnunetutil.la
191libgnunettransporttesting2_la_LDFLAGS = \ 184libgnunettransporttesting2_la_LDFLAGS = \
192 $(GN_LIBINTL) \ 185 $(GN_LIBINTL) \
193 $(GN_LIB_LDFLAGS) 186 $(GN_LIB_LDFLAGS) \
187 -version-info 0:0:0
194 188
195libgnunettransport_la_SOURCES = \ 189libgnunettransport_la_SOURCES = \
196 transport.h \ 190 transport.h \
@@ -208,10 +202,6 @@ libgnunettransport_la_LIBADD = \
208 $(top_builddir)/src/ats/libgnunetats.la \ 202 $(top_builddir)/src/ats/libgnunetats.la \
209 $(top_builddir)/src/util/libgnunetutil.la \ 203 $(top_builddir)/src/util/libgnunetutil.la \
210 $(GN_LIBINTL) 204 $(GN_LIBINTL)
211libgnunettransport_la_DEPENDENCIES = \
212 $(top_builddir)/src/hello/libgnunethello.la \
213 $(top_builddir)/src/ats/libgnunetats.la \
214 $(top_builddir)/src/util/libgnunetutil.la
215libgnunettransport_la_LDFLAGS = \ 205libgnunettransport_la_LDFLAGS = \
216 $(GN_LIB_LDFLAGS) \ 206 $(GN_LIB_LDFLAGS) \
217 -version-info 4:0:2 207 -version-info 4:0:2
@@ -406,16 +396,23 @@ plugin_LTLIBRARIES = \
406libgnunet_test_transport_plugin_cmd_simple_send_la_SOURCES = \ 396libgnunet_test_transport_plugin_cmd_simple_send_la_SOURCES = \
407 test_transport_plugin_cmd_simple_send.c 397 test_transport_plugin_cmd_simple_send.c
408libgnunet_test_transport_plugin_cmd_simple_send_la_LIBADD = \ 398libgnunet_test_transport_plugin_cmd_simple_send_la_LIBADD = \
409 $(top_builddir)/src/util/libgnunetutil.la \ 399 libgnunettransporttesting2.la \
400 libgnunettransportapplication.la \
401 libgnunettransport.la \
410 $(top_builddir)/src/testing/libgnunettesting.la \ 402 $(top_builddir)/src/testing/libgnunettesting.la \
403 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
411 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 404 $(top_builddir)/src/statistics/libgnunetstatistics.la \
412 libgnunettransporttesting2.la \ 405 $(top_builddir)/src/hello/libgnunethello.la \
406 $(top_builddir)/src/ats/libgnunetats.la \
407 $(top_builddir)/src/arm/libgnunetarm.la \
408 $(top_builddir)/src/util/libgnunetutil.la \
413 $(LTLIBINTL) 409 $(LTLIBINTL)
414libgnunet_test_transport_plugin_cmd_simple_send_la_LDFLAGS = \ 410libgnunet_test_transport_plugin_cmd_simple_send_la_LDFLAGS = \
415 $(GN_PLUGIN_LDFLAGS) 411 $(GN_PLUGIN_LDFLAGS)
416 412
417if HAVE_EXPERIMENTAL 413if HAVE_EXPERIMENTAL
418plugin_LTLIBRARIES += libgnunet_plugin_transport_udp.la 414plugin_LTLIBRARIES += \
415 libgnunet_plugin_transport_udp.la
419endif 416endif
420 417
421# Note: real plugins of course need to be added 418# Note: real plugins of course need to be added
@@ -731,8 +728,8 @@ test_transport_api_cmd_simple_send_LDADD = \
731 $(top_builddir)/src/testing/libgnunettesting.la \ 728 $(top_builddir)/src/testing/libgnunettesting.la \
732 $(top_builddir)/src/util/libgnunetutil.la \ 729 $(top_builddir)/src/util/libgnunetutil.la \
733 $(top_builddir)/src/testbed/libgnunettestbed.la \ 730 $(top_builddir)/src/testbed/libgnunettestbed.la \
734 libgnunettransport.la \
735 $(top_builddir)/src/hello/libgnunethello.la \ 731 $(top_builddir)/src/hello/libgnunethello.la \
732 libgnunettransport.la \
736 libgnunettransporttesting.la 733 libgnunettransporttesting.la
737 734
738test_transport_testing_startstop_SOURCES = \ 735test_transport_testing_startstop_SOURCES = \