aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2016-07-23 22:32:35 +0000
committerChristian Grothoff <christian@grothoff.org>2016-07-23 22:32:35 +0000
commit658c3cf583b0c09e55c41a78a9ec8dbe28cb515e (patch)
tree236759ed9a5b6a5e3493667c34f384279bc12bbe /src/transport/Makefile.am
parent1d188d2b9437f8a7685d0d139da7a6b9fb1b7c9c (diff)
downloadgnunet-658c3cf583b0c09e55c41a78a9ec8dbe28cb515e.tar.gz
gnunet-658c3cf583b0c09e55c41a78a9ec8dbe28cb515e.zip
more refactoring of tests for new send API
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index d6c4e3ccf..b201ab24a 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -431,7 +431,6 @@ libgnunet_plugin_transport_https_server_la_CFLAGS = \
431 431
432if HAVE_TESTING 432if HAVE_TESTING
433check_PROGRAMS = \ 433check_PROGRAMS = \
434 test_transport_api_restart_2peers \
435 test_transport_address_switch_tcp \ 434 test_transport_address_switch_tcp \
436 test_transport_address_switch_udp \ 435 test_transport_address_switch_udp \
437 test_transport_testing_startstop \ 436 test_transport_testing_startstop \
@@ -450,6 +449,7 @@ check_PROGRAMS = \
450 test_transport_api_disconnect_tcp \ 449 test_transport_api_disconnect_tcp \
451 test_transport_api_tcp \ 450 test_transport_api_tcp \
452 test_transport_api_restart_1peer \ 451 test_transport_api_restart_1peer \
452 test_transport_api_restart_2peers \
453 test_transport_api_timeout_tcp \ 453 test_transport_api_timeout_tcp \
454 test_transport_api_limited_sockets_tcp \ 454 test_transport_api_limited_sockets_tcp \
455 test_transport_api_tcp_nat \ 455 test_transport_api_tcp_nat \
@@ -508,6 +508,10 @@ endif
508if ENABLE_TEST_RUN 508if ENABLE_TEST_RUN
509AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH; 509AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;
510TESTS = \ 510TESTS = \
511 test_transport_address_switch_tcp \
512 test_transport_address_switch_udp \
513 $(HTTP_SWITCH) \
514 $(HTTPS_SWITCH) \
511 test_transport_testing_startstop \ 515 test_transport_testing_startstop \
512 test_transport_testing_restart \ 516 test_transport_testing_restart \
513 test_plugin_tcp \ 517 test_plugin_tcp \
@@ -563,11 +567,7 @@ TESTS = \
563 $(HTTP_API_TIMEOUT_TEST) \ 567 $(HTTP_API_TIMEOUT_TEST) \
564 $(HTTPS_API_TIMEOUT_TEST) \ 568 $(HTTPS_API_TIMEOUT_TEST) \
565 $(WLAN_TIMEOUT_TEST) \ 569 $(WLAN_TIMEOUT_TEST) \
566 $(BT_TIMEOUT_TEST) \ 570 $(BT_TIMEOUT_TEST)
567 test_transport_address_switch_tcp \
568 test_transport_address_switch_udp \
569 $(HTTP_SWITCH) \
570 $(HTTPS_SWITCH)
571if HAVE_GETOPT_BINARY 571if HAVE_GETOPT_BINARY
572TESTS += \ 572TESTS += \
573test_transport_api_slow_ats 573test_transport_api_slow_ats
@@ -762,7 +762,7 @@ test_transport_api_tcp_LDADD = \
762 libgnunettransporttesting.la 762 libgnunettransporttesting.la
763 763
764test_transport_api_restart_1peer_SOURCES = \ 764test_transport_api_restart_1peer_SOURCES = \
765 test_transport_api_restart_1peer.c 765 test_transport_api_restart_reconnect.c
766test_transport_api_restart_1peer_LDADD = \ 766test_transport_api_restart_1peer_LDADD = \
767 libgnunettransport.la \ 767 libgnunettransport.la \
768 $(top_builddir)/src/hello/libgnunethello.la \ 768 $(top_builddir)/src/hello/libgnunethello.la \
@@ -772,7 +772,7 @@ test_transport_api_restart_1peer_LDADD = \
772 libgnunettransporttesting.la 772 libgnunettransporttesting.la
773 773
774test_transport_api_restart_2peers_SOURCES = \ 774test_transport_api_restart_2peers_SOURCES = \
775 test_transport_api_restart_2peers.c 775 test_transport_api_restart_reconnect.c
776test_transport_api_restart_2peers_LDADD = \ 776test_transport_api_restart_2peers_LDADD = \
777 libgnunettransport.la \ 777 libgnunettransport.la \
778 $(top_builddir)/src/hello/libgnunethello.la \ 778 $(top_builddir)/src/hello/libgnunethello.la \