aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authort3sserakt <t3ss@posteo.de>2023-02-08 10:37:33 +0100
committert3sserakt <t3ss@posteo.de>2023-02-08 10:37:33 +0100
commit6b83e9a453ffc9ea0347a7e725c3a9b6d2a32517 (patch)
tree7bc7b5f2d65ebaf28713f8a69f11f619b2044f4b /src/transport/Makefile.am
parentbe0909d95bc5fa961b91223729b9858a864e3f61 (diff)
downloadgnunet-6b83e9a453ffc9ea0347a7e725c3a9b6d2a32517.tar.gz
gnunet-6b83e9a453ffc9ea0347a7e725c3a9b6d2a32517.zip
TNG: Added performance test case.
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am23
1 files changed, 22 insertions, 1 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 5acba3a4e..eeafab840 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -130,6 +130,7 @@ libgnunettransporttesting2_la_SOURCES = \
130 transport_api_cmd_start_peer.c \ 130 transport_api_cmd_start_peer.c \
131 transport_api_cmd_stop_peer.c \ 131 transport_api_cmd_stop_peer.c \
132 transport_api_cmd_send_simple.c \ 132 transport_api_cmd_send_simple.c \
133 transport_api_cmd_send_simple_performance.c \
133 transport-testing2.c transport-testing2.h \ 134 transport-testing2.c transport-testing2.h \
134 transport-testing-cmds.h \ 135 transport-testing-cmds.h \
135 transport-testing-filenames2.c \ 136 transport-testing-filenames2.c \
@@ -357,6 +358,7 @@ plugin_LTLIBRARIES = \
357 $(HTTPS_SERVER_PLUGIN_LA) \ 358 $(HTTPS_SERVER_PLUGIN_LA) \
358 $(WLAN_PLUGIN_LA) \ 359 $(WLAN_PLUGIN_LA) \
359 $(BT_PLUGIN_LA) \ 360 $(BT_PLUGIN_LA) \
361 libgnunet_test_transport_plugin_cmd_simple_send_performance.la \
360 libgnunet_test_transport_plugin_cmd_nat_upnp.la \ 362 libgnunet_test_transport_plugin_cmd_nat_upnp.la \
361 libgnunet_test_transport_plugin_cmd_simple_send.la \ 363 libgnunet_test_transport_plugin_cmd_simple_send.la \
362 libgnunet_test_transport_plugin_cmd_simple_send_broadcast.la \ 364 libgnunet_test_transport_plugin_cmd_simple_send_broadcast.la \
@@ -414,6 +416,23 @@ libgnunet_test_transport_plugin_cmd_simple_send_la_LIBADD = \
414libgnunet_test_transport_plugin_cmd_simple_send_la_LDFLAGS = \ 416libgnunet_test_transport_plugin_cmd_simple_send_la_LDFLAGS = \
415 $(GN_PLUGIN_LDFLAGS) 417 $(GN_PLUGIN_LDFLAGS)
416 418
419libgnunet_test_transport_plugin_cmd_simple_send_performance_la_SOURCES = \
420 test_transport_plugin_cmd_simple_send_performance.c
421libgnunet_test_transport_plugin_cmd_simple_send_performance_la_LIBADD = \
422 libgnunettransporttesting2.la \
423 libgnunettransportapplication.la \
424 libgnunettransportcore.la \
425 $(top_builddir)/src/testing/libgnunettesting.la \
426 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
427 $(top_builddir)/src/statistics/libgnunetstatistics.la \
428 $(top_builddir)/src/hello/libgnunethello.la \
429 $(top_builddir)/src/ats/libgnunetats.la \
430 $(top_builddir)/src/arm/libgnunetarm.la \
431 $(top_builddir)/src/util/libgnunetutil.la \
432 $(LTLIBINTL)
433libgnunet_test_transport_plugin_cmd_simple_send_performance_la_LDFLAGS = \
434 $(GN_PLUGIN_LDFLAGS)
435
417libgnunet_test_transport_plugin_cmd_simple_send_broadcast_la_SOURCES = \ 436libgnunet_test_transport_plugin_cmd_simple_send_broadcast_la_SOURCES = \
418 test_transport_plugin_cmd_simple_send_broadcast.c 437 test_transport_plugin_cmd_simple_send_broadcast.c
419libgnunet_test_transport_plugin_cmd_simple_send_broadcast_la_LIBADD = \ 438libgnunet_test_transport_plugin_cmd_simple_send_broadcast_la_LIBADD = \
@@ -760,7 +779,8 @@ endif
760# Only test TNG if we run experimental 779# Only test TNG if we run experimental
761if HAVE_EXPERIMENTAL 780if HAVE_EXPERIMENTAL
762check_SCRIPTS= \ 781check_SCRIPTS= \
763test_transport_nat_icmp_tcp.sh \ 782 test_transport_simple_send_performance.sh \
783 test_transport_nat_icmp_tcp.sh \
764 test_transport_nat_upnp.sh \ 784 test_transport_nat_upnp.sh \
765 test_transport_simple_send_string.sh \ 785 test_transport_simple_send_string.sh \
766 test_transport_simple_send.sh \ 786 test_transport_simple_send.sh \
@@ -1510,6 +1530,7 @@ test_transport_api_slow_ats_LDADD = \
1510 1530
1511 1531
1512EXTRA_DIST = \ 1532EXTRA_DIST = \
1533test_transport_simple_send_performance.sh \
1513test_transport_nat_icmp_tcp.sh \ 1534test_transport_nat_icmp_tcp.sh \
1514test_transport_nat_upnp.sh \ 1535test_transport_nat_upnp.sh \
1515test_transport_simple_send_string.sh \ 1536test_transport_simple_send_string.sh \