aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authort3sserakt <t3ss@posteo.de>2022-03-17 14:28:40 +0100
committert3sserakt <t3ss@posteo.de>2022-03-17 14:28:40 +0100
commit95a1edacccd9b3bf769a144a12d41946d0ac25dc (patch)
treeb84608361cd836d29649f076589dd42943d1301f /src/transport/Makefile.am
parent16c9959d9b395b179446ee4a2cb70f3563c4fb20 (diff)
downloadgnunet-95a1edacccd9b3bf769a144a12d41946d0ac25dc.tar.gz
gnunet-95a1edacccd9b3bf769a144a12d41946d0ac25dc.zip
- Trying to exchange iptables with nft, first shot failed.
- Fixed small bug in UDP communicator. - Fixed bug in DV circle test case - Introduced a default value to wait for a reliability ack. - Introduced a FC retransmission threshold together with a retransmission count. - Introduced a original size value for TransportDVBoxMessage - Checking if we have the root pending messge, when removing the pending message from virtual link. - Added delay value to schedule_transmit_on_queue to wait for retransmitting. - Checking for confirmed virtual link, before routing. - Allow unconfirmed queues or DV routes when doing dv encapsulation for control traffic. - Changed check_vl_transmission to also check window size for DV next hop peer. - Fixed fragment box handling to also handle reliability boxed message which needed to be fragmented. - Fixed completing a message which was not only fragmented but also DV boxed. - Added logic to notify core about a new virtual link using distance vector without having validated next neighbour. - Added logic to create a virtual link to handle flow control messages. - fixed several smaller bugs in fragmentation logic. - Changed logic for adding the next_attempt value of PendingMessage.
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 5d6fb8421..ec00bc917 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -778,7 +778,7 @@ check_SCRIPTS= \
778 test_transport_simple_send.sh \ 778 test_transport_simple_send.sh \
779 test_transport_simple_send_broadcast.sh \ 779 test_transport_simple_send_broadcast.sh \
780 test_transport_udp_backchannel.sh \ 780 test_transport_udp_backchannel.sh \
781 # test_transport_simple_send_dv_circle.sh 781 test_transport_simple_send_dv_circle.sh
782 # test_transport_simple_send_dv_inverse.sh 782 # test_transport_simple_send_dv_inverse.sh
783 783
784test_transport_start_with_config_SOURCES = \ 784test_transport_start_with_config_SOURCES = \