aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <schanzen@gnunet.org>2022-09-06 12:34:39 +0200
committerMartin Schanzenbach <schanzen@gnunet.org>2022-09-06 12:34:39 +0200
commitafea0eea1ecfa41150fdf9ee052acac75eee6534 (patch)
tree1bb24bac4340262b15640fadbdb7beb8a32f695c /src/transport/Makefile.am
parent1d4e7a0eec5ee96d878cdd0e4e3c62c0676bf2d0 (diff)
downloadgnunet-afea0eea1ecfa41150fdf9ee052acac75eee6534.tar.gz
gnunet-afea0eea1ecfa41150fdf9ee052acac75eee6534.zip
BUILD: Remove gnurl. Improve curl-gnutls detection
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am73
1 files changed, 19 insertions, 54 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 7bd07b905..a4971ff2c 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -16,63 +16,28 @@ HTTPS_SERVER_PLUGIN_LA = libgnunet_plugin_transport_https_server.la
16HTTP_SERVER_PLUGIN_TEST = test_plugin_http_server 16HTTP_SERVER_PLUGIN_TEST = test_plugin_http_server
17HTTPS_SERVER_PLUGIN_TEST = test_plugin_https_server 17HTTPS_SERVER_PLUGIN_TEST = test_plugin_https_server
18 18
19if HAVE_LIBGNURL 19HTTP_CLIENT_PLUGIN_TEST = test_plugin_http_client
20 HTTP_CLIENT_PLUGIN_TEST = test_plugin_http_client 20HTTPS_CLIENT_PLUGIN_TEST = test_plugin_https_client
21 HTTPS_CLIENT_PLUGIN_TEST = test_plugin_https_client 21HTTP_CLIENT_PLUGIN_LA = libgnunet_plugin_transport_http_client.la
22 HTTP_CLIENT_PLUGIN_LA = libgnunet_plugin_transport_http_client.la 22HTTPS_CLIENT_PLUGIN_LA = libgnunet_plugin_transport_https_client.la
23 HTTPS_CLIENT_PLUGIN_LA = libgnunet_plugin_transport_https_client.la 23
24LIB_GNURL=@LIBGNURL@ 24HTTP_API_TEST = test_transport_api_http
25CPP_GNURL=@LIBGNURL_CPPFLAGS@ 25HTTP_REVERSE_API_TEST = test_transport_api_http_reverse
26else 26HTTP_API_TIMEOUT_TEST = test_transport_api_timeout_http
27if HAVE_LIBCURL 27HTTP_REL_TEST = test_transport_api_reliability_http \
28 HTTP_CLIENT_PLUGIN_TEST = test_plugin_http_client
29 HTTPS_CLIENT_PLUGIN_TEST = test_plugin_https_client
30 HTTP_CLIENT_PLUGIN_LA = libgnunet_plugin_transport_http_client.la
31 HTTPS_CLIENT_PLUGIN_LA = libgnunet_plugin_transport_https_client.la
32LIB_GNURL=@LIBCURL@
33CPP_GNURL=@LIBCURL_CPPFLAGS@
34endif
35endif
36
37if HAVE_LIBGNURL
38 HTTP_API_TEST = test_transport_api_http
39 HTTP_REVERSE_API_TEST = test_transport_api_http_reverse
40 HTTP_API_TIMEOUT_TEST = test_transport_api_timeout_http
41 HTTP_REL_TEST = test_transport_api_reliability_http \
42 test_transport_api_reliability_http_xhr
43 HTTP_QUOTA_TEST = test_quota_compliance_http \
44 test_quota_compliance_http_asymmetric
45 HTTP_SWITCH = test_transport_address_switch_http
46 HTTPS_API_TEST = test_transport_api_https
47 HTTPS_API_TIMEOUT_TEST = test_transport_api_timeout_https
48if HAVE_EXPERIMENTAL
49 HTTPS_REL_TEST = test_transport_api_reliability_https \
50 test_transport_api_reliability_https_xhr
51endif
52 HTTPS_QUOTA_TEST = test_quota_compliance_https \
53 test_quota_compliance_https_asymmetric
54 HTTPS_SWITCH = test_transport_address_switch_https
55else
56if HAVE_LIBCURL
57 HTTP_API_TEST = test_transport_api_http
58 HTTP_REVERSE_API_TEST = test_transport_api_http_reverse
59 HTTP_API_TIMEOUT_TEST = test_transport_api_timeout_http
60 HTTP_REL_TEST = test_transport_api_reliability_http \
61 test_transport_api_reliability_http_xhr 28 test_transport_api_reliability_http_xhr
62 HTTP_QUOTA_TEST = test_quota_compliance_http \ 29HTTP_QUOTA_TEST = test_quota_compliance_http \
63 test_quota_compliance_http_asymmetric 30 test_quota_compliance_http_asymmetric
64 HTTP_SWITCH = test_transport_address_switch_http 31HTTP_SWITCH = test_transport_address_switch_http
65 HTTPS_API_TEST = test_transport_api_https 32HTTPS_API_TEST = test_transport_api_https
66 HTTPS_API_TIMEOUT_TEST = test_transport_api_timeout_https 33HTTPS_API_TIMEOUT_TEST = test_transport_api_timeout_https
67if HAVE_EXPERIMENTAL 34if HAVE_EXPERIMENTAL
68 HTTPS_REL_TEST = test_transport_api_reliability_https \ 35 HTTPS_REL_TEST = test_transport_api_reliability_https \
69 test_transport_api_reliability_https_xhr 36 test_transport_api_reliability_https_xhr
70endif 37endif
71 HTTPS_QUOTA_TEST = test_quota_compliance_https \ 38HTTPS_QUOTA_TEST = test_quota_compliance_https \
72 test_quota_compliance_https_asymmetric 39 test_quota_compliance_https_asymmetric
73 HTTPS_SWITCH = test_transport_address_switch_https 40HTTPS_SWITCH = test_transport_address_switch_https
74endif
75endif
76 41
77if USE_COVERAGE 42if USE_COVERAGE
78 AM_CFLAGS = --coverage -O0 43 AM_CFLAGS = --coverage -O0
@@ -555,13 +520,13 @@ libgnunet_plugin_transport_http_client_la_LIBADD = \
555 $(top_builddir)/src/hello/libgnunethello.la \ 520 $(top_builddir)/src/hello/libgnunethello.la \
556 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 521 $(top_builddir)/src/statistics/libgnunetstatistics.la \
557 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \ 522 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
558 $(LIB_GNURL) \ 523 @LIBCURL@ \
559 $(top_builddir)/src/util/libgnunetutil.la 524 $(top_builddir)/src/util/libgnunetutil.la
560libgnunet_plugin_transport_http_client_la_LDFLAGS = \ 525libgnunet_plugin_transport_http_client_la_LDFLAGS = \
561 $(GN_LIBINTL) \ 526 $(GN_LIBINTL) \
562 $(GN_PLUGIN_LDFLAGS) 527 $(GN_PLUGIN_LDFLAGS)
563libgnunet_plugin_transport_http_client_la_CFLAGS = \ 528libgnunet_plugin_transport_http_client_la_CFLAGS = \
564 $(CPP_GNURL) $(AM_CFLAGS) 529 @LIBCURL_CPPFLAGS@ $(AM_CFLAGS)
565 530
566 531
567libgnunet_plugin_transport_http_server_la_SOURCES = \ 532libgnunet_plugin_transport_http_server_la_SOURCES = \
@@ -585,13 +550,13 @@ libgnunet_plugin_transport_https_client_la_LIBADD = \
585 $(top_builddir)/src/hello/libgnunethello.la \ 550 $(top_builddir)/src/hello/libgnunethello.la \
586 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 551 $(top_builddir)/src/statistics/libgnunetstatistics.la \
587 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \ 552 $(top_builddir)/src/peerinfo/libgnunetpeerinfo.la \
588 $(LIB_GNURL) \ 553 @LIBCURL@ \
589 $(top_builddir)/src/util/libgnunetutil.la 554 $(top_builddir)/src/util/libgnunetutil.la
590libgnunet_plugin_transport_https_client_la_LDFLAGS = \ 555libgnunet_plugin_transport_https_client_la_LDFLAGS = \
591 $(GN_LIBINTL) \ 556 $(GN_LIBINTL) \
592 $(GN_PLUGIN_LDFLAGS) 557 $(GN_PLUGIN_LDFLAGS)
593libgnunet_plugin_transport_https_client_la_CFLAGS = \ 558libgnunet_plugin_transport_https_client_la_CFLAGS = \
594 $(CPP_GNURL) $(AM_CFLAGS) -DBUILD_HTTPS 559 @LIBCURL_CPPFLAGS@ $(AM_CFLAGS) -DBUILD_HTTPS
595 560
596 561
597libgnunet_plugin_transport_https_server_la_SOURCES = \ 562libgnunet_plugin_transport_https_server_la_SOURCES = \