aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorClaudiu Olteanu <claudiu@140774ce-b5e7-0310-ab8b-a85725594a96>2013-08-04 18:19:43 +0000
committerClaudiu Olteanu <claudiu@140774ce-b5e7-0310-ab8b-a85725594a96>2013-08-04 18:19:43 +0000
commitb15362b6534debb8098d797cf4a847599b03228d (patch)
treef7891f1220509aa7fba9396d9e3aeeaa9477da90 /src/transport/Makefile.am
parent7725cd78de93ce9eefe51c2fa52ce1bd1b0ce636 (diff)
downloadgnunet-b15362b6534debb8098d797cf4a847599b03228d.tar.gz
gnunet-b15362b6534debb8098d797cf4a847599b03228d.zip
Extending the testcases to use bluetooth
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am79
1 files changed, 78 insertions, 1 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 4524f9897..358eba98b 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -71,6 +71,12 @@ if HAVE_LIBBLUETOOTH
71 AM_LDFLAGS = -lbluetooth 71 AM_LDFLAGS = -lbluetooth
72 BT_BIN = gnunet-helper-transport-bluetooth 72 BT_BIN = gnunet-helper-transport-bluetooth
73 BT_PLUGIN_LA = libgnunet_plugin_transport_bluetooth.la 73 BT_PLUGIN_LA = libgnunet_plugin_transport_bluetooth.la
74 BT_PLUGIN_TEST = test_plugin_bluetooth
75 BT_API_TEST = test_transport_api_bluetooth
76 BT_REL_TEST = test_transport_api_reliability_bluetooth
77 BT_UREL_TEST = test_transport_api_unreliability_bluetooth
78 BT_QUOTA_TEST = test_quota_compliance_bluetooth \
79 test_quota_compliance_bluetooth_asymmetric
74endif 80endif
75endif 81endif
76 82
@@ -355,6 +361,7 @@ check_PROGRAMS = \
355 test_plugin_udp \ 361 test_plugin_udp \
356 $(UNIX_TEST) \ 362 $(UNIX_TEST) \
357 $(WLAN_PLUGIN_TEST) \ 363 $(WLAN_PLUGIN_TEST) \
364 $(BT_PLUGIN_TEST) \
358 test_http_common \ 365 test_http_common \
359 $(HTTP_CLIENT_PLUGIN_TEST) \ 366 $(HTTP_CLIENT_PLUGIN_TEST) \
360 $(HTTPS_CLIENT_PLUGIN_TEST) \ 367 $(HTTPS_CLIENT_PLUGIN_TEST) \
@@ -380,6 +387,7 @@ check_PROGRAMS = \
380 $(HTTPS_API_TEST) \ 387 $(HTTPS_API_TEST) \
381 $(HTTPS_API_TIMEOUT_TEST) \ 388 $(HTTPS_API_TIMEOUT_TEST) \
382 $(WLAN_API_TEST) \ 389 $(WLAN_API_TEST) \
390 $(BT_API_TEST) \
383 test_transport_api_multi \ 391 test_transport_api_multi \
384 test_transport_blacklisting_no_bl \ 392 test_transport_blacklisting_no_bl \
385 test_transport_blacklisting_outbound_bl_full \ 393 test_transport_blacklisting_outbound_bl_full \
@@ -399,13 +407,16 @@ check_PROGRAMS = \
399 $(HTTPS_REL_TEST) \ 407 $(HTTPS_REL_TEST) \
400 $(WLAN_REL_TEST) \ 408 $(WLAN_REL_TEST) \
401 $(WLAN_UREL_TEST) \ 409 $(WLAN_UREL_TEST) \
410 $(BT_REL_TEST) \
411 $(BT_UREL_TEST) \
402 test_quota_compliance_tcp \ 412 test_quota_compliance_tcp \
403 test_quota_compliance_tcp_asymmetric \ 413 test_quota_compliance_tcp_asymmetric \
404 test_quota_compliance_udp \ 414 test_quota_compliance_udp \
405 $(UNIX_QUOTA_TEST) \ 415 $(UNIX_QUOTA_TEST) \
406 $(HTTP_QUOTA_TEST) \ 416 $(HTTP_QUOTA_TEST) \
407 $(HTTPS_QUOTA_TEST) \ 417 $(HTTPS_QUOTA_TEST) \
408 $(WLAN_QUOTA_TEST) 418 $(WLAN_QUOTA_TEST) \
419 $(BT_QUOTA_TEST)
409endif 420endif
410 421
411if ENABLE_TEST_RUN 422if ENABLE_TEST_RUN
@@ -418,6 +429,7 @@ TESTS = \
418 test_plugin_udp \ 429 test_plugin_udp \
419 $(UNIX_TEST) \ 430 $(UNIX_TEST) \
420 $(WLAN_PLUGIN_TEST) \ 431 $(WLAN_PLUGIN_TEST) \
432 $(BT_PLUGIN_TEST) \
421 test_transport_api_blacklisting \ 433 test_transport_api_blacklisting \
422 test_transport_api_disconnect_tcp \ 434 test_transport_api_disconnect_tcp \
423 test_transport_api_bidirectional_connect \ 435 test_transport_api_bidirectional_connect \
@@ -437,6 +449,7 @@ TESTS = \
437 $(HTTPS_API_TEST) \ 449 $(HTTPS_API_TEST) \
438 $(HTTPS_API_TIMEOUT_TEST) \ 450 $(HTTPS_API_TIMEOUT_TEST) \
439 $(WLAN_API_TEST) \ 451 $(WLAN_API_TEST) \
452 $(BT_API_TEST) \
440 test_transport_api_multi \ 453 test_transport_api_multi \
441 test_transport_blacklisting_no_bl \ 454 test_transport_blacklisting_no_bl \
442 test_transport_blacklisting_outbound_bl_full \ 455 test_transport_blacklisting_outbound_bl_full \
@@ -456,6 +469,8 @@ TESTS = \
456 $(HTTPS_REL_TEST) \ 469 $(HTTPS_REL_TEST) \
457 $(WLAN_REL_TEST) \ 470 $(WLAN_REL_TEST) \
458 $(WLAN_UREL_TEST) \ 471 $(WLAN_UREL_TEST) \
472 $(BT_REL_TEST) \
473 $(BT_UREL_TEST) \
459 test_quota_compliance_tcp \ 474 test_quota_compliance_tcp \
460 test_quota_compliance_tcp_asymmetric \ 475 test_quota_compliance_tcp_asymmetric \
461 test_quota_compliance_udp \ 476 test_quota_compliance_udp \
@@ -606,6 +621,14 @@ test_plugin_wlan_LDADD = \
606 $(top_builddir)/src/util/libgnunetutil.la \ 621 $(top_builddir)/src/util/libgnunetutil.la \
607 $(top_builddir)/src/transport/libgnunettransporttesting.la 622 $(top_builddir)/src/transport/libgnunettransporttesting.la
608 623
624test_plugin_bluetooth_SOURCES = \
625 test_plugin_transport.c
626test_plugin_bluetooth_LDADD = \
627 $(top_builddir)/src/transport/libgnunettransport.la \
628 $(top_builddir)/src/statistics/libgnunetstatistics.la \
629 $(top_builddir)/src/hello/libgnunethello.la \
630 $(top_builddir)/src/util/libgnunetutil.la \
631 $(top_builddir)/src/transport/libgnunettransporttesting.la
609 632
610test_http_common_SOURCES = \ 633test_http_common_SOURCES = \
611 test_http_common.c plugin_transport_http_common.c 634 test_http_common.c plugin_transport_http_common.c
@@ -766,6 +789,14 @@ test_transport_api_reliability_wlan_LDADD = \
766 $(top_builddir)/src/transport/libgnunettransport.la \ 789 $(top_builddir)/src/transport/libgnunettransport.la \
767 $(top_builddir)/src/hello/libgnunethello.la \ 790 $(top_builddir)/src/hello/libgnunethello.la \
768 $(top_builddir)/src/util/libgnunetutil.la \ 791 $(top_builddir)/src/util/libgnunetutil.la \
792 $(top_builddir)/src/transport/libgnunettransporttesting.la
793
794test_transport_api_reliability_bluetooth_SOURCES = \
795 test_transport_api_reliability.c
796test_transport_api_reliability_bluetooth_LDADD = \
797 $(top_builddir)/src/transport/libgnunettransport.la \
798 $(top_builddir)/src/hello/libgnunethello.la \
799 $(top_builddir)/src/util/libgnunetutil.la \
769 $(top_builddir)/src/transport/libgnunettransporttesting.la 800 $(top_builddir)/src/transport/libgnunettransporttesting.la
770 801
771test_transport_api_unreliability_wlan_SOURCES = \ 802test_transport_api_unreliability_wlan_SOURCES = \
@@ -776,6 +807,14 @@ test_transport_api_unreliability_wlan_LDADD = \
776 $(top_builddir)/src/util/libgnunetutil.la \ 807 $(top_builddir)/src/util/libgnunetutil.la \
777 $(top_builddir)/src/transport/libgnunettransporttesting.la 808 $(top_builddir)/src/transport/libgnunettransporttesting.la
778 809
810test_transport_api_unreliability_bluetooth_SOURCES = \
811 test_transport_api_unreliability.c
812test_transport_api_unreliability_bluetooth_LDADD = \
813 $(top_builddir)/src/transport/libgnunettransport.la \
814 $(top_builddir)/src/hello/libgnunethello.la \
815 $(top_builddir)/src/util/libgnunetutil.la \
816 $(top_builddir)/src/transport/libgnunettransporttesting.la
817
779test_transport_api_udp_SOURCES = \ 818test_transport_api_udp_SOURCES = \
780 test_transport_api.c 819 test_transport_api.c
781test_transport_api_udp_LDADD = \ 820test_transport_api_udp_LDADD = \
@@ -933,6 +972,18 @@ test_transport_api_wlan_LDADD = \
933 $(top_builddir)/src/transport/libgnunettransporttesting.la 972 $(top_builddir)/src/transport/libgnunettransporttesting.la
934endif 973endif
935 974
975if LINUX
976if HAVE_LIBBLUETOOTH
977test_transport_api_bluetooth_SOURCES = \
978 test_transport_api.c
979test_transport_api_bluetooth_LDADD = \
980 $(top_builddir)/src/transport/libgnunettransport.la \
981 $(top_builddir)/src/hello/libgnunethello.la \
982 $(top_builddir)/src/util/libgnunetutil.la \
983 $(top_builddir)/src/transport/libgnunettransporttesting.la
984endif
985endif
986
936test_quota_compliance_tcp_SOURCES = \ 987test_quota_compliance_tcp_SOURCES = \
937 test_quota_compliance.c 988 test_quota_compliance.c
938test_quota_compliance_tcp_LDADD = \ 989test_quota_compliance_tcp_LDADD = \
@@ -989,6 +1040,22 @@ test_quota_compliance_wlan_asymmetric_LDADD = \
989 $(top_builddir)/src/util/libgnunetutil.la \ 1040 $(top_builddir)/src/util/libgnunetutil.la \
990 $(top_builddir)/src/transport/libgnunettransporttesting.la 1041 $(top_builddir)/src/transport/libgnunettransporttesting.la
991 1042
1043test_quota_compliance_bluetooth_SOURCES = \
1044 test_quota_compliance.c
1045test_quota_compliance_bluetooth_LDADD = \
1046 $(top_builddir)/src/transport/libgnunettransport.la \
1047 $(top_builddir)/src/hello/libgnunethello.la \
1048 $(top_builddir)/src/util/libgnunetutil.la \
1049 $(top_builddir)/src/transport/libgnunettransporttesting.la
1050
1051test_quota_compliance_bluetooth_asymmetric_SOURCES = \
1052 test_quota_compliance.c
1053test_quota_compliance_bluetooth_asymmetric_LDADD = \
1054 $(top_builddir)/src/transport/libgnunettransport.la \
1055 $(top_builddir)/src/hello/libgnunethello.la \
1056 $(top_builddir)/src/util/libgnunetutil.la \
1057 $(top_builddir)/src/transport/libgnunettransporttesting.la
1058
992test_transport_api_multi_SOURCES = \ 1059test_transport_api_multi_SOURCES = \
993 test_transport_api.c 1060 test_transport_api.c
994test_transport_api_multi_LDADD = \ 1061test_transport_api_multi_LDADD = \
@@ -1018,6 +1085,8 @@ test_quota_compliance_unix_peer1.conf\
1018test_quota_compliance_unix_peer2.conf\ 1085test_quota_compliance_unix_peer2.conf\
1019test_quota_compliance_wlan_peer1.conf\ 1086test_quota_compliance_wlan_peer1.conf\
1020test_quota_compliance_wlan_peer2.conf\ 1087test_quota_compliance_wlan_peer2.conf\
1088test_quota_compliance_bluetooth_peer1.conf\
1089test_quota_compliance_bluetooth_peer2.conf\
1021test_quota_compliance_http_asymmetric_peer1.conf\ 1090test_quota_compliance_http_asymmetric_peer1.conf\
1022test_quota_compliance_http_asymmetric_peer2.conf\ 1091test_quota_compliance_http_asymmetric_peer2.conf\
1023test_quota_compliance_https_asymmetric_peer1.conf\ 1092test_quota_compliance_https_asymmetric_peer1.conf\
@@ -1028,6 +1097,8 @@ test_quota_compliance_unix_asymmetric_peer1.conf\
1028test_quota_compliance_unix_asymmetric_peer2.conf\ 1097test_quota_compliance_unix_asymmetric_peer2.conf\
1029test_quota_compliance_wlan_asymmetric_peer1.conf\ 1098test_quota_compliance_wlan_asymmetric_peer1.conf\
1030test_quota_compliance_wlan_asymmetric_peer2.conf\ 1099test_quota_compliance_wlan_asymmetric_peer2.conf\
1100test_quota_compliance_bluetooth_asymmetric_peer1.conf\
1101test_quota_compliance_bluetooth_asymmetric_peer2.conf\
1031test_transport_api_data.conf\ 1102test_transport_api_data.conf\
1032test_transport_api_http_peer1.conf\ 1103test_transport_api_http_peer1.conf\
1033test_transport_api_http_peer2.conf\ 1104test_transport_api_http_peer2.conf\
@@ -1049,6 +1120,8 @@ test_transport_api_reliability_tcp_peer1.conf\
1049test_transport_api_reliability_tcp_peer2.conf\ 1120test_transport_api_reliability_tcp_peer2.conf\
1050test_transport_api_reliability_wlan_peer1.conf\ 1121test_transport_api_reliability_wlan_peer1.conf\
1051test_transport_api_reliability_wlan_peer2.conf\ 1122test_transport_api_reliability_wlan_peer2.conf\
1123test_transport_api_reliability_bluetooth_peer1.conf\
1124test_transport_api_reliability_bluetooth_peer2.conf\
1052test_transport_api_bidirectional_connect_peer1.conf\ 1125test_transport_api_bidirectional_connect_peer1.conf\
1053test_transport_api_bidirectional_connect_peer2.conf\ 1126test_transport_api_bidirectional_connect_peer2.conf\
1054test_transport_api_manipulation_send_tcp_peer1.conf\ 1127test_transport_api_manipulation_send_tcp_peer1.conf\
@@ -1077,8 +1150,12 @@ test_transport_api_unreliability_unix_peer1.conf\
1077test_transport_api_unreliability_unix_peer2.conf\ 1150test_transport_api_unreliability_unix_peer2.conf\
1078test_transport_api_unreliability_wlan_peer1.conf\ 1151test_transport_api_unreliability_wlan_peer1.conf\
1079test_transport_api_unreliability_wlan_peer2.conf\ 1152test_transport_api_unreliability_wlan_peer2.conf\
1153test_transport_api_unreliability_bluetooth_peer1.conf\
1154test_transport_api_unreliability_bluetooth_peer2.conf\
1080test_transport_api_wlan_peer1.conf\ 1155test_transport_api_wlan_peer1.conf\
1081test_transport_api_wlan_peer2.conf\ 1156test_transport_api_wlan_peer2.conf\
1157test_transport_api_bluetooth_peer1.conf\
1158test_transport_api_bluetooth_peer2.conf\
1082test_transport_defaults.conf\ 1159test_transport_defaults.conf\
1083test_transport_startonly.conf\ 1160test_transport_startonly.conf\
1084test_transport_api_disconnect_tcp_peer1.conf\ 1161test_transport_api_disconnect_tcp_peer1.conf\