aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2019-12-12 21:16:49 +0100
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2019-12-12 21:16:49 +0100
commitd554b80d09b6e4c8b7fe229ceb95597e9d91291e (patch)
tree87d9f359a399d3f13d59c2c4aa1ff8b7a78a86d4 /src/transport/Makefile.am
parenta9fadbb9d0012cd7b65bd0c5cf3196f1fc54d3e8 (diff)
downloadgnunet-d554b80d09b6e4c8b7fe229ceb95597e9d91291e.tar.gz
gnunet-d554b80d09b6e4c8b7fe229ceb95597e9d91291e.zip
make udp transport experimental p2
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am68
1 files changed, 24 insertions, 44 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 5069e95b6..ae77899a0 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -369,9 +369,6 @@ gnunet_service_tng_LDADD = \
369 369
370plugin_LTLIBRARIES = \ 370plugin_LTLIBRARIES = \
371 libgnunet_plugin_transport_tcp.la \ 371 libgnunet_plugin_transport_tcp.la \
372if HAVE_EXPERIMENTAL
373 libgnunet_plugin_transport_udp.la \
374endif
375 $(UNIX_PLUGIN_LA) \ 372 $(UNIX_PLUGIN_LA) \
376 $(HTTP_CLIENT_PLUGIN_LA) \ 373 $(HTTP_CLIENT_PLUGIN_LA) \
377 $(HTTPS_CLIENT_PLUGIN_LA) \ 374 $(HTTPS_CLIENT_PLUGIN_LA) \
@@ -380,6 +377,10 @@ endif
380 $(WLAN_PLUGIN_LA) \ 377 $(WLAN_PLUGIN_LA) \
381 $(BT_PLUGIN_LA) 378 $(BT_PLUGIN_LA)
382 379
380if HAVE_EXPERIMENTAL
381plugin_LTLIBRARIES += libgnunet_plugin_transport_udp.la
382endif
383
383# Note: real plugins of course need to be added 384# Note: real plugins of course need to be added
384# to the plugin_LTLIBRARIES above 385# to the plugin_LTLIBRARIES above
385noinst_LTLIBRARIES = \ 386noinst_LTLIBRARIES = \
@@ -519,19 +520,12 @@ libgnunet_plugin_transport_https_server_la_LDFLAGS = \
519libgnunet_plugin_transport_https_server_la_CFLAGS = \ 520libgnunet_plugin_transport_https_server_la_CFLAGS = \
520 $(MHD_CFLAGS) $(AM_CFLAGS) -DBUILD_HTTPS 521 $(MHD_CFLAGS) $(AM_CFLAGS) -DBUILD_HTTPS
521 522
522
523if HAVE_TESTING 523if HAVE_TESTING
524check_PROGRAMS = \ 524check_PROGRAMS = \
525 test_transport_address_switch_tcp \ 525 test_transport_address_switch_tcp \
526if HAVE_EXPERIMENTAL
527 test_transport_address_switch_udp \
528endif
529 test_transport_testing_startstop \ 526 test_transport_testing_startstop \
530 test_transport_testing_restart \ 527 test_transport_testing_restart \
531 test_plugin_tcp \ 528 test_plugin_tcp \
532if HAVE_EXPERIMENTAL
533 test_plugin_udp \
534endif
535 $(UNIX_TEST) \ 529 $(UNIX_TEST) \
536 $(WLAN_PLUGIN_TEST) \ 530 $(WLAN_PLUGIN_TEST) \
537 $(BT_PLUGIN_TEST) \ 531 $(BT_PLUGIN_TEST) \
@@ -548,16 +542,9 @@ endif
548 test_transport_api_timeout_tcp \ 542 test_transport_api_timeout_tcp \
549 test_transport_api_limited_sockets_tcp \ 543 test_transport_api_limited_sockets_tcp \
550 test_transport_api_tcp_nat \ 544 test_transport_api_tcp_nat \
551if HAVE_EXPERIMENTAL
552 test_transport_api_udp \
553 test_transport_api_timeout_udp \
554endif
555 $(UNIX_PLUGIN_TEST) \ 545 $(UNIX_PLUGIN_TEST) \
556 $(UNIX_PLUGIN_TIMEOUT_TEST) \ 546 $(UNIX_PLUGIN_TIMEOUT_TEST) \
557 $(UNIX_API_ABSTRACT_TEST) \ 547 $(UNIX_API_ABSTRACT_TEST) \
558if HAVE_EXPERIMENTAL
559 test_transport_api_udp_nat \
560endif
561 $(HTTP_API_TEST) \ 548 $(HTTP_API_TEST) \
562 $(HTTP_REVERSE_API_TEST) \ 549 $(HTTP_REVERSE_API_TEST) \
563 $(HTTP_API_TIMEOUT_TEST) \ 550 $(HTTP_API_TIMEOUT_TEST) \
@@ -582,9 +569,6 @@ endif
582 test_transport_api_manipulation_cfg \ 569 test_transport_api_manipulation_cfg \
583 test_transport_api_reliability_tcp \ 570 test_transport_api_reliability_tcp \
584 test_transport_api_reliability_tcp_nat \ 571 test_transport_api_reliability_tcp_nat \
585if HAVE_EXPERIMENTAL
586 test_transport_api_reliability_udp \
587endif
588 $(UNIX_REL_TEST) \ 572 $(UNIX_REL_TEST) \
589 $(HTTP_REL_TEST) \ 573 $(HTTP_REL_TEST) \
590 $(HTTPS_REL_TEST) \ 574 $(HTTPS_REL_TEST) \
@@ -594,9 +578,6 @@ endif
594 $(BT_UREL_TEST) \ 578 $(BT_UREL_TEST) \
595 test_quota_compliance_tcp \ 579 test_quota_compliance_tcp \
596 test_quota_compliance_tcp_asymmetric \ 580 test_quota_compliance_tcp_asymmetric \
597if HAVE_EXPERIMENTAL
598 test_quota_compliance_udp \
599endif
600 $(UNIX_QUOTA_TEST) \ 581 $(UNIX_QUOTA_TEST) \
601 $(HTTP_QUOTA_TEST) \ 582 $(HTTP_QUOTA_TEST) \
602 $(HTTPS_QUOTA_TEST) \ 583 $(HTTPS_QUOTA_TEST) \
@@ -608,23 +589,27 @@ test_transport_api_slow_ats
608endif 589endif
609check_PROGRAMS += \ 590check_PROGRAMS += \
610test_communicator_unix 591test_communicator_unix
592if HAVE_EXPERIMENTAL
593check_PROGRAMS += \
594 test_transport_address_switch_udp \
595 test_plugin_udp \
596 test_transport_api_udp \
597 test_transport_api_timeout_udp \
598 test_transport_api_udp_nat \
599 test_transport_api_reliability_udp \
600 test_quota_compliance_udp
601endif
611endif 602endif
612 603
613if ENABLE_TEST_RUN 604if ENABLE_TEST_RUN
614AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME; 605AM_TESTS_ENVIRONMENT=export GNUNET_PREFIX=$${GNUNET_PREFIX:-@libdir@};export PATH=$${GNUNET_PREFIX:-@prefix@}/bin:$$PATH;unset XDG_DATA_HOME;unset XDG_CONFIG_HOME;
615TESTS = \ 606TESTS = \
616 test_transport_address_switch_tcp \ 607 test_transport_address_switch_tcp \
617if HAVE_EXPERIMENTAL
618 test_transport_address_switch_udp \
619endif
620 $(HTTP_SWITCH) \ 608 $(HTTP_SWITCH) \
621 $(HTTPS_SWITCH) \ 609 $(HTTPS_SWITCH) \
622 test_transport_testing_startstop \ 610 test_transport_testing_startstop \
623 test_transport_testing_restart \ 611 test_transport_testing_restart \
624 test_plugin_tcp \ 612 test_plugin_tcp \
625if HAVE_EXPERIMENTAL
626 test_plugin_udp \
627endif
628 $(UNIX_TEST) \ 613 $(UNIX_TEST) \
629 $(WLAN_PLUGIN_TEST) \ 614 $(WLAN_PLUGIN_TEST) \
630 $(BT_PLUGIN_TEST) \ 615 $(BT_PLUGIN_TEST) \
@@ -635,14 +620,8 @@ endif
635 test_transport_api_restart_2peers \ 620 test_transport_api_restart_2peers \
636 test_transport_api_limited_sockets_tcp \ 621 test_transport_api_limited_sockets_tcp \
637 test_transport_api_tcp_nat \ 622 test_transport_api_tcp_nat \
638if HAVE_EXPERIMENTAL
639 test_transport_api_udp \
640endif
641 $(UNIX_PLUGIN_TEST) \ 623 $(UNIX_PLUGIN_TEST) \
642 $(UNIX_API_ABSTRACT_TEST) \ 624 $(UNIX_API_ABSTRACT_TEST) \
643if HAVE_EXPERIMENTAL
644 test_transport_api_udp_nat \
645endif
646 $(HTTP_API_TEST) \ 625 $(HTTP_API_TEST) \
647 $(HTTPS_API_TEST) \ 626 $(HTTPS_API_TEST) \
648 $(WLAN_API_TEST) \ 627 $(WLAN_API_TEST) \
@@ -660,9 +639,6 @@ endif
660 test_transport_api_manipulation_cfg \ 639 test_transport_api_manipulation_cfg \
661 test_transport_api_reliability_tcp \ 640 test_transport_api_reliability_tcp \
662 test_transport_api_reliability_tcp_nat \ 641 test_transport_api_reliability_tcp_nat \
663if HAVE_EXPERIMENTAL
664 test_transport_api_reliability_udp \
665endif
666 $(UNIX_REL_TEST) \ 642 $(UNIX_REL_TEST) \
667 $(HTTP_REL_TEST) \ 643 $(HTTP_REL_TEST) \
668 $(HTTPS_REL_TEST) \ 644 $(HTTPS_REL_TEST) \
@@ -672,16 +648,10 @@ endif
672 $(BT_UREL_TEST) \ 648 $(BT_UREL_TEST) \
673 test_quota_compliance_tcp \ 649 test_quota_compliance_tcp \
674 test_quota_compliance_tcp_asymmetric \ 650 test_quota_compliance_tcp_asymmetric \
675if HAVE_EXPERIMENTAL
676 test_quota_compliance_udp \
677endif
678 $(UNIX_QUOTA_TEST) \ 651 $(UNIX_QUOTA_TEST) \
679 $(HTTP_QUOTA_TEST) \ 652 $(HTTP_QUOTA_TEST) \
680 $(HTTPS_QUOTA_TEST) \ 653 $(HTTPS_QUOTA_TEST) \
681 test_transport_api_timeout_tcp \ 654 test_transport_api_timeout_tcp \
682if HAVE_EXPERIMENTAL
683 test_transport_api_timeout_udp \
684endif
685 $(UNIX_PLUGIN_TIMEOUT_TEST) \ 655 $(UNIX_PLUGIN_TIMEOUT_TEST) \
686 $(HTTP_API_TIMEOUT_TEST) \ 656 $(HTTP_API_TIMEOUT_TEST) \
687 $(HTTPS_API_TIMEOUT_TEST) \ 657 $(HTTPS_API_TIMEOUT_TEST) \
@@ -691,6 +661,16 @@ if HAVE_GETOPT_BINARY
691TESTS += \ 661TESTS += \
692test_transport_api_slow_ats 662test_transport_api_slow_ats
693endif 663endif
664if HAVE_EXPERIMENTAL
665TESTS += \
666 test_transport_address_switch_udp \
667 test_plugin_udp \
668 test_transport_api_udp \
669 test_transport_api_timeout_udp \
670 test_transport_api_udp_nat \
671 test_transport_api_reliability_udp \
672 test_quota_compliance_udp
673endif
694endif 674endif
695 675
696test_transport_testing_startstop_SOURCES = \ 676test_transport_testing_startstop_SOURCES = \