aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authort3sserakt <t3ss@posteo.de>2021-09-20 09:00:09 +0200
committert3sserakt <t3ss@posteo.de>2021-09-20 09:00:09 +0200
commitd5df403e64bbde52c5436165eee5231a1b2f876b (patch)
tree3a4efc07dc5d2576a9f6656de58764aa9840d856 /src/transport/Makefile.am
parent9bdaa1f9b21b324963fe0f41311ae6d9c0948946 (diff)
downloadgnunet-d5df403e64bbde52c5436165eee5231a1b2f876b.tar.gz
gnunet-d5df403e64bbde52c5436165eee5231a1b2f876b.zip
- added new udp backchannel testcase, changed netjail script to have port forwarding into subnets, master loop is no configured completely by topology config file, connect cmd reads topology file to connect to configured nodes
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am37
1 files changed, 35 insertions, 2 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index 561ac5e60..c8290628f 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -162,8 +162,10 @@ libgnunettransporttesting_la_LDFLAGS = \
162libgnunettransporttesting2_la_SOURCES = \ 162libgnunettransporttesting2_la_SOURCES = \
163 transport_api_cmd_connecting_peers.c \ 163 transport_api_cmd_connecting_peers.c \
164 transport_api_cmd_connecting_peers_v2.c \ 164 transport_api_cmd_connecting_peers_v2.c \
165 transport_api_cmd_connecting_peers_v3.c \
165 transport_api_cmd_start_peer.c \ 166 transport_api_cmd_start_peer.c \
166 transport_api_cmd_start_peer_v2.c \ 167 transport_api_cmd_start_peer_v2.c \
168 transport_api_cmd_start_peer_v3.c \
167 transport_api_cmd_stop_peer.c \ 169 transport_api_cmd_stop_peer.c \
168 transport_api_cmd_send_simple.c \ 170 transport_api_cmd_send_simple.c \
169 transport_api_cmd_send_simple_v2.c \ 171 transport_api_cmd_send_simple_v2.c \
@@ -394,7 +396,25 @@ plugin_LTLIBRARIES = \
394 $(WLAN_PLUGIN_LA) \ 396 $(WLAN_PLUGIN_LA) \
395 $(BT_PLUGIN_LA) \ 397 $(BT_PLUGIN_LA) \
396 libgnunet_test_transport_plugin_cmd_simple_send.la \ 398 libgnunet_test_transport_plugin_cmd_simple_send.la \
397 libgnunet_test_transport_plugin_cmd_simple_send_v2.la 399 libgnunet_test_transport_plugin_cmd_simple_send_v2.la \
400 libgnunet_test_transport_plugin_cmd_udp_backchannel.la
401
402libgnunet_test_transport_plugin_cmd_udp_backchannel_la_SOURCES = \
403 test_transport_plugin_cmd_udp_backchannel.c
404libgnunet_test_transport_plugin_cmd_udp_backchannel_la_LIBADD = \
405 libgnunettransporttesting2.la \
406 libgnunettransportapplication.la \
407 libgnunettransportcore.la \
408 $(top_builddir)/src/testing/libgnunettesting.la \
409 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
410 $(top_builddir)/src/statistics/libgnunetstatistics.la \
411 $(top_builddir)/src/hello/libgnunethello.la \
412 $(top_builddir)/src/ats/libgnunetats.la \
413 $(top_builddir)/src/arm/libgnunetarm.la \
414 $(top_builddir)/src/util/libgnunetutil.la \
415 $(LTLIBINTL)
416libgnunet_test_transport_plugin_cmd_simple_send_la_LDFLAGS = \
417 $(GN_PLUGIN_LDFLAGS)
398 418
399libgnunet_test_transport_plugin_cmd_simple_send_la_SOURCES = \ 419libgnunet_test_transport_plugin_cmd_simple_send_la_SOURCES = \
400 test_transport_plugin_cmd_simple_send.c 420 test_transport_plugin_cmd_simple_send.c
@@ -578,6 +598,7 @@ if HAVE_TESTING
578check_PROGRAMS = \ 598check_PROGRAMS = \
579 test_transport_simple_send \ 599 test_transport_simple_send \
580 test_transport_simple_send_v2 \ 600 test_transport_simple_send_v2 \
601 test_transport_start_with_config \
581 test_transport_address_switch_tcp \ 602 test_transport_address_switch_tcp \
582 test_transport_testing_startstop \ 603 test_transport_testing_startstop \
583 test_transport_testing_restart \ 604 test_transport_testing_restart \
@@ -728,6 +749,7 @@ if HAVE_EXPERIMENTAL
728TESTS += \ 749TESTS += \
729 test_transport_simple_send \ 750 test_transport_simple_send \
730 test_transport_simple_send_v2 \ 751 test_transport_simple_send_v2 \
752 test_transport_start_with_config \
731 test_transport_address_switch_udp \ 753 test_transport_address_switch_udp \
732 test_plugin_udp \ 754 test_plugin_udp \
733 test_transport_api_udp \ 755 test_transport_api_udp \
@@ -747,7 +769,18 @@ endif
747 769
748check_SCRIPTS= \ 770check_SCRIPTS= \
749 test_transport_simple_send.sh \ 771 test_transport_simple_send.sh \
750 test_transport_simple_send_v2.sh 772 test_transport_simple_send_v2.sh \
773 test_transport_udp_backchannel.sh
774
775test_transport_start_with_config_SOURCES = \
776 test_transport_start_with_config.c
777test_transport_start_with_config_LDADD = \
778 $(top_builddir)/src/testing/libgnunettesting.la \
779 $(top_builddir)/src/util/libgnunetutil.la \
780 $(top_builddir)/src/testbed/libgnunettestbed.la \
781 $(top_builddir)/src/hello/libgnunethello.la \
782 libgnunettransportcore.la \
783 libgnunettransporttesting2.la
751 784
752test_transport_simple_send_SOURCES = \ 785test_transport_simple_send_SOURCES = \
753 test_transport_simple_send.c 786 test_transport_simple_send.c