aboutsummaryrefslogtreecommitdiff
path: root/src/transport/Makefile.am
diff options
context:
space:
mode:
authort3sserakt <t3ss@posteo.de>2021-10-14 16:39:24 +0200
committert3sserakt <t3ss@posteo.de>2021-10-14 16:39:24 +0200
commitd64ac269856744b9bab170964e1d6f36896ecc55 (patch)
treeed5aa79b91fe3cf9388433a5611581b7ce3b846c /src/transport/Makefile.am
parent003910fc614cd347919707d1bf3c37a939978459 (diff)
downloadgnunet-d64ac269856744b9bab170964e1d6f36896ecc55.tar.gz
gnunet-d64ac269856744b9bab170964e1d6f36896ecc55.zip
removed versioned artefacts with v2 and v3. changes to reflect the changes in testing_api_loop.c
Diffstat (limited to 'src/transport/Makefile.am')
-rw-r--r--src/transport/Makefile.am48
1 files changed, 0 insertions, 48 deletions
diff --git a/src/transport/Makefile.am b/src/transport/Makefile.am
index a539f3f25..0df422976 100644
--- a/src/transport/Makefile.am
+++ b/src/transport/Makefile.am
@@ -159,14 +159,9 @@ libgnunettransporttesting_la_LDFLAGS = \
159 159
160libgnunettransporttesting2_la_SOURCES = \ 160libgnunettransporttesting2_la_SOURCES = \
161 transport_api_cmd_connecting_peers.c \ 161 transport_api_cmd_connecting_peers.c \
162 transport_api_cmd_connecting_peers_v2.c \
163 transport_api_cmd_connecting_peers_v3.c \
164 transport_api_cmd_start_peer.c \ 162 transport_api_cmd_start_peer.c \
165 transport_api_cmd_start_peer_v2.c \
166 transport_api_cmd_start_peer_v3.c \
167 transport_api_cmd_stop_peer.c \ 163 transport_api_cmd_stop_peer.c \
168 transport_api_cmd_send_simple.c \ 164 transport_api_cmd_send_simple.c \
169 transport_api_cmd_send_simple_v2.c \
170 transport-testing2.c transport-testing2.h \ 165 transport-testing2.c transport-testing2.h \
171 transport-testing-cmds.h \ 166 transport-testing-cmds.h \
172 transport-testing-filenames2.c \ 167 transport-testing-filenames2.c \
@@ -394,7 +389,6 @@ plugin_LTLIBRARIES = \
394 $(WLAN_PLUGIN_LA) \ 389 $(WLAN_PLUGIN_LA) \
395 $(BT_PLUGIN_LA) \ 390 $(BT_PLUGIN_LA) \
396 libgnunet_test_transport_plugin_cmd_simple_send.la \ 391 libgnunet_test_transport_plugin_cmd_simple_send.la \
397 libgnunet_test_transport_plugin_cmd_simple_send_v2.la \
398 libgnunet_test_transport_plugin_cmd_udp_backchannel.la 392 libgnunet_test_transport_plugin_cmd_udp_backchannel.la
399 393
400libgnunet_test_transport_plugin_cmd_udp_backchannel_la_SOURCES = \ 394libgnunet_test_transport_plugin_cmd_udp_backchannel_la_SOURCES = \
@@ -431,23 +425,6 @@ libgnunet_test_transport_plugin_cmd_simple_send_la_LIBADD = \
431libgnunet_test_transport_plugin_cmd_simple_send_la_LDFLAGS = \ 425libgnunet_test_transport_plugin_cmd_simple_send_la_LDFLAGS = \
432 $(GN_PLUGIN_LDFLAGS) 426 $(GN_PLUGIN_LDFLAGS)
433 427
434libgnunet_test_transport_plugin_cmd_simple_send_v2_la_SOURCES = \
435 test_transport_plugin_cmd_simple_send_v2.c
436libgnunet_test_transport_plugin_cmd_simple_send_v2_la_LIBADD = \
437 libgnunettransporttesting2.la \
438 libgnunettransportapplication.la \
439 libgnunettransportcore.la \
440 $(top_builddir)/src/testing/libgnunettesting.la \
441 $(top_builddir)/src/peerstore/libgnunetpeerstore.la \
442 $(top_builddir)/src/statistics/libgnunetstatistics.la \
443 $(top_builddir)/src/hello/libgnunethello.la \
444 $(top_builddir)/src/ats/libgnunetats.la \
445 $(top_builddir)/src/arm/libgnunetarm.la \
446 $(top_builddir)/src/util/libgnunetutil.la \
447 $(LTLIBINTL)
448libgnunet_test_transport_plugin_cmd_simple_send_v2_la_LDFLAGS = \
449 $(GN_PLUGIN_LDFLAGS)
450
451if HAVE_EXPERIMENTAL 428if HAVE_EXPERIMENTAL
452plugin_LTLIBRARIES += \ 429plugin_LTLIBRARIES += \
453 libgnunet_plugin_transport_udp.la 430 libgnunet_plugin_transport_udp.la
@@ -593,8 +570,6 @@ libgnunet_plugin_transport_https_server_la_CFLAGS = \
593 $(MHD_CFLAGS) $(AM_CFLAGS) -DBUILD_HTTPS 570 $(MHD_CFLAGS) $(AM_CFLAGS) -DBUILD_HTTPS
594 571
595check_PROGRAMS = \ 572check_PROGRAMS = \
596 test_transport_simple_send \
597 test_transport_simple_send_v2 \
598 test_transport_start_with_config \ 573 test_transport_start_with_config \
599 test_transport_address_switch_tcp \ 574 test_transport_address_switch_tcp \
600 test_transport_testing_startstop \ 575 test_transport_testing_startstop \
@@ -743,8 +718,6 @@ test_transport_api_slow_ats
743endif 718endif
744if HAVE_EXPERIMENTAL 719if HAVE_EXPERIMENTAL
745TESTS += \ 720TESTS += \
746 test_transport_simple_send \
747 test_transport_simple_send_v2 \
748 test_transport_start_with_config \ 721 test_transport_start_with_config \
749 test_transport_address_switch_udp \ 722 test_transport_address_switch_udp \
750 test_plugin_udp \ 723 test_plugin_udp \
@@ -765,7 +738,6 @@ endif
765 738
766check_SCRIPTS= \ 739check_SCRIPTS= \
767 test_transport_simple_send.sh \ 740 test_transport_simple_send.sh \
768 test_transport_simple_send_v2.sh \
769 test_transport_udp_backchannel.sh 741 test_transport_udp_backchannel.sh
770 742
771test_transport_start_with_config_SOURCES = \ 743test_transport_start_with_config_SOURCES = \
@@ -778,26 +750,6 @@ test_transport_start_with_config_LDADD = \
778 libgnunettransportcore.la \ 750 libgnunettransportcore.la \
779 libgnunettransporttesting2.la 751 libgnunettransporttesting2.la
780 752
781test_transport_simple_send_SOURCES = \
782 test_transport_simple_send.c
783test_transport_simple_send_LDADD = \
784 $(top_builddir)/src/testing/libgnunettesting.la \
785 $(top_builddir)/src/util/libgnunetutil.la \
786 $(top_builddir)/src/testbed/libgnunettestbed.la \
787 $(top_builddir)/src/hello/libgnunethello.la \
788 libgnunettransportcore.la \
789 libgnunettransporttesting2.la
790
791test_transport_simple_send_v2_SOURCES = \
792 test_transport_simple_send_v2.c
793test_transport_simple_send_v2_LDADD = \
794 $(top_builddir)/src/testing/libgnunettesting.la \
795 $(top_builddir)/src/util/libgnunetutil.la \
796 $(top_builddir)/src/testbed/libgnunettestbed.la \
797 $(top_builddir)/src/hello/libgnunethello.la \
798 libgnunettransportcore.la \
799 libgnunettransporttesting2.la
800
801test_transport_testing_startstop_SOURCES = \ 753test_transport_testing_startstop_SOURCES = \
802 test_transport_testing_startstop.c 754 test_transport_testing_startstop.c
803test_transport_testing_startstop_LDADD = \ 755test_transport_testing_startstop_LDADD = \