aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorJonathan Buchanan <jonathan.russ.buchanan@gmail.com>2020-08-26 14:49:02 -0400
committerJonathan Buchanan <jonathan.russ.buchanan@gmail.com>2020-08-26 14:49:02 -0400
commit49d74db2e9bd8418f15b560e36e1f27661f65361 (patch)
tree48612892b643b0abbc63d99c8e2bcacfc1d6e396 /src/util/Makefile.am
parente36180a17c8da8d3639f42924ce56c11fec1fddd (diff)
downloadgnunet-49d74db2e9bd8418f15b560e36e1f27661f65361.tar.gz
gnunet-49d74db2e9bd8418f15b560e36e1f27661f65361.zip
use (and "GNUnet-ify") libyuarel as a basepoint for uri parsing
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 83b3b9c3d..c5059bbb1 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -96,6 +96,7 @@ libgnunetutil_la_SOURCES = \
96 strings.c \ 96 strings.c \
97 time.c \ 97 time.c \
98 tun.c \ 98 tun.c \
99 uri.c \
99 speedup.c speedup.h \ 100 speedup.c speedup.h \
100 proc_compat.c 101 proc_compat.c
101 102
@@ -302,6 +303,7 @@ check_PROGRAMS = \
302 test_speedup \ 303 test_speedup \
303 test_time \ 304 test_time \
304 test_tun \ 305 test_tun \
306 test_uri \
305 $(BENCHMARKS) \ 307 $(BENCHMARKS) \
306 test_os_start_process \ 308 test_os_start_process \
307 test_common_logging_runtime_loglevels 309 test_common_logging_runtime_loglevels
@@ -573,6 +575,11 @@ test_speedup_SOURCES = \
573test_speedup_LDADD = \ 575test_speedup_LDADD = \
574 libgnunetutil.la 576 libgnunetutil.la
575 577
578test_uri_SOURCES = \
579 test_uri.c
580test_uri_LDADD = \
581 libgnunetutil.la
582
576perf_crypto_hash_SOURCES = \ 583perf_crypto_hash_SOURCES = \
577 perf_crypto_hash.c 584 perf_crypto_hash.c
578perf_crypto_hash_LDADD = \ 585perf_crypto_hash_LDADD = \