aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorSchanzenbach, Martin <mschanzenbach@posteo.de>2020-01-06 16:46:32 +0900
committerSchanzenbach, Martin <mschanzenbach@posteo.de>2020-01-06 16:46:32 +0900
commit2111817ee190b99561f067277c3b081da27e2afa (patch)
tree15e5cc2f445f7f72d4ffdb23ea9a53c9f00ef92c /src/util/Makefile.am
parente7b3a8cdf0d10517fbfdcd247198ef6d36d5435e (diff)
downloadgnunet-2111817ee190b99561f067277c3b081da27e2afa.tar.gz
gnunet-2111817ee190b99561f067277c3b081da27e2afa.zip
add test for ecdsa ecdh
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 0f6251f96..387f22a9f 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -298,6 +298,7 @@ check_PROGRAMS = \
298 test_crypto_eddsa \ 298 test_crypto_eddsa \
299 test_crypto_ecdhe \ 299 test_crypto_ecdhe \
300 test_crypto_ecdh_eddsa \ 300 test_crypto_ecdh_eddsa \
301 test_crypto_ecdh_ecdsa \
301 test_crypto_ecc_dlog \ 302 test_crypto_ecc_dlog \
302 test_crypto_hash \ 303 test_crypto_hash \
303 test_crypto_hash_context \ 304 test_crypto_hash_context \
@@ -476,6 +477,13 @@ test_crypto_ecdh_eddsa_LDADD = \
476 libgnunetutil.la \ 477 libgnunetutil.la \
477 $(LIBGCRYPT_LIBS) 478 $(LIBGCRYPT_LIBS)
478 479
480test_crypto_ecdh_ecdsa_SOURCES = \
481 test_crypto_ecdh_ecdsa.c
482test_crypto_ecdh_ecdsa_LDADD = \
483 libgnunetutil.la \
484 $(LIBGCRYPT_LIBS)
485
486
479test_crypto_hash_SOURCES = \ 487test_crypto_hash_SOURCES = \
480 test_crypto_hash.c 488 test_crypto_hash.c
481test_crypto_hash_LDADD = \ 489test_crypto_hash_LDADD = \