aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2018-06-25 19:52:15 +0200
committerChristian Grothoff <christian@grothoff.org>2018-06-25 19:52:15 +0200
commit4a1f21163c041e673604813a8c48c14bf9f20222 (patch)
treef8c74a2f6a88c51115447115a5bfe747e7647583 /src/util/Makefile.am
parenta4186fc2fd00b3fe2899bffcdbbbf8fead31115f (diff)
downloadgnunet-4a1f21163c041e673604813a8c48c14bf9f20222.tar.gz
gnunet-4a1f21163c041e673604813a8c48c14bf9f20222.zip
move dns ops again, 2nd try
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am25
1 files changed, 23 insertions, 2 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 4296199db..ec7bcb016 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -89,6 +89,8 @@ libgnunetutil_la_SOURCES = \
89 crypto_rsa.c \ 89 crypto_rsa.c \
90 disk.c \ 90 disk.c \
91 disk.h \ 91 disk.h \
92 dnsparser.c \
93 dnsstub.c \
92 getopt.c \ 94 getopt.c \
93 getopt_helpers.c \ 95 getopt_helpers.c \
94 helper.c \ 96 helper.c \
@@ -104,12 +106,14 @@ libgnunetutil_la_SOURCES = \
104 peer.c \ 106 peer.c \
105 plugin.c \ 107 plugin.c \
106 program.c \ 108 program.c \
109 regex.c \
107 resolver_api.c resolver.h \ 110 resolver_api.c resolver.h \
108 scheduler.c \ 111 scheduler.c \
109 service.c \ 112 service.c \
110 signal.c \ 113 signal.c \
111 strings.c \ 114 strings.c \
112 time.c \ 115 time.c \
116 tun.c \
113 speedup.c speedup.h 117 speedup.c speedup.h
114 118
115libgnunetutil_la_LIBADD = \ 119libgnunetutil_la_LIBADD = \
@@ -117,7 +121,7 @@ libgnunetutil_la_LIBADD = \
117 $(LIBGCRYPT_LIBS) \ 121 $(LIBGCRYPT_LIBS) \
118 $(LTLIBICONV) \ 122 $(LTLIBICONV) \
119 $(LTLIBINTL) \ 123 $(LTLIBINTL) \
120 -lltdl $(Z_LIBS) -lunistring $(XLIB) 124 -lltdl -lidn $(Z_LIBS) -lunistring $(XLIB)
121 125
122libgnunetutil_la_LDFLAGS = \ 126libgnunetutil_la_LDFLAGS = \
123 $(GN_LIB_LDFLAGS) \ 127 $(GN_LIB_LDFLAGS) \
@@ -291,19 +295,22 @@ check_PROGRAMS = \
291 test_crypto_rsa \ 295 test_crypto_rsa \
292 test_disk \ 296 test_disk \
293 test_getopt \ 297 test_getopt \
298 test_hexcoder \
294 test_mq \ 299 test_mq \
295 test_os_network \ 300 test_os_network \
296 test_peer \ 301 test_peer \
297 test_plugin \ 302 test_plugin \
298 test_program \ 303 test_program \
304 test_regex \
299 test_resolver_api.nc \ 305 test_resolver_api.nc \
300 test_scheduler \ 306 test_scheduler \
301 test_scheduler_delay \ 307 test_scheduler_delay \
302 test_service \ 308 test_service \
303 test_strings \ 309 test_strings \
304 test_strings_to_data \ 310 test_strings_to_data \
305 test_time \
306 test_speedup \ 311 test_speedup \
312 test_time \
313 test_tun \
307 $(BENCHMARKS) \ 314 $(BENCHMARKS) \
308 test_os_start_process \ 315 test_os_start_process \
309 test_common_logging_runtime_loglevels 316 test_common_logging_runtime_loglevels
@@ -319,6 +326,20 @@ test_bio_SOURCES = \
319test_bio_LDADD = \ 326test_bio_LDADD = \
320 libgnunetutil.la 327 libgnunetutil.la
321 328
329test_hexcoder_SOURCES = \
330 test_hexcoder.c
331test_hexcoder_LDADD = \
332 libgnunetutil.la
333
334test_tun_SOURCES = \
335 test_tun.c
336test_tun_LDADD = \
337 libgnunetutil.la
338
339test_regex_SOURCES = \
340 test_regex.c
341test_regex_LDADD = \
342 libgnunetutil.la
322 343
323test_os_start_process_SOURCES = \ 344test_os_start_process_SOURCES = \
324 test_os_start_process.c 345 test_os_start_process.c