aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-02-26 08:35:45 +0000
committerng0 <ng0@n0.is>2019-02-26 08:35:45 +0000
commit5f80de3fbc0c4b43fb93d0ef4460aea16b2c78e0 (patch)
tree74e83f28ea8198bb1e934a770a6f082bd3ea7984 /src/util/Makefile.am
parent689614a7e51f4fda776e99aa5892811fa5923b2d (diff)
downloadgnunet-5f80de3fbc0c4b43fb93d0ef4460aea16b2c78e0.tar.gz
gnunet-5f80de3fbc0c4b43fb93d0ef4460aea16b2c78e0.zip
Proposed fix for https://bugs.gnunet.org/view.php?id=5611
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am27
1 files changed, 10 insertions, 17 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index d1aa8aa9b..7041004ac 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -204,8 +204,15 @@ libexec_PROGRAMS = \
204 gnunet-timeout \ 204 gnunet-timeout \
205 $(W32CONSOLEHELPER) 205 $(W32CONSOLEHELPER)
206 206
207do_subst = $(SED) -e 's,[@]PREFIX[@],$(PREFIX),g'
208
209gnunet-qr: gnunet-qr.in Makefile
210 $(do_subst) < $(srcdir)/gnunet-qr.in > gnunet-qr
211 chmod +x gnunet-qr
212
207bin_SCRIPTS =\ 213bin_SCRIPTS =\
208 gnunet-qr 214 gnunet-qr \
215 gnunet-qr.py
209 216
210bin_PROGRAMS = \ 217bin_PROGRAMS = \
211 gnunet-resolver \ 218 gnunet-resolver \
@@ -236,21 +243,6 @@ gnunet_timeout_SOURCES = \
236 gnunet-timeout-w32.c 243 gnunet-timeout-w32.c
237endif 244endif
238 245
239# This is horrible, but compared to the alternatives and the solution
240# which preceded this it is a good compromise and good enough for one
241# file. Everyone else is invited to patch it locally.
242# In case someone reads this file and is wondering about the
243# assignment operator below, it's explained here:
244# https://lists.gnu.org/archive/html/make-w32/2013-10/msg00021.html
245
246xENV != which env
247
248do_subst = $(SED) -e 's,[@]ENV[@],${xENV},g'
249
250gnunet-qr: gnunet-qr.py.in Makefile
251 $(do_subst) < $(top_srcdir)/src/util/gnunet-qr.py.in > gnunet-qr
252 chmod +x gnunet-qr
253
254gnunet_service_resolver_SOURCES = \ 246gnunet_service_resolver_SOURCES = \
255 gnunet-service-resolver.c 247 gnunet-service-resolver.c
256gnunet_service_resolver_LDADD = \ 248gnunet_service_resolver_LDADD = \
@@ -675,4 +667,5 @@ EXTRA_DIST = \
675 test_resolver_api_data.conf \ 667 test_resolver_api_data.conf \
676 test_service_data.conf \ 668 test_service_data.conf \
677 test_speedup_data.conf \ 669 test_speedup_data.conf \
678 gnunet-qr.py.in 670 gnunet-qr.py \
671 gnunet-qr.in