aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorlurchi <lurchi@strangeplace.net>2018-06-25 18:38:13 +0200
committerlurchi <lurchi@strangeplace.net>2018-06-25 18:38:27 +0200
commita4186fc2fd00b3fe2899bffcdbbbf8fead31115f (patch)
treed70c5939cc99d43e29ce63a4faa9ef334de0c81d /src/util/Makefile.am
parent7da98cf076e9c5101244dfbbf8c3ddff045d298e (diff)
downloadgnunet-a4186fc2fd00b3fe2899bffcdbbbf8fead31115f.tar.gz
gnunet-a4186fc2fd00b3fe2899bffcdbbbf8fead31115f.zip
Revert "integrate dnsparser and dnsstub and tun with libgnunetutil"
This reverts commit 7da98cf076e9c5101244dfbbf8c3ddff045d298e.
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am25
1 files changed, 2 insertions, 23 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index ec7bcb016..4296199db 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -89,8 +89,6 @@ libgnunetutil_la_SOURCES = \
89 crypto_rsa.c \ 89 crypto_rsa.c \
90 disk.c \ 90 disk.c \
91 disk.h \ 91 disk.h \
92 dnsparser.c \
93 dnsstub.c \
94 getopt.c \ 92 getopt.c \
95 getopt_helpers.c \ 93 getopt_helpers.c \
96 helper.c \ 94 helper.c \
@@ -106,14 +104,12 @@ libgnunetutil_la_SOURCES = \
106 peer.c \ 104 peer.c \
107 plugin.c \ 105 plugin.c \
108 program.c \ 106 program.c \
109 regex.c \
110 resolver_api.c resolver.h \ 107 resolver_api.c resolver.h \
111 scheduler.c \ 108 scheduler.c \
112 service.c \ 109 service.c \
113 signal.c \ 110 signal.c \
114 strings.c \ 111 strings.c \
115 time.c \ 112 time.c \
116 tun.c \
117 speedup.c speedup.h 113 speedup.c speedup.h
118 114
119libgnunetutil_la_LIBADD = \ 115libgnunetutil_la_LIBADD = \
@@ -121,7 +117,7 @@ libgnunetutil_la_LIBADD = \
121 $(LIBGCRYPT_LIBS) \ 117 $(LIBGCRYPT_LIBS) \
122 $(LTLIBICONV) \ 118 $(LTLIBICONV) \
123 $(LTLIBINTL) \ 119 $(LTLIBINTL) \
124 -lltdl -lidn $(Z_LIBS) -lunistring $(XLIB) 120 -lltdl $(Z_LIBS) -lunistring $(XLIB)
125 121
126libgnunetutil_la_LDFLAGS = \ 122libgnunetutil_la_LDFLAGS = \
127 $(GN_LIB_LDFLAGS) \ 123 $(GN_LIB_LDFLAGS) \
@@ -295,22 +291,19 @@ check_PROGRAMS = \
295 test_crypto_rsa \ 291 test_crypto_rsa \
296 test_disk \ 292 test_disk \
297 test_getopt \ 293 test_getopt \
298 test_hexcoder \
299 test_mq \ 294 test_mq \
300 test_os_network \ 295 test_os_network \
301 test_peer \ 296 test_peer \
302 test_plugin \ 297 test_plugin \
303 test_program \ 298 test_program \
304 test_regex \
305 test_resolver_api.nc \ 299 test_resolver_api.nc \
306 test_scheduler \ 300 test_scheduler \
307 test_scheduler_delay \ 301 test_scheduler_delay \
308 test_service \ 302 test_service \
309 test_strings \ 303 test_strings \
310 test_strings_to_data \ 304 test_strings_to_data \
311 test_speedup \
312 test_time \ 305 test_time \
313 test_tun \ 306 test_speedup \
314 $(BENCHMARKS) \ 307 $(BENCHMARKS) \
315 test_os_start_process \ 308 test_os_start_process \
316 test_common_logging_runtime_loglevels 309 test_common_logging_runtime_loglevels
@@ -326,20 +319,6 @@ test_bio_SOURCES = \
326test_bio_LDADD = \ 319test_bio_LDADD = \
327 libgnunetutil.la 320 libgnunetutil.la
328 321
329test_hexcoder_SOURCES = \
330 test_hexcoder.c
331test_hexcoder_LDADD = \
332 libgnunetutil.la
333
334test_tun_SOURCES = \
335 test_tun.c
336test_tun_LDADD = \
337 libgnunetutil.la
338
339test_regex_SOURCES = \
340 test_regex.c
341test_regex_LDADD = \
342 libgnunetutil.la
343 322
344test_os_start_process_SOURCES = \ 323test_os_start_process_SOURCES = \
345 test_os_start_process.c 324 test_os_start_process.c