aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2018-10-25 12:00:16 +0200
committerChristian Grothoff <christian@grothoff.org>2018-10-25 12:01:28 +0200
commitb64879a11e2062b78e984b8e5c22dc26ba224668 (patch)
tree4aa89ec773918de3dca484b107c5822396298d89 /src/util/Makefile.am
parent0a97ba60f4f09558b0c2a4b8d2c09e6ff7bfd112 (diff)
downloadgnunet-b64879a11e2062b78e984b8e5c22dc26ba224668.tar.gz
gnunet-b64879a11e2062b78e984b8e5c22dc26ba224668.zip
fix -lidn(2) linkage by adding missing AM_CONDITIONAL and missing endif statements
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 165d41d01..fc5a4648c 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -126,18 +126,25 @@ if HAVE_LIBIDN
126 LIBIDN= -lidn 126 LIBIDN= -lidn
127else 127else
128 LIBIDN= 128 LIBIDN=
129endif
129 130
130if HAVE_LIBIDN2 131if HAVE_LIBIDN2
131 LIBIDN2= -lidn2 132 LIBIDN2= -lidn2
132else 133else
133 LIBIDN2= 134 LIBIDN2=
135endif
134 136
135libgnunetutil_la_LIBADD = \ 137libgnunetutil_la_LIBADD = \
136 $(GCLIBADD) $(WINLIB) \ 138 $(GCLIBADD) $(WINLIB) \
137 $(LIBGCRYPT_LIBS) \ 139 $(LIBGCRYPT_LIBS) \
138 $(LTLIBICONV) \ 140 $(LTLIBICONV) \
139 $(LTLIBINTL) \ 141 $(LTLIBINTL) \
140 -lltdl $(LIBIDN) $(LIBIDN2) $(Z_LIBS) -lunistring $(XLIB) $(PTHREAD) 142 -lltdl \
143 $(LIBIDN) $(LIBIDN2) \
144 $(Z_LIBS) \
145 -lunistring \
146 $(XLIB) \
147 $(PTHREAD)
141 148
142libgnunetutil_la_LDFLAGS = \ 149libgnunetutil_la_LDFLAGS = \
143 $(GN_LIB_LDFLAGS) \ 150 $(GN_LIB_LDFLAGS) \