aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorGian Demarmels <gian@demarmels.org>2021-12-06 22:44:14 +0100
committerLucien Heuzeveldt <lucienclaude.heuzeveldt@students.bfh.ch>2021-12-07 20:44:37 +0100
commit67b56e366bc73cc9d940721067ae0f3c7f554768 (patch)
treef931e85c18cbde7ca5ed620d073e816964e08ad0 /src/util/Makefile.am
parent2bcdfc2f958f5fd2512103c2240f1c24c07524d7 (diff)
downloadgnunet-67b56e366bc73cc9d940721067ae0f3c7f554768.tar.gz
gnunet-67b56e366bc73cc9d940721067ae0f3c7f554768.zip
add crypto_cs testing and benchmark
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index 771be1ee3..9fda40f51 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -254,6 +254,7 @@ libgnunet_plugin_utiltest_la_LDFLAGS = \
254 254
255if HAVE_BENCHMARKS 255if HAVE_BENCHMARKS
256 BENCHMARKS = \ 256 BENCHMARKS = \
257 perf_crypto_cs \
257 perf_crypto_hash \ 258 perf_crypto_hash \
258 perf_crypto_rsa \ 259 perf_crypto_rsa \
259 perf_crypto_paillier \ 260 perf_crypto_paillier \
@@ -290,6 +291,7 @@ check_PROGRAMS = \
290 test_container_heap \ 291 test_container_heap \
291 test_crypto_symmetric \ 292 test_crypto_symmetric \
292 test_crypto_crc \ 293 test_crypto_crc \
294 test_crypto_cs \
293 test_crypto_ecdsa \ 295 test_crypto_ecdsa \
294 test_crypto_eddsa \ 296 test_crypto_eddsa \
295 test_crypto_ecdhe \ 297 test_crypto_ecdhe \
@@ -450,6 +452,12 @@ test_crypto_crc_SOURCES = \
450test_crypto_crc_LDADD = \ 452test_crypto_crc_LDADD = \
451 libgnunetutil.la 453 libgnunetutil.la
452 454
455test_crypto_cs_SOURCES = \
456 test_crypto_cs.c
457test_crypto_cs_LDADD = \
458 libgnunetutil.la \
459 -lsodium
460
453test_crypto_ecdsa_SOURCES = \ 461test_crypto_ecdsa_SOURCES = \
454 test_crypto_ecdsa.c 462 test_crypto_ecdsa.c
455test_crypto_ecdsa_LDADD = \ 463test_crypto_ecdsa_LDADD = \
@@ -605,6 +613,11 @@ test_uri_SOURCES = \
605test_uri_LDADD = \ 613test_uri_LDADD = \
606 libgnunetutil.la 614 libgnunetutil.la
607 615
616perf_crypto_cs_SOURCES = \
617 perf_crypto_cs.c
618perf_crypto_cs_LDADD = \
619 libgnunetutil.la
620
608perf_crypto_hash_SOURCES = \ 621perf_crypto_hash_SOURCES = \
609 perf_crypto_hash.c 622 perf_crypto_hash.c
610perf_crypto_hash_LDADD = \ 623perf_crypto_hash_LDADD = \