aboutsummaryrefslogtreecommitdiff
path: root/src/util/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-04-03 12:19:26 +0000
committerng0 <ng0@n0.is>2019-04-03 12:19:26 +0000
commitcc3d270b525cdc4756fa706221fd4ad510539700 (patch)
treed7199304b17651d285dd09d41c2bc7fbc70950e9 /src/util/Makefile.am
parentf002ecb549ec33da77e4a034ad1cffe27922112d (diff)
parente96ba10771f6c6932607624c4645cf50b3d5b71f (diff)
downloadgnunet-cc3d270b525cdc4756fa706221fd4ad510539700.tar.gz
gnunet-cc3d270b525cdc4756fa706221fd4ad510539700.zip
Merge branch 'master' of gnunet.org:gnunet
Diffstat (limited to 'src/util/Makefile.am')
-rw-r--r--src/util/Makefile.am32
1 files changed, 14 insertions, 18 deletions
diff --git a/src/util/Makefile.am b/src/util/Makefile.am
index cd14fb4ca..89d0462c5 100644
--- a/src/util/Makefile.am
+++ b/src/util/Makefile.am
@@ -204,26 +204,15 @@ libexec_PROGRAMS = \
204 gnunet-timeout \ 204 gnunet-timeout \
205 $(W32CONSOLEHELPER) 205 $(W32CONSOLEHELPER)
206 206
207do_subst = $(SED) -e 's,[@]PREFIX[@],$(prefix),g'
208
209gnunet-qr: gnunet-qr.in Makefile
210 $(do_subst) < $(srcdir)/gnunet-qr.in > gnunet-qr
211 chmod +x gnunet-qr
212
213CLEANFILES = gnunet-qr
214
215pkgdata_DATA = \
216 gnunet-qr.py
217
218bin_SCRIPTS =\
219 gnunet-qr
220
221bin_PROGRAMS = \ 207bin_PROGRAMS = \
222 gnunet-resolver \ 208 gnunet-resolver \
223 gnunet-config \ 209 gnunet-config \
224 $(GNUNET_ECC) \ 210 $(GNUNET_ECC) \
225 $(GNUNET_SCRYPT) \ 211 $(GNUNET_SCRYPT) \
226 gnunet-uri 212 gnunet-uri
213if HAVE_ZBAR
214bin_PROGRAMS += gnunet-qr
215endif
227 216
228noinst_PROGRAMS = \ 217noinst_PROGRAMS = \
229 gnunet-config-diff \ 218 gnunet-config-diff \
@@ -283,13 +272,22 @@ gnunet_config_LDADD = \
283 libgnunetutil.la \ 272 libgnunetutil.la \
284 $(GN_LIBINTL) 273 $(GN_LIBINTL)
285 274
286
287gnunet_uri_SOURCES = \ 275gnunet_uri_SOURCES = \
288 gnunet-uri.c 276 gnunet-uri.c
289gnunet_uri_LDADD = \ 277gnunet_uri_LDADD = \
290 libgnunetutil.la \ 278 libgnunetutil.la \
291 $(GN_LIBINTL) 279 $(GN_LIBINTL)
292 280
281
282gnunet_qr_SOURCES = \
283 gnunet-qr.c \
284 gnunet-qr-utils.h
285gnunet_qr_LDADD = \
286 libgnunetutil.la \
287 $(GN_LIBINTL)
288gnunet_qr_LDFLAGS= $(libzbar_LIBS)
289gnunet_qr_CFLAGS = $(libzbar_CFLAGS) -DBINDIR=\"@bindir@/\"
290
293plugin_LTLIBRARIES = \ 291plugin_LTLIBRARIES = \
294 libgnunet_plugin_test.la 292 libgnunet_plugin_test.la
295 293
@@ -670,6 +668,4 @@ EXTRA_DIST = \
670 test_program_data.conf \ 668 test_program_data.conf \
671 test_resolver_api_data.conf \ 669 test_resolver_api_data.conf \
672 test_service_data.conf \ 670 test_service_data.conf \
673 test_speedup_data.conf \ 671 test_speedup_data.conf
674 gnunet-qr.in \
675 gnunet-qr.py