aboutsummaryrefslogtreecommitdiff
path: root/src/vpn/Makefile.am
diff options
context:
space:
mode:
authorChristian Fuchs <christian.fuchs@cfuchs.net>2012-11-26 10:11:00 +0000
committerChristian Fuchs <christian.fuchs@cfuchs.net>2012-11-26 10:11:00 +0000
commit1a52014b3b0da4f4330ee00aef0f92400e917558 (patch)
treeb782f52c67088e6232012c97e693e175b3c8a143 /src/vpn/Makefile.am
parent8bb9fe7704908d551be75cc8f169c109682d7a56 (diff)
downloadgnunet-1a52014b3b0da4f4330ee00aef0f92400e917558.tar.gz
gnunet-1a52014b3b0da4f4330ee00aef0f92400e917558.zip
added libraries for setupapi & dependencies
Diffstat (limited to 'src/vpn/Makefile.am')
-rw-r--r--src/vpn/Makefile.am15
1 files changed, 11 insertions, 4 deletions
diff --git a/src/vpn/Makefile.am b/src/vpn/Makefile.am
index b80be7749..090b463f6 100644
--- a/src/vpn/Makefile.am
+++ b/src/vpn/Makefile.am
@@ -1,7 +1,7 @@
1INCLUDES = -I$(top_srcdir)/src/include 1INCLUDES = -I$(top_srcdir)/src/include -I$(top_builddir)/src/include
2 2
3if MINGW 3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols 4 WINFLAGS = -Wl,--no-undefined,--export-all-symbols
5 VPNBIN = gnunet-helper-vpn 5 VPNBIN = gnunet-helper-vpn
6endif 6endif
7 7
@@ -39,8 +39,15 @@ bin_PROGRAMS = \
39 gnunet-vpn 39 gnunet-vpn
40 40
41if MINGW 41if MINGW
42 gnunet_helper_vpn_SOURCES = \ 42 gnunet_helper_vpn_LDFLAGS = \
43 gnunet-helper-vpn-windows.c 43 -no-undefined -Wl,--export-all-symbols
44
45 gnunet_helper_vpn_LDADD = \
46 -lsetupapi -lshell32 -liconv -lstdc++ \
47 -lcomdlg32 -lgdi32 -liphlpapi
48
49 gnunet_helper_vpn_SOURCES = \
50 gnunet-helper-vpn-windows.c
44else 51else
45 gnunet_helper_vpn_SOURCES = \ 52 gnunet_helper_vpn_SOURCES = \
46 gnunet-helper-vpn.c 53 gnunet-helper-vpn.c