aboutsummaryrefslogtreecommitdiff
path: root/src/vpn/Makefile.am
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2019-10-23 21:51:46 +0000
committerng0 <ng0@n0.is>2019-10-23 21:51:46 +0000
commit4993eac25ce2737fc45aec08f21226f523405804 (patch)
treea32a054c36102aa712a17b9b27be14b72fa8557b /src/vpn/Makefile.am
parent0c13e270c31ef2896d56eb3d53ac7a5714ea1e58 (diff)
downloadgnunet-4993eac25ce2737fc45aec08f21226f523405804.tar.gz
gnunet-4993eac25ce2737fc45aec08f21226f523405804.zip
remove never working setuid helper code from the build-system.
refer to the Changelog for a longer reason. In conclusion, this is what people expect, this is what Package Managers patch away for portability, and we can't use install(1) for this because it's not a portable tool.
Diffstat (limited to 'src/vpn/Makefile.am')
-rw-r--r--src/vpn/Makefile.am13
1 files changed, 0 insertions, 13 deletions
diff --git a/src/vpn/Makefile.am b/src/vpn/Makefile.am
index 9992fa5ed..407d8ba92 100644
--- a/src/vpn/Makefile.am
+++ b/src/vpn/Makefile.am
@@ -14,21 +14,8 @@ plugindir = $(libdir)/gnunet
14pkgcfg_DATA = \ 14pkgcfg_DATA = \
15 vpn.conf 15 vpn.conf
16 16
17if HAVE_SUDO
18SUDO_OR_DOAS_BINARY= $(SUDO_BINARY)
19else
20if HAVE_DOAS_BINARY
21SUDO_OR_DOAS_BINARY= $(DOAS_BINARY)
22endif
23endif
24
25if LINUX 17if LINUX
26VPNBIN = gnunet-helper-vpn 18VPNBIN = gnunet-helper-vpn
27install-exec-hook:
28 chown root:root $(DESTDIR)$(libexecdir)/gnunet-helper-vpn
29 chmod u+s $(DESTDIR)$(libexecdir)/gnunet-helper-vpn
30else
31install-exec-hook:
32endif 19endif
33 20
34 21