aboutsummaryrefslogtreecommitdiff
path: root/src/vpn/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-01-07 19:00:55 +0000
committerChristian Grothoff <christian@grothoff.org>2012-01-07 19:00:55 +0000
commit4c6f5a7ae36bbed02ecd1ae78ecff44e93c0970b (patch)
treef715e8ea14fdc5b98033db81e91c2b0d03e1c03b /src/vpn/Makefile.am
parentffc10c1b249e2cc774ec7bcbf9d5366a36179a22 (diff)
downloadgnunet-4c6f5a7ae36bbed02ecd1ae78ecff44e93c0970b.tar.gz
gnunet-4c6f5a7ae36bbed02ecd1ae78ecff44e93c0970b.zip
-vpn api skeleton
Diffstat (limited to 'src/vpn/Makefile.am')
-rw-r--r--src/vpn/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/vpn/Makefile.am b/src/vpn/Makefile.am
index 380db4446..dd617c2d5 100644
--- a/src/vpn/Makefile.am
+++ b/src/vpn/Makefile.am
@@ -25,6 +25,10 @@ install-exec-hook:
25endif 25endif
26 26
27 27
28lib_LTLIBRARIES = \
29 libgnunetvpn.la
30
31
28bin_PROGRAMS = \ 32bin_PROGRAMS = \
29 gnunet-daemon-exit gnunet-daemon-vpn $(VPNBIN) gnunet-service-vpn 33 gnunet-daemon-exit gnunet-daemon-vpn $(VPNBIN) gnunet-service-vpn
30 34
@@ -60,6 +64,13 @@ gnunet_daemon_exit_LDADD = \
60 $(top_builddir)/src/mesh/libgnunetmesh.la \ 64 $(top_builddir)/src/mesh/libgnunetmesh.la \
61 $(GN_LIBINTL) 65 $(GN_LIBINTL)
62 66
67libgnunetvpn_la_SOURCES = \
68 vpn_api.c vpn.h
69libgnunetvpn_la_LIBADD = \
70 $(top_builddir)/src/util/libgnunetutil.la $(XLIB)
71libgnunetvpn_la_LDFLAGS = \
72 $(GN_LIB_LDFLAGS)
73
63 74
64if ENABLE_TEST_RUN 75if ENABLE_TEST_RUN
65#TESTS = \ 76#TESTS = \