aboutsummaryrefslogtreecommitdiff
path: root/src/vpn/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-01-01 23:00:59 +0000
committerChristian Grothoff <christian@grothoff.org>2012-01-01 23:00:59 +0000
commit66ffc809472f27d69b9ad7361f8ba29c2674f716 (patch)
tree609623cb79291939f9cb81a8858853a202dae2ca /src/vpn/Makefile.am
parent131c43b2b18b12e52ff045e51025706802cbd2e2 (diff)
downloadgnunet-66ffc809472f27d69b9ad7361f8ba29c2674f716.tar.gz
gnunet-66ffc809472f27d69b9ad7361f8ba29c2674f716.zip
-moving DNS code into its own directory
Diffstat (limited to 'src/vpn/Makefile.am')
-rw-r--r--src/vpn/Makefile.am21
1 files changed, 2 insertions, 19 deletions
diff --git a/src/vpn/Makefile.am b/src/vpn/Makefile.am
index e69c5643e..dfba44f0a 100644
--- a/src/vpn/Makefile.am
+++ b/src/vpn/Makefile.am
@@ -17,30 +17,23 @@ dist_pkgcfg_DATA = \
17 17
18if LINUX 18if LINUX
19VPNBIN = gnunet-helper-vpn 19VPNBIN = gnunet-helper-vpn
20HIJACKBIN = gnunet-helper-hijack-dns
21install-exec-hook: 20install-exec-hook:
22 $(SUDO_BINARY) chown root:root $(bindir)/gnunet-helper-vpn || true 21 $(SUDO_BINARY) chown root:root $(bindir)/gnunet-helper-vpn || true
23 $(SUDO_BINARY) chmod u+s $(bindir)/gnunet-helper-vpn || true 22 $(SUDO_BINARY) chmod u+s $(bindir)/gnunet-helper-vpn || true
24 $(SUDO_BINARY) chown root:root $(bindir)/gnunet-helper-hijack-dns || true
25 $(SUDO_BINARY) chmod u+s $(bindir)/gnunet-helper-hijack-dns || true
26else 23else
27install-exec-hook: 24install-exec-hook:
28endif 25endif
29 26
30 27
31bin_PROGRAMS = \ 28bin_PROGRAMS = \
32 gnunet-daemon-exit gnunet-daemon-vpn gnunet-service-dns $(VPNBIN) $(HIJACKBIN) 29 gnunet-daemon-exit gnunet-daemon-vpn $(VPNBIN) $(HIJACKBIN)
33 30
34 31
35gnunet_helper_vpn_SOURCES = \ 32gnunet_helper_vpn_SOURCES = \
36 gnunet-helper-vpn.c 33 gnunet-helper-vpn.c
37 34
38gnunet_helper_hijack_dns_SOURCES = \
39 gnunet-helper-hijack-dns.c
40
41gnunet_daemon_vpn_SOURCES = \ 35gnunet_daemon_vpn_SOURCES = \
42 gnunet-daemon-vpn.c gnunet-daemon-vpn.h \ 36 gnunet-daemon-vpn.c gnunet-daemon-vpn.h \
43 gnunet-dns-parser.c gnunet-dns-parser.h \
44 gnunet-daemon-vpn-helper.c gnunet-daemon-vpn-helper.h \ 37 gnunet-daemon-vpn-helper.c gnunet-daemon-vpn-helper.h \
45 gnunet-daemon-vpn-dns.c gnunet-daemon-vpn-dns.h \ 38 gnunet-daemon-vpn-dns.c gnunet-daemon-vpn-dns.h \
46 gnunet-helper-vpn-api.c gnunet-helper-vpn-api.h \ 39 gnunet-helper-vpn-api.c gnunet-helper-vpn-api.h \
@@ -50,17 +43,7 @@ gnunet_daemon_vpn_LDADD = \
50 $(top_builddir)/src/statistics/libgnunetstatistics.la \ 43 $(top_builddir)/src/statistics/libgnunetstatistics.la \
51 $(top_builddir)/src/util/libgnunetutil.la \ 44 $(top_builddir)/src/util/libgnunetutil.la \
52 $(top_builddir)/src/mesh/libgnunetmesh.la \ 45 $(top_builddir)/src/mesh/libgnunetmesh.la \
53 $(GN_LIBINTL) 46 $(top_builddir)/src/dns/libgnunetdnsparser.la \
54
55gnunet_service_dns_SOURCES = \
56 gnunet-service-dns.c gnunet-service-dns-p.h \
57 gnunet-dns-parser.c gnunet-dns-parser.h
58gnunet_service_dns_LDADD = \
59 $(top_builddir)/src/core/libgnunetcore.la \
60 $(top_builddir)/src/statistics/libgnunetstatistics.la \
61 $(top_builddir)/src/util/libgnunetutil.la \
62 $(top_builddir)/src/dht/libgnunetdht.la \
63 $(top_builddir)/src/mesh/libgnunetmesh.la \
64 $(GN_LIBINTL) 47 $(GN_LIBINTL)
65 48
66gnunet_daemon_exit_SOURCES = \ 49gnunet_daemon_exit_SOURCES = \