aboutsummaryrefslogtreecommitdiff
path: root/src/vpn/Makefile.am
diff options
context:
space:
mode:
authorChristian Grothoff <christian@grothoff.org>2012-01-24 10:18:13 +0000
committerChristian Grothoff <christian@grothoff.org>2012-01-24 10:18:13 +0000
commit77d74ef24d2f0bf071e74d4d8131909ac06c5404 (patch)
tree1feeca1ced41c8e7c6a2c7242569d88aa0134011 /src/vpn/Makefile.am
parentd23a2ea6fbe415b0e56249d55fb2b178d76629f2 (diff)
downloadgnunet-77d74ef24d2f0bf071e74d4d8131909ac06c5404.tar.gz
gnunet-77d74ef24d2f0bf071e74d4d8131909ac06c5404.zip
-a first VPN testcase
Diffstat (limited to 'src/vpn/Makefile.am')
-rw-r--r--src/vpn/Makefile.am28
1 files changed, 17 insertions, 11 deletions
diff --git a/src/vpn/Makefile.am b/src/vpn/Makefile.am
index 786f94d6a..fea89724d 100644
--- a/src/vpn/Makefile.am
+++ b/src/vpn/Makefile.am
@@ -33,6 +33,17 @@ bin_PROGRAMS = \
33 $(VPNBIN) gnunet-service-vpn gnunet-vpn 33 $(VPNBIN) gnunet-service-vpn gnunet-vpn
34 34
35 35
36if HAVE_MHD
37 VPN_TEST = test_gnunet_vpn
38endif
39
40check_PROGRAMS = $(VPN_TEST)
41
42if ENABLE_TEST_RUN
43TESTS = $(check_PROGRAMS)
44endif
45
46
36gnunet_helper_vpn_SOURCES = \ 47gnunet_helper_vpn_SOURCES = \
37 gnunet-helper-vpn.c 48 gnunet-helper-vpn.c
38 49
@@ -64,14 +75,9 @@ libgnunetvpn_la_LDFLAGS = \
64 $(GN_LIB_LDFLAGS) 75 $(GN_LIB_LDFLAGS)
65 76
66 77
67if ENABLE_TEST_RUN 78test_gnunet_vpn_SOURCES = \
68#TESTS = \ 79 test_gnunet_vpn.c
69# test_transport_api_tcp 80test_gnunet_vpn_LDADD = -lmicrohttpd @LIBCURL@ \
70endif 81 $(top_builddir)/src/vpn/libgnunetvpn.la \
71 82 $(top_builddir)/src/arm/libgnunetarm.la \
72#test_transport_api_tcp_SOURCES = \ 83 $(top_builddir)/src/util/libgnunetutil.la
73# test_transport_api.c
74#test_transport_api_tcp_LDADD = \
75# $(top_builddir)/src/transport/libgnunettransport.la \
76# $(top_builddir)/src/util/libgnunetutil.la
77