aboutsummaryrefslogtreecommitdiff
path: root/src/vpn/Makefile.am
diff options
context:
space:
mode:
authorChristian Fuchs <christian.fuchs@cfuchs.net>2012-11-16 09:03:54 +0000
committerChristian Fuchs <christian.fuchs@cfuchs.net>2012-11-16 09:03:54 +0000
commit934db0fcddb6c3fb793e1995cb3441b22945809a (patch)
tree2733162eb5d053e34b3acf653b35b9175df4dcea /src/vpn/Makefile.am
parent246cd58943ccff6dd50bb10d5e01ea8ba4e2e0f5 (diff)
downloadgnunet-934db0fcddb6c3fb793e1995cb3441b22945809a.tar.gz
gnunet-934db0fcddb6c3fb793e1995cb3441b22945809a.zip
- added vpn helper stub for win32 builds
- modified vpn-makefile definitions to process gnunet-helper-vpn-windows instead of the regular one when using mingw as toolchain
Diffstat (limited to 'src/vpn/Makefile.am')
-rw-r--r--src/vpn/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/src/vpn/Makefile.am b/src/vpn/Makefile.am
index 71601383e..b80be7749 100644
--- a/src/vpn/Makefile.am
+++ b/src/vpn/Makefile.am
@@ -2,6 +2,7 @@ INCLUDES = -I$(top_srcdir)/src/include
2 2
3if MINGW 3if MINGW
4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols 4 WINFLAGS = -Wl,--no-undefined -Wl,--export-all-symbols
5 VPNBIN = gnunet-helper-vpn
5endif 6endif
6 7
7if USE_COVERAGE 8if USE_COVERAGE
@@ -37,9 +38,13 @@ libexec_PROGRAMS = \
37bin_PROGRAMS = \ 38bin_PROGRAMS = \
38 gnunet-vpn 39 gnunet-vpn
39 40
40gnunet_helper_vpn_SOURCES = \ 41if MINGW
41 gnunet-helper-vpn.c 42 gnunet_helper_vpn_SOURCES = \
42 43 gnunet-helper-vpn-windows.c
44else
45 gnunet_helper_vpn_SOURCES = \
46 gnunet-helper-vpn.c
47endif
43gnunet_service_vpn_SOURCES = \ 48gnunet_service_vpn_SOURCES = \
44 gnunet-service-vpn.c 49 gnunet-service-vpn.c
45gnunet_service_vpn_LDADD = \ 50gnunet_service_vpn_LDADD = \