aboutsummaryrefslogtreecommitdiff
path: root/src/vpn/Makefile.am
diff options
context:
space:
mode:
authorMartin Schanzenbach <mschanzenbach@posteo.de>2012-06-27 10:26:20 +0000
committerMartin Schanzenbach <mschanzenbach@posteo.de>2012-06-27 10:26:20 +0000
commitf68e5cda5acb6f39abaaeec839cb7e7cf2b77053 (patch)
tree82a9eb484330322585b067191e4c823ce8fef955 /src/vpn/Makefile.am
parentb7daa03785d09510b3f36d4e6bbab37b005c3619 (diff)
downloadgnunet-f68e5cda5acb6f39abaaeec839cb7e7cf2b77053.tar.gz
gnunet-f68e5cda5acb6f39abaaeec839cb7e7cf2b77053.zip
-fix order
Diffstat (limited to 'src/vpn/Makefile.am')
-rw-r--r--src/vpn/Makefile.am65
1 files changed, 1 insertions, 64 deletions
diff --git a/src/vpn/Makefile.am b/src/vpn/Makefile.am
index c079f3711..efd61d775 100644
--- a/src/vpn/Makefile.am
+++ b/src/vpn/Makefile.am
@@ -20,14 +20,6 @@ VPNBIN = gnunet-helper-vpn
20install-exec-hook: 20install-exec-hook:
21 $(SUDO_BINARY) chown root:root $(bindir)/gnunet-helper-vpn || true 21 $(SUDO_BINARY) chown root:root $(bindir)/gnunet-helper-vpn || true
22 $(SUDO_BINARY) chmod u+s $(bindir)/gnunet-helper-vpn || true 22 $(SUDO_BINARY) chmod u+s $(bindir)/gnunet-helper-vpn || true
23if HAVE_MHD
24 VPN_TEST = \
25 test_gnunet_vpn-4_to_6 \
26 test_gnunet_vpn-6_to_4 \
27 test_gnunet_vpn-6_over \
28 test_gnunet_vpn-4_over \
29 test_gns_vpn
30endif
31else 23else
32install-exec-hook: 24install-exec-hook:
33endif 25endif
@@ -40,18 +32,6 @@ lib_LTLIBRARIES = \
40bin_PROGRAMS = \ 32bin_PROGRAMS = \
41 $(VPNBIN) gnunet-service-vpn gnunet-vpn 33 $(VPNBIN) gnunet-service-vpn gnunet-vpn
42 34
43
44
45check_PROGRAMS = $(VPN_TEST)
46
47if ENABLE_TEST_RUN
48TESTS = $(check_PROGRAMS)
49endif
50
51EXTRA_DIST = \
52 test_gnunet_vpn.conf \
53 test_gns_vpn.conf
54
55gnunet_helper_vpn_SOURCES = \ 35gnunet_helper_vpn_SOURCES = \
56 gnunet-helper-vpn.c 36 gnunet-helper-vpn.c
57 37
@@ -82,47 +62,4 @@ libgnunetvpn_la_LIBADD = \
82libgnunetvpn_la_LDFLAGS = \ 62libgnunetvpn_la_LDFLAGS = \
83 $(GN_LIB_LDFLAGS) 63 $(GN_LIB_LDFLAGS)
84 64
85test_gns_vpn_SOURCES = \ 65
86 test_gns_vpn.c
87test_gns_vpn_LDADD = -lmicrohttpd @LIBCURL@ \
88 $(top_builddir)/src/namestore/libgnunetnamestore.la \
89 $(top_builddir)/src/testing/libgnunettesting.la \
90 $(top_builddir)/src/util/libgnunetutil.la
91test_gnunet_vpn_4_over_CPPFLAGS = \
92 @LIBCURL_CPPFLAGS@
93
94test_gnunet_vpn_4_over_SOURCES = \
95 test_gnunet_vpn.c
96test_gnunet_vpn_4_over_LDADD = -lmicrohttpd @LIBCURL@ \
97 $(top_builddir)/src/vpn/libgnunetvpn.la \
98 $(top_builddir)/src/testing/libgnunettesting.la \
99 $(top_builddir)/src/util/libgnunetutil.la
100test_gnunet_vpn_4_over_CPPFLAGS = \
101 @LIBCURL_CPPFLAGS@
102
103test_gnunet_vpn_6_over_SOURCES = \
104 test_gnunet_vpn.c
105test_gnunet_vpn_6_over_LDADD = -lmicrohttpd @LIBCURL@ \
106 $(top_builddir)/src/vpn/libgnunetvpn.la \
107 $(top_builddir)/src/testing/libgnunettesting.la \
108 $(top_builddir)/src/util/libgnunetutil.la
109test_gnunet_vpn_6_over_CPPFLAGS = \
110 @LIBCURL_CPPFLAGS@
111
112test_gnunet_vpn_4_to_6_SOURCES = \
113 test_gnunet_vpn.c
114test_gnunet_vpn_4_to_6_LDADD = -lmicrohttpd @LIBCURL@ \
115 $(top_builddir)/src/vpn/libgnunetvpn.la \
116 $(top_builddir)/src/testing/libgnunettesting.la \
117 $(top_builddir)/src/util/libgnunetutil.la
118test_gnunet_vpn_4_to_6_CPPFLAGS = \
119 @LIBCURL_CPPFLAGS@
120
121test_gnunet_vpn_6_to_4_SOURCES = \
122 test_gnunet_vpn.c
123test_gnunet_vpn_6_to_4_LDADD = -lmicrohttpd @LIBCURL@ \
124 $(top_builddir)/src/vpn/libgnunetvpn.la \
125 $(top_builddir)/src/testing/libgnunettesting.la \
126 $(top_builddir)/src/util/libgnunetutil.la
127test_gnunet_vpn_6_to_4_CPPFLAGS = \
128 @LIBCURL_CPPFLAGS@