summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog3
-rw-r--r--README1
-rw-r--r--configure.ac14
3 files changed, 3 insertions, 15 deletions
diff --git a/ChangeLog b/ChangeLog
index 8c24a7e5f..c719c4b37 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,6 @@
+Fri Oct 25 00:00:00 UTC 2019
+ Dropped glpk dependency(-check). -ng0
+
Wed Oct 23 00:00:00 UTC 2019
Remove setuid helpers. They never worked as intended. The
fixed version is not portable and the defacto good way to
diff --git a/README b/README
index ac4a2618c..c1e7db2e5 100644
--- a/README
+++ b/README
@@ -122,7 +122,6 @@ These are the optional dependencies:
- grof (for linting of man pages)
- libextractor >= 0.6.1 (highly recommended[*5])
- libjansson
-- libglpk >= 4.45 (for experimental code)
- libopus >= 1.0.1 (for experimental conversation tool)
- libpulse >= 2.0 (for experimental conversation tool)
- libogg >= 1.3.0 (for experimental conversation tool)
diff --git a/configure.ac b/configure.ac
index bf4e13320..fc0d75fbf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -791,20 +791,6 @@ AM_CONDITIONAL(HAVE_LIBATOMIC, [test "$have_libatomic" = 1])
LIBS=$SAVE_LIBS
CPPFLAGS=$SAVE_CPPFLAGS
-AC_CHECK_HEADERS([glpk.h],[glpk=true],[glpk=false])
-# GLPK must support glpk_init_env, version >= 4.43
-AC_CHECK_LIB([glpk],[glp_init_env],,[glpk=false])
-# GLPK must support atm MLP presolving, version >= 4.32
-AC_CHECK_MEMBERS(glp_iocp.presolve,,[glpk=false],[[#include <glpk.h>]])
-AS_IF([test "x$glpk" = xfalse],
-[
- AM_CONDITIONAL(HAVE_LIBGLPK, false)
- AC_MSG_WARN([ERROR: GNUnet requires GLPK >= 4.32])
-],[
- AM_CONDITIONAL(HAVE_LIBGLPK, true)
- AC_DEFINE([HAVE_LIBGLPK],[1],[Have GLPK])
-])
-
AC_CHECK_HEADERS([nss.h],[nss=true],[nss=false])
AS_IF([test x$nss = xfalse],