summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog4
-rw-r--r--README2
-rw-r--r--configure.ac6
-rw-r--r--doc/handbook/chapters/installation.texi2
4 files changed, 9 insertions, 5 deletions
diff --git a/ChangeLog b/ChangeLog
index aed5c2de0..bfe55682f 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+Sat 27 Apr 2019 06:36:31 AM CEST
+ Bump libmicrohttpd version requirement as some intermediate
+ versions have relevant bugs that cause problems. -CG
+
Sat Apr 27 01:50:43 2019 +0200
RECLAIM: No longer experimental
diff --git a/README b/README
index 595bc746e..ad8b28419 100644
--- a/README
+++ b/README
@@ -69,7 +69,7 @@ These are the direct dependencies for running GNUnet:
* libidn2 (prefered)
or
* libidn >= 1.0
-- libmicrohttpd >= 0.9.52 (strongly recommended for
+- libmicrohttpd >= 0.9.63 (strongly recommended for
a wide range of features)
- makeinfo >= 4.8
- make[*3]
diff --git a/configure.ac b/configure.ac
index c9f2d38c7..a9845d202 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1297,12 +1297,12 @@ AC_ARG_WITH(microhttpd,
AC_CHECK_HEADERS([microhttpd.h],
AC_CHECK_DECL(MHD_OPTION_PER_IP_CONNECTION_LIMIT,
AC_CHECK_LIB([microhttpd], [MHD_get_fdset2],
- [AC_MSG_CHECKING([for libmicrohttpd >= 0.9.52])
+ [AC_MSG_CHECKING([for libmicrohttpd >= 0.9.63])
AC_COMPILE_IFELSE([AC_LANG_SOURCE([
#include "$native_srcdir/src/include/platform.h"
#include <microhttpd.h>
- #if (MHD_VERSION < 0x0094200)
- #error needs at least version 0.9.42
+ #if (MHD_VERSION < 0x0096300)
+ #error needs at least version 0.9.63
#endif
int main () { return 0; }
])],
diff --git a/doc/handbook/chapters/installation.texi b/doc/handbook/chapters/installation.texi
index 94d6807e1..c3b9c6cbc 100644
--- a/doc/handbook/chapters/installation.texi
+++ b/doc/handbook/chapters/installation.texi
@@ -38,7 +38,7 @@ The mandatory libraries and applications are
@item libgcrypt 1.6 or above
@item libextractor
@item libidn2 or libidn
-@item libmicrohttpd 0.9.52 or above
+@item libmicrohttpd 0.9.63 or above
@item libunistring
@item libgmp
@item libgnurl or libcurl (libcurl has to be linked to GnuTLS) 7.35.0 or above