aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am24
1 files changed, 15 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 9191107d2..90d2f4c60 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,9 +3,9 @@ AM_CPPFLAGS = -I$(top_srcdir)/src/include
3 3
4# only documentation (ALL of the documentation) 4# only documentation (ALL of the documentation)
5if DOCUMENTATION_ONLY 5if DOCUMENTATION_ONLY
6 SUBDIRS = bin doc 6 SUBDIRS = scripts doc
7else 7else
8 SUBDIRS = m4 bin src po pkgconfig 8 SUBDIRS = m4 scripts src po pkgconfig
9endif 9endif
10 10
11# documentation on / off switch (affects all of the documentation) 11# documentation on / off switch (affects all of the documentation)
@@ -13,12 +13,7 @@ if DOCUMENTATION
13 SUBDIRS += doc 13 SUBDIRS += doc
14endif 14endif
15 15
16# only manpages, needs "doc" subdir 16SUBDIRS += contrib data scripts
17if INCLUDE_MANPAGES
18 SUBDIRS += doc
19endif
20
21SUBDIRS += contrib
22 17
23EXTRA_DIST = \ 18EXTRA_DIST = \
24 ABOUT-NLS \ 19 ABOUT-NLS \
@@ -28,7 +23,7 @@ EXTRA_DIST = \
28 .version 23 .version
29 24
30gnunetincludedir = $(includedir)/gnunet 25gnunetincludedir = $(includedir)/gnunet
31gnunetinclude_HEADERS = gnunet_config.h 26#gnunetinclude_HEADERS = gnunet_config.h
32 27
33docdir = $(datadir)/doc/gnunet/ 28docdir = $(datadir)/doc/gnunet/
34doc_DATA = COPYING README 29doc_DATA = COPYING README
@@ -73,3 +68,14 @@ if HAVE_AWK
73check-texinfo: 68check-texinfo:
74 @cd $(top_srcdir); find . -type f ! -path '*/.*' -name '*.texi' -print0 | xargs -0 ./contrib/scripts/check-texinfo.awk > $(srcdir)/texinfo_lint.log || true 69 @cd $(top_srcdir); find . -type f ! -path '*/.*' -name '*.texi' -print0 | xargs -0 ./contrib/scripts/check-texinfo.awk > $(srcdir)/texinfo_lint.log || true
75endif 70endif
71
72gana: gana-gns gana-gnunet-signatures
73
74gana-gns:
75 @cd $(top_srcdir)/src/gana/gnu-name-system-record-types; make; cp gnu_name_system_record_types.h ../../../src/include/
76 @cd $(top_srcdir)/src/gana/gnu-name-system-default-tlds; make; cp tlds.conf ../../../src/gns
77
78gana-gnunet-signatures:
79 @cd $(top_srcdir)/src/gana/gnunet-signatures; make; cp gnunet_signatures.h ../../../src/include
80
81