aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a5e36545a..daa2946a7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,11 +33,11 @@ ACLOCAL_AMFLAGS = -I m4
33check-bashism: 33check-bashism:
34 printf "Run checkbashism on all .sh files.\n" 34 printf "Run checkbashism on all .sh files.\n"
35 printf "Currently this expects checkbashism.pl at a fixed location." 35 printf "Currently this expects checkbashism.pl at a fixed location."
36 find . -type f ! -path '*/.*' ! -path '*/_*' -name '*.sh' -print0 | xargs -0 ~/src/scripts/src/checkbashisms.pl -f 36 find . -type f ! -path '*/.*' ! -path '*/_*' -name '*.sh' -print0 | xargs -0 ~/src/scripts/src/checkbashisms.pl -f 2>&1 | tee $(top_srcdir)/bashism.log || true
37 37
38check-python: 38check-python:
39 printf "Running flake8 and 2to3 if detected.\n" 39 printf "Running flake8 and 2to3 if detected.\n"
40 $(top_srcdir)/contrib/scripts/lint-python.sh 40 $(top_srcdir)/contrib/scripts/lint-python.sh || true
41 41
42check-man: 42check-man:
43 printf "Running lint-man.sh in doc/man.\n" 43 printf "Running lint-man.sh in doc/man.\n"