aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index fd18d7c3c..9be41951e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -27,3 +27,10 @@ docdir = $(datadir)/doc/gnunet/
27doc_DATA = COPYING README 27doc_DATA = COPYING README
28 28
29ACLOCAL_AMFLAGS = -I m4 29ACLOCAL_AMFLAGS = -I m4
30
31# Check for bashisms in shell scripts
32# Very verbose, need to exclude more files.
33check-bashism:
34 printf "Run checkbashism on all .sh files.\n"
35 printf "Currently this expects checkbashism.pl at a fixed location."
36 find . -type f ! -path '*/.*' ! -path '*/_*' -name '*.sh' -print0 | xargs -0 ~/src/scripts/src/checkbashisms.pl -f