aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3cf7e6cb6..581764b52 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1335,7 +1335,7 @@ CPPFLAGS=$SAVE_CPPFLAGS
1335 1335
1336# test for postgres: 1336# test for postgres:
1337postgres=false 1337postgres=false
1338AX_LIB_POSTGRESQL([9.5], 1338AX_LIB_POSTGRESQL([12.0],
1339 [CPPFLAGS="$CPPFLAGS $POSTGRESQL_CPPFLAGS" 1339 [CPPFLAGS="$CPPFLAGS $POSTGRESQL_CPPFLAGS"
1340 AC_CHECK_HEADERS([libpq-fe.h], 1340 AC_CHECK_HEADERS([libpq-fe.h],
1341 postgres=true) 1341 postgres=true)
@@ -1817,6 +1817,16 @@ AC_MSG_RESULT($use_gcov)
1817AM_CONDITIONAL([USE_COVERAGE], [test "x$use_gcov" = "xyes"]) 1817AM_CONDITIONAL([USE_COVERAGE], [test "x$use_gcov" = "xyes"])
1818 1818
1819 1819
1820# Temporarily disable a specific piece of code until TNG is out.
1821AC_ARG_ENABLE([transport-timing-diagnostic],
1822 [AS_HELP_STRING([--enable-transport-timing-diagnostic],
1823 [enable logging of transport (not TNG) sending times])],
1824 [enable_ttd=yes],
1825 [enable_ttd=no])
1826AS_IF([test "x$enable_ttd" = "xyes"],
1827 [AC_DEFINE([ENABLE_TTD], [1], [Define if transport (not TNG) should warn about sending times.])])
1828
1829
1820# version info 1830# version info
1821# TODO: git blame says this predates our switch to git. 1831# TODO: git blame says this predates our switch to git.
1822# git-svn should be adjusted to simply git, or 1832# git-svn should be adjusted to simply git, or