aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac67
1 files changed, 20 insertions, 47 deletions
diff --git a/configure.ac b/configure.ac
index 94c0a7689..6dc914c12 100644
--- a/configure.ac
+++ b/configure.ac
@@ -786,12 +786,9 @@ AC_ARG_WITH(jansson,
786 ], 786 ],
787 [AC_MSG_RESULT([--with-jansson not specified]) 787 [AC_MSG_RESULT([--with-jansson not specified])
788 CHECK_LIBHEADER(JANSSON, jansson, json_loads, jansson.h,jansson=1,)]) 788 CHECK_LIBHEADER(JANSSON, jansson, json_loads, jansson.h,jansson=1,)])
789AM_CONDITIONAL(HAVE_JANSSON, [test "$jansson" = 1])
790AM_CONDITIONAL(HAVE_JSON, [test x$jansson = x1])
791AS_IF([test "x$jansson" = x1],
792 [AC_DEFINE([HAVE_JANSSON],[1],[Have jansson library])],
793 [AC_DEFINE([HAVE_JANSSON],[0],[Lacking jansson library])])
794 789
790AS_IF([test "x$jansson" != x1],
791 [AC_MSG_ERROR([GNUnet requires libjansson])])
795 792
796# check for libpulse(audio) library 793# check for libpulse(audio) library
797pulse=0 794pulse=0
@@ -984,8 +981,8 @@ AS_IF([test "x$curl" = xtrue],[
984 AC_CHECK_HEADER([curl/curl.h], 981 AC_CHECK_HEADER([curl/curl.h],
985 AC_CHECK_DECLS(CURLINFO_TLS_SESSION,[curl=true],[curl=false],[[#include <curl/curl.h>]]), 982 AC_CHECK_DECLS(CURLINFO_TLS_SESSION,[curl=true],[curl=false],[[#include <curl/curl.h>]]),
986 [curl=false]) 983 [curl=false])
987 # need libcurl-gnutls.so, everything else is not acceptable 984 # need libcurl-gnutls.so for proxy, warn later if not found.
988 AC_CHECK_LIB([curl-gnutls],[curl_easy_getinfo],,[curl=false]) 985 AC_CHECK_LIB([curl-gnutls],[curl_easy_getinfo],[curl_gnutls=true],[curl_gnutls=false])
989 # cURL must support CURLINFO_TLS_SESSION, version >= 7.34 986 # cURL must support CURLINFO_TLS_SESSION, version >= 7.34
990]) 987])
991 988
@@ -1000,7 +997,7 @@ AS_IF([test "$gnurl" = 1],
1000 AC_DEFINE([HAVE_LIBGNURL],[0],[Lacking libgnurl]) 997 AC_DEFINE([HAVE_LIBGNURL],[0],[Lacking libgnurl])
1001 AM_CONDITIONAL(HAVE_LIBCURL, true) 998 AM_CONDITIONAL(HAVE_LIBCURL, true)
1002 AC_DEFINE([HAVE_LIBCURL],[1],[Have libcurl])], 999 AC_DEFINE([HAVE_LIBCURL],[1],[Have libcurl])],
1003 [AC_MSG_WARN([ERROR: GNUnet requires libcurl-gnutls or gnurl >= 7.34]) 1000 [AC_MSG_ERROR([GNUnet requires libcurl or gnurl >= 7.34])
1004 AM_CONDITIONAL(HAVE_LIBGNURL, false) 1001 AM_CONDITIONAL(HAVE_LIBGNURL, false)
1005 AC_DEFINE([HAVE_LIBGNURL],[0],[Lacking libgnurl]) 1002 AC_DEFINE([HAVE_LIBGNURL],[0],[Lacking libgnurl])
1006 AM_CONDITIONAL(HAVE_LIBCURL, false) 1003 AM_CONDITIONAL(HAVE_LIBCURL, false)
@@ -1036,20 +1033,10 @@ AS_IF([test x$nss = xfalse],
1036AC_CHECK_LIB([kvm],[kvm_open]) 1033AC_CHECK_LIB([kvm],[kvm_open])
1037AC_CHECK_LIB([kstat],[kstat_open]) 1034AC_CHECK_LIB([kstat],[kstat_open])
1038 1035
1039argon=0
1040# test for argon2 (for POW)
1041AC_CHECK_LIB([argon2],[argon2d_hash_raw], argon=1, argon=0)
1042AS_IF([test x$argon = x1],
1043[
1044 AC_MSG_RESULT([argon2 found])
1045],[
1046 AC_MSG_ERROR([GNUnet requires argon2.])
1047])
1048
1049libsodium=0 1036libsodium=0
1050# test for libsodium 1037# test for libsodium
1051AC_CHECK_HEADER([sodium.h], 1038AC_CHECK_HEADER([sodium.h],
1052 [AC_CHECK_LIB([sodium], [sodium_init], 1039 [AC_CHECK_LIB([sodium], [crypto_pwhash_argon2id],
1053 [libsodium=1])]) 1040 [libsodium=1])])
1054 1041
1055AS_IF([test x$libsodium = x0], 1042AS_IF([test x$libsodium = x0],
@@ -1472,6 +1459,9 @@ AC_DEFINE_UNQUOTED([HAVE_MHD], $lmhd, [We have libmicrohttpd])
1472 1459
1473AM_CONDITIONAL(HAVE_JSON, [test x$jansson = x1]) 1460AM_CONDITIONAL(HAVE_JSON, [test x$jansson = x1])
1474AM_CONDITIONAL(HAVE_REST, [test x$jansson = x1 -a x$lmhd = x1]) 1461AM_CONDITIONAL(HAVE_REST, [test x$jansson = x1 -a x$lmhd = x1])
1462AS_IF([test "x$lmhd" != "x1"],
1463 [AC_MSG_ERROR([GNUnet requires libmicrohttpd >= 0.9.63.])])
1464
1475 1465
1476# restore LIBS 1466# restore LIBS
1477LIBS=$SAVE_LIBS 1467LIBS=$SAVE_LIBS
@@ -2001,7 +1991,7 @@ AS_IF([test "x$enable_java_ports" = "xyes"],
2001#### This could be moved to the checks above, 1991#### This could be moved to the checks above,
2002#### but for now let's keep it here. 1992#### but for now let's keep it here.
2003#### 1993####
2004transport_msg="tcp udp unix" 1994transport_msg="tcp udp unix http"
2005AS_IF([test "x$build_target" = "xlinux" -a "x$enable_experimental" = "xyes"], 1995AS_IF([test "x$build_target" = "xlinux" -a "x$enable_experimental" = "xyes"],
2006 [transport_msg="$transport_msg wlan"]) 1996 [transport_msg="$transport_msg wlan"])
2007# -- print message regarding enabled experimental features 1997# -- print message regarding enabled experimental features
@@ -2047,26 +2037,10 @@ AS_IF([test "x$conversation_backend" = "xnone"],
2047 [AS_IF([test "x$opus" = x1], 2037 [AS_IF([test "x$opus" = x1],
2048 [conversation_msg="yes (x$conversation_backend)"], 2038 [conversation_msg="yes (x$conversation_backend)"],
2049 [AC_MSG_WARN([libopus not found (required to build conversation)])])]) 2039 [AC_MSG_WARN([libopus not found (required to build conversation)])])])
2050# -- rest / oidc
2051rest_msg="no"
2052AS_IF([test "x$lmhd" = "x1" -a "x$jansson" = "x1"],
2053 [rest_msg="yes"
2054 reclaim_msg="yes (with OpenID Connect)"],
2055 [rest_msg="no"
2056 reclaim_msg="yes (without OpenID Connect)"])
2057
2058 2040
2059# -- interface 2041# -- interface
2060interface_msg=`echo $DEFAULT_INTERFACE | tr -d \"` 2042interface_msg=`echo $DEFAULT_INTERFACE | tr -d \"`
2061# -- libmicrohttpd
2062AS_IF([test "x$lmhd" = "x0"],
2063 [libmicrohttpd_msg="no (REST service and HTTP transport will not be built)"],
2064 [libmicrohttpd_msg="yes"
2065 transport_msg="$transport_msg http_server"])
2066# -- jansson 2043# -- jansson
2067AS_IF([test "x$jansson" = "x0"],
2068 [jansson_msg="no (REST service will not be built)"],
2069 [jansson_msg="yes"])
2070# -- libextractor 2044# -- libextractor
2071AS_IF([test "$extractor" != 1], 2045AS_IF([test "$extractor" != 1],
2072 [AC_MSG_WARN([libextractor not found, but various file-sharing functions require it])], 2046 [AC_MSG_WARN([libextractor not found, but various file-sharing functions require it])],
@@ -2080,11 +2054,15 @@ AS_IF([test "$gnurl" = "0"],
2080 [AS_IF([test "x$curl" = "xfalse"], 2054 [AS_IF([test "x$curl" = "xfalse"],
2081 [AC_MSG_WARN([libgnurl not found. http client support will not be compiled.]) 2055 [AC_MSG_WARN([libgnurl not found. http client support will not be compiled.])
2082 AC_MSG_WARN([IMPORTANT: No HTTP client library found. HTTP transports and hostlist daemon will not be compiled, and you probably WANT the hostlist daemon]) 2056 AC_MSG_WARN([IMPORTANT: No HTTP client library found. HTTP transports and hostlist daemon will not be compiled, and you probably WANT the hostlist daemon])
2083 curl_msg="no"], 2057 http_client="none"],
2084 [AC_MSG_NOTICE([libgnurl not found, trying to use libcurl-gnutls instead.]) 2058 [AC_MSG_NOTICE([Using libcurl as HTTP client library.])
2085 curl_msg="yes"])], 2059 http_client="curl"])],
2086 [gnurl_msg="yes" 2060 [AC_MSG_NOTICE([Using libgnurl as HTTP client library.])
2087 transport_msg="$transport_msg http_client"]) 2061 http_client="gnurl"])
2062AS_IF([test "x$curl" = "xtrue" -a "x$curl_gnutls" != "xtrue"],
2063 [AC_MSG_WARN([libcurl TLS backend is not gnutls. The GNS Proxy will likely not function properly.])
2064 http_client="curl-openssl"],
2065 [http_client="curl-gnutls"])
2088# -- ifconfig 2066# -- ifconfig
2089AS_IF([test "$VAR_IFCONFIG_BINARY" = "false"], 2067AS_IF([test "$VAR_IFCONFIG_BINARY" = "false"],
2090 [ifconfig_msg="no (optional, some features will not work)"], 2068 [ifconfig_msg="no (optional, some features will not work)"],
@@ -2160,17 +2138,14 @@ Default Interface: ${interface_msg}
2160MySQL: ${mysql_msg} 2138MySQL: ${mysql_msg}
2161PostgreSQL: ${postgres_msg} 2139PostgreSQL: ${postgres_msg}
2162sqlite3: ${sqlite_msg} 2140sqlite3: ${sqlite_msg}
2163gnurl: ${gnurl_msg} 2141http client: ${http_client}
2164curl: ${curl_msg}
2165bluetooth: ${bluetooth_msg} 2142bluetooth: ${bluetooth_msg}
2166jansson: ${jansson_msg}
2167iptables: ${iptables_msg} 2143iptables: ${iptables_msg}
2168ifconfig: ${ifconfig_msg} 2144ifconfig: ${ifconfig_msg}
2169upnpc: ${upnpc_msg} 2145upnpc: ${upnpc_msg}
2170gnutls: ${gnutls_msg} 2146gnutls: ${gnutls_msg}
2171libzbar: ${libzbar_msg} 2147libzbar: ${libzbar_msg}
2172java: ${java_msg} 2148java: ${java_msg}
2173libmicrohttpd: ${libmicrohttpd_msg}
2174libidn: ${libidn1_msg}${libidn2_msg} 2149libidn: ${libidn1_msg}${libidn2_msg}
2175libopus: ${libopus_msg} 2150libopus: ${libopus_msg}
2176gstreamer: ${gstreamer_msg} 2151gstreamer: ${gstreamer_msg}
@@ -2182,9 +2157,7 @@ mandoc: ${mandoc_msg}
2182GNUnet configuration: 2157GNUnet configuration:
2183===================== 2158=====================
2184transports: ${transport_msg} 2159transports: ${transport_msg}
2185reclaimID: ${reclaim_msg}
2186conversation: ${conversation_msg} 2160conversation: ${conversation_msg}
2187rest: ${rest_msg}
2188database backends: ${features_msg} 2161database backends: ${features_msg}
2189experimental: ${experimental_msg} 2162experimental: ${experimental_msg}
2190 2163