aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 68cae8c0e..b6a4d21c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -558,6 +558,18 @@ AS_IF([test "x$include_manpages" = "xyes"],
558# texinfo5 switches are used. This comes with no version checks, is 558# texinfo5 switches are used. This comes with no version checks, is
559# enabled only at distributors action (ie defaults to "no"). 559# enabled only at distributors action (ie defaults to "no").
560# Mantis #3914 for more details (https://bugs.gnunet.org/view.php?id=3914) 560# Mantis #3914 for more details (https://bugs.gnunet.org/view.php?id=3914)
561# While GNU makeinfo 6.5 supports --css-ref=URL,
562# makeinfo 4.8 (in NetBSD 8.0, macOS, and maybe other
563# base) does only support --css-include=FILE.
564# The only difference is a shorter html output and
565# in 6.5 the ability to use refs instead of include.
566# We prefer not to break builds in this case, so
567# we use the include version which is backwards compatible
568# and upwards compatible, while the ref variant is neither.
569# In the 5.x version they added `--split=chapters|sections` in
570# addition to `--split=nodes`.
571# Hold on to your hats: In version 6.5 this is already removed, ffs.
572# GNU Texinfo, please be more consistent than 1 version in switches.
561AC_MSG_CHECKING(whether to enable texinfo4 switches) 573AC_MSG_CHECKING(whether to enable texinfo4 switches)
562AC_ARG_ENABLE([texinfo4], 574AC_ARG_ENABLE([texinfo4],
563 [AS_HELP_STRING([--enable-texinfo4], [Use texinfo version 4 specific switches])], 575 [AS_HELP_STRING([--enable-texinfo4], [Use texinfo version 4 specific switches])],
@@ -568,11 +580,15 @@ AS_IF([test "x$activate_texinfo4" = "xyes"],
568 [ 580 [
569 AM_CONDITIONAL([ACTIVATE_TEXINFO4],true) 581 AM_CONDITIONAL([ACTIVATE_TEXINFO4],true)
570 AC_DEFINE([ACTIVATE_TEXINFO4],[1],[Using texinfo version 4 specific switches]) 582 AC_DEFINE([ACTIVATE_TEXINFO4],[1],[Using texinfo version 4 specific switches])
583 TEXINFO_HTMLFLAGS="--no-split --css-include=style.css --css-include=manual.css"
571 ],[ 584 ],[
572 AM_CONDITIONAL([ACTIVATE_TEXINFO4],false) 585 AM_CONDITIONAL([ACTIVATE_TEXINFO4],false)
573 AC_DEFINE([INCLUDE_MANPAGES],[0],[Using texinfo version 5 or later switches]) 586 AC_DEFINE([INCLUDE_MANPAGES],[0],[Using texinfo version 5 or later switches])
587 TEXINFO_HTMLFLAGS="--split --css-ref='../style.css' --css-ref='../manual.css'"
588
574 ]) 589 ])
575 590
591AC_SUBST([TEXINFO_HTMLFLAGS])
576 592
577# Adam shostack suggests the following for Windows: 593# Adam shostack suggests the following for Windows:
578# -D_FORTIFY_SOURCE=2 -fstack-protector-all 594# -D_FORTIFY_SOURCE=2 -fstack-protector-all