aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 53db0bfaf..6471cb872 100644
--- a/configure.ac
+++ b/configure.ac
@@ -247,6 +247,25 @@ AC_PATH_PROG( PERL, perl, ,
247 $PATH:/usr/local/bin/perl:/usr/bin/:/usr/local/bin ) 247 $PATH:/usr/local/bin/perl:/usr/bin/:/usr/local/bin )
248AC_SUBST([PERL]) 248AC_SUBST([PERL])
249 249
250# should we install gnunet-logread?
251AC_MSG_CHECKING(whether to install gnunet-logread)
252AC_ARG_WITH([gnunet-logread],
253 [AS_HELP_STRING([--with-gnunet-logread],
254 [Install gnunet-logread])],
255 [logread=${withval}],
256 [logread=no])
257AC_MSG_RESULT($logread)
258AS_IF([test "x$logread" = "xyes"],
259 [AM_CONDITIONAL([GNUNET_LOGREAD], true)
260 AC_DEFINE([GNUNET_LOGREAD],
261 [1],
262 [Installing gnunet-logread])],
263 [AM_CONDITIONAL([GNUNET_LOGREAD],
264 false)
265 AC_DEFINE([GNUNET_LOGREAD],
266 [0],
267 [Not installing gnunet-logread])])
268
250# iptables is a soft requirement to run tests 269# iptables is a soft requirement to run tests
251AC_PATH_TARGET_TOOL(VAR_IPTABLES_BINARY, iptables, false) 270AC_PATH_TARGET_TOOL(VAR_IPTABLES_BINARY, iptables, false)
252 271