aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac536
1 files changed, 213 insertions, 323 deletions
diff --git a/configure.ac b/configure.ac
index b1bc03e91..316257f97 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
1# This file is part of GNUnet. 1# This file is part of GNUnet.
2# (C) 2001--2022 GNUnet e.V. 2# (C) 2001--2023 GNUnet e.V.
3# 3#
4# GNUnet is free software: you can redistribute it and/or modify it 4# GNUnet is free software: you can redistribute it and/or modify it
5# under the terms of the GNU Affero General Public License as published 5# under the terms of the GNU Affero General Public License as published
@@ -20,12 +20,22 @@
20# 20#
21# 21#
22AC_PREREQ([2.69]) 22AC_PREREQ([2.69])
23AC_INIT([gnunet],[m4_esyscmd_s(sh contrib/get_version.sh)],[bug-gnunet@gnu.org]) 23AC_INIT([gnunet],[m4_esyscmd_s(sh scripts/get_version.sh)],[bug-gnunet@gnu.org])
24
25gnunet_version=m4_esyscmd_s(sh scripts/get_version.sh)
26gnunet_major_version=m4_esyscmd_s(sh scripts/get_version.sh --major)
27gnunet_minor_version=m4_esyscmd_s(sh scripts/get_version.sh --minor)
28gnunet_micro_version=m4_esyscmd_s(sh scripts/get_version.sh --micro)
29
30AC_SUBST([gnunet_version])
31AC_SUBST([gnunet_major_version])
32AC_SUBST([gnunet_minor_version])
33AC_SUBST([gnunet_micro_version])
24 34
25AC_CONFIG_AUX_DIR([build-aux]) 35AC_CONFIG_AUX_DIR([build-aux])
26AC_CONFIG_MACRO_DIRS([m4]) 36AC_CONFIG_MACRO_DIRS([m4])
27 37
28AC_CONFIG_HEADERS([gnunet_config.h]) 38AC_CONFIG_HEADERS([gnunet_private_config.h])
29 39
30AC_CANONICAL_TARGET 40AC_CANONICAL_TARGET
31AC_CANONICAL_HOST 41AC_CANONICAL_HOST
@@ -441,26 +451,11 @@ AC_ARG_ENABLE([documentation],
441 [do not build the documentation])], 451 [do not build the documentation])],
442 [documentation=${enableval}], 452 [documentation=${enableval}],
443 [documentation=yes]) 453 [documentation=yes])
454
455AC_CHECK_PROG([DOXY_BINARY], [doxygen], [true], [false])
456AM_CONDITIONAL([HAVE_DOXY_BINARY], [$DOXY_BINARY])
457
444AM_CONDITIONAL([DOCUMENTATION], [test "x$documentation" = "xyes"]) 458AM_CONDITIONAL([DOCUMENTATION], [test "x$documentation" = "xyes"])
445AS_IF([test "x$documentation" = "xyes"],
446 [AC_DEFINE([DOCUMENTATION], [1], [Define to 1 if documentation is built])],
447 [AC_DEFINE([DOCUMENTATION], [0], [Define to 1 if documentation is built])])
448
449AC_ARG_ENABLE([texi2mdoc-generation],
450 [AS_HELP_STRING([--enable-texi2mdoc-generation],
451 [generate and install texi2mdoc output])],
452 [texi2mdoc_enabled=${enableval}],
453 [texi2mdoc_enabled=no])
454AM_CONDITIONAL([TEXI2MDOC_GENERATION], [test "x$texi2mdoc_enabled" = "xyes"])
455AS_IF([test "x$texi2mdoc_enabled" = "xyes"],
456 [AC_CHECK_PROGS([TEXI2MDOC_BINARY], [texi2mdoc], [false])
457 AS_IF([test "x$TEXI2MDOC_BINARY" != "xfalse"],
458 [AC_DEFINE([TEXI2MDOC_GENERATION], [1],
459 [Define to 1 if mdoc output is generated])],
460 [AC_DEFINE([TEXI2MDOC_GENERATION], [0],
461 [Define to 1 if mdoc output is generated])])],
462 [TEXI2MDOC_BINARY=false])
463AM_CONDITIONAL([HAVE_TEXI2MDOC], [test "x$TEXI2MDOC_BINARY" != "xfalse"])
464 459
465AC_CHECK_PROGS([MANDOC_BINARY], [mandoc], [false]) 460AC_CHECK_PROGS([MANDOC_BINARY], [mandoc], [false])
466AM_CONDITIONAL([HAVE_MANDOC], [test "x$MANDOC_BINARY" != "xfalse"]) 461AM_CONDITIONAL([HAVE_MANDOC], [test "x$MANDOC_BINARY" != "xfalse"])
@@ -489,44 +484,12 @@ AC_DEFINE_UNQUOTED([INCLUDE_MANPAGES], [$include_man],
489 [Define to 1 if man pages are included]) 484 [Define to 1 if man pages are included])
490AM_CONDITIONAL([INCLUDE_MANPAGES], [test "x$include_man" = "x1"]) 485AM_CONDITIONAL([INCLUDE_MANPAGES], [test "x$include_man" = "x1"])
491 486
492# Do we have texinfo4? If yes, it is used to set texinfo4 specific switches
493# (not syntax!) to the commandline tools which generate the html. If not,
494# texinfo5 switches are used. This comes with no version checks, is
495# enabled only at distributors action (ie defaults to "no").
496# Mantis #3914 for more details (https://bugs.gnunet.org/view.php?id=3914)
497# While GNU makeinfo 6.5 supports --css-ref=URL,
498# makeinfo 4.8 (in NetBSD 8.0, macOS, and maybe other
499# base) does only support --css-include=FILE.
500# The only difference is a shorter html output and
501# in 6.5 the ability to use refs instead of include.
502# We prefer not to break builds in this case, so
503# we use the include version which is backwards compatible
504# and upwards compatible, while the ref variant is neither.
505# In the 5.x version they added `--split=chapters|sections` in
506# addition to `--split=nodes`.
507# Hold on to your hats: In version 6.5 this is already removed, ffs.
508# GNU Texinfo, please be more consistent than 1 version in switches.
509AC_ARG_ENABLE([texinfo4],
510 [AS_HELP_STRING([--enable-texinfo4],
511 [Use Texinfo version 4 specific switches])],
512 [activate_texinfo4=${enableval}],
513 [activate_texinfo4=no])
514AM_CONDITIONAL([ACTIVATE_TEXINFO4], [test "x$activate_texinfo4" = "xyes"])
515AS_IF([test "x$activate_texinfo4" = "xyes"],
516 [AC_DEFINE([ACTIVATE_TEXINFO4], [1],
517 [Define to 1 if using Texinfo v4 switches])
518 TEXINFO_HTMLFLAGS="--no-split --css-include=style.css --css-include=manual.css"],
519 [AC_DEFINE([ACTIVATE_TEXINFO4], [0],
520 [Define to 1 if using Texinfo v4 switches])
521 TEXINFO_HTMLFLAGS="--no-split --css-ref='../style.css' --css-ref='../manual.css'"])
522AC_SUBST([TEXINFO_HTMLFLAGS])
523
524# Hardening options 487# Hardening options
525AC_ARG_ENABLE([gcc-hardening], 488AC_ARG_ENABLE([gcc-hardening],
526 [AS_HELP_STRING([--enable-gcc-hardening], [enable compiler security checks])], 489 [AS_HELP_STRING([--enable-gcc-hardening], [enable compiler security checks])],
527 [AS_IF([test "x$enableval" = "xyes"], 490 [AS_IF([test "x$enableval" = "xyes"],
528 [CFLAGS="$CFLAGS -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-all" 491 [CFLAGS="$CFLAGS -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-all"
529 CFLAGS="$CFLAGS -fwrapv -fPIE -Wstacl-protector" 492 CFLAGS="$CFLAGS -fwrapv -fPIE -Wstack-protector"
530 CFLAGS="$CFLAGS --param ssp-buffer-size=1" 493 CFLAGS="$CFLAGS --param ssp-buffer-size=1"
531 LDFLAGS="$LDFLAGS -pie"])]) 494 LDFLAGS="$LDFLAGS -pie"])])
532 495
@@ -640,16 +603,6 @@ gcry_md_close (mac);]])],
640 [AC_MSG_RESULT([cross compiling, test skipped])]) 603 [AC_MSG_RESULT([cross compiling, test skipped])])
641 AC_LANG_POP([C])]) 604 AC_LANG_POP([C])])
642 605
643AC_MSG_CHECKING([for static assertion support])
644AC_COMPILE_IFELSE([AC_LANG_PROGRAM([],
645 [[_Static_assert(sizeof(int) >= 4, "not big enough");]])],
646 [AC_MSG_RESULT([yes])
647 AC_DEFINE([HAVE_STATIC_ASSERT], [1],
648 [Define to 1 if static assert is supported])],
649 [AC_MSG_RESULT([no])
650 AC_DEFINE([HAVE_STATIC_ASSERT], [0],
651 [Define to 1 if static assert is supported])])
652
653dnl Helper function to shorten the amount of repeated code 606dnl Helper function to shorten the amount of repeated code
654dnl It will create a --with-<lib> option for configure. 607dnl It will create a --with-<lib> option for configure.
655dnl 608dnl
@@ -736,18 +689,6 @@ CHECK_WITH_LIB([opus], [opus_decode_float], [opus/opus.h], [HAVE_OPUS])
736# check for libogg 689# check for libogg
737CHECK_WITH_LIB([ogg], [ogg_stream_flush_fill], [ogg/ogg.h], [HAVE_OGG]) 690CHECK_WITH_LIB([ogg], [ogg_stream_flush_fill], [ogg/ogg.h], [HAVE_OGG])
738 691
739PKG_CHECK_MODULES([GLIB], [glib-2.0],
740 [AC_CHECK_HEADER([pbc/pbc.h], [pbc=1], [pbc=0])
741 AC_CHECK_HEADER([gabe.h], [abe=1], [abe=0])
742 AM_CONDITIONAL([HAVE_PBC], [test "x$pbc" = "x1"])
743 AM_CONDITIONAL([HAVE_ABE], [test "x$abe" = "x1"])
744 AC_DEFINE_UNQUOTED([HAVE_PBC], [$pbc], [Define to 1 if pbc is available])
745 AC_DEFINE_UNQUOTED([HAVE_ABE], [$abe], [Define to 1 if abe is available])],
746 [AM_CONDITIONAL([HAVE_PBC], [false])
747 AM_CONDITIONAL([HAVE_ABE], [false])
748 AC_DEFINE([HAVE_PBC], [0], [Define to 1 if pbc is available])
749 AC_DEFINE([HAVE_ABE], [0], [Define to 1 if abe is available])])
750
751PKG_CHECK_MODULES([GST], 692PKG_CHECK_MODULES([GST],
752 [glib-2.0 gobject-2.0 gstreamer-1.0 gstreamer-app-1.0 gstreamer-audio-1.0], 693 [glib-2.0 gobject-2.0 gstreamer-1.0 gstreamer-app-1.0 gstreamer-audio-1.0],
753 [gst=1], 694 [gst=1],
@@ -773,35 +714,36 @@ AS_IF([test "x$pulse" != "x1" || test "x$opus" != "x1" || test "x$ogg" != "x1"],
773AM_CONDITIONAL([BUILD_CONVERSATION], [test "x$conversation_backend" != "xnone"]) 714AM_CONDITIONAL([BUILD_CONVERSATION], [test "x$conversation_backend" != "xnone"])
774AC_MSG_RESULT([$conversation_backend]) 715AC_MSG_RESULT([$conversation_backend])
775 716
776# check for libgnurl 717# NOTE: If we find libcurl-gnutls here we set LIBCURL to -lcurl-gnutls
777LIBGNURL_CHECK_CONFIG([], [7.34.0], 718# This affects the LIBCURL_CHECK_CONFIG call below as it takes LIBCURL into
778 [gnurl=1 719# account when checking for curl.
779 curl=0], 720LIBCURL="-lcurl"
780 [gnurl=0 721AC_CHECK_LIB([curl-gnutls],
781 curl=0]) 722 [curl_easy_getinfo],
782AS_IF([test "x$gnurl" = "x0"], 723 [LIBCURL="-lcurl-gnutls"])
783 [LIBCURL_CHECK_CONFIG([], [7.34.0], [curl=1], [curl=0]) 724
784 AS_IF([test "x$curl" = "x0"], 725LIBCURL_CHECK_CONFIG([], [7.85.0], [],
785 [AC_CHECK_HEADER([curl/curl.h], 726 [AC_MSG_ERROR([cURL must have a version >= 7.85.0])])
786 [AC_CHECK_DECLS([CURLINFO_TLS_SESSION], 727
787 [curl=1], 728OLD_LIBS=$LIBS
788 [curl=0], 729LIBS="$LIBS $LIBCURL"
789 [[#include <curl/curl.h>]])]) 730AC_RUN_IFELSE(
790 AC_CHECK_LIB([curl-gnutls], 731 [AC_LANG_PROGRAM([[#include <curl/curl.h>]],
791 [curl_easy_getinfo], 732 [[return (CURLSSLSET_OK != curl_global_sslset(CURLSSLBACKEND_GNUTLS, NULL, NULL));]])],
792 [curl_gnutls=1], 733 [curl_gnutls=1],
793 [curl_gnutls=0])]) 734 [AC_MSG_WARN([cURL does not have GnuTLS backend])
794 AS_IF([test "x$curl" = "x0" || test "x$curl_gnutls" = "x0"], 735 curl_gnutls=0])
795 [AC_MSG_ERROR([cURL must have a version >= 7.34.0 and must support CURLINFO_TLS_SESSION])])]) 736LIBS=$OLD_LIBS
796 737AM_CONDITIONAL([HAVE_GNUTLS_CURL], [test "x$curl_gnutls" = "x1"])
797AS_IF([test "x$gnurl" = "x0" && test "x$curl" = "x0"], 738AC_SUBST([curl_gnutls])
798 [AC_MSG_ERROR([either gnurl or cURL must be available])]) 739
799 740# Even if curl is found, we check for this constant in order to determine
800AM_CONDITIONAL([HAVE_LIBGNURL], [test "x$gnurl" = "x1"]) 741# if we can use this feature.
801AC_DEFINE_UNQUOTED([HAVE_LIBGNURL], [$gnurl], [Define to 1 if libgnurl is used]) 742AC_CHECK_HEADER([curl/curl.h],
802AM_CONDITIONAL([HAVE_LIBCURL], [test "x$curl" = "x1"]) 743 [AC_CHECK_DECLS([CURLINFO_TLS_SSL_PTR],
803AC_DEFINE_UNQUOTED([HAVE_LIBCURL], [$curl], [Define to 0 if libcurl is used]) 744 [],
804 745 [AC_MSG_ERROR([cURL must support CURLINFO_TLS_SSL_PTR])],
746 [[#include <curl/curl.h>]])])
805# libatomic 747# libatomic
806AC_SEARCH_LIBS([__atomic_load_8], [atomic], 748AC_SEARCH_LIBS([__atomic_load_8], [atomic],
807 [have_libatomic=1 749 [have_libatomic=1
@@ -826,13 +768,9 @@ AC_CHECK_LIB([kstat], [kstat_open])
826 768
827# check for libsodium version >= 1.0.18 769# check for libsodium version >= 1.0.18
828libsodium=0 770libsodium=0
829AC_CHECK_HEADER([sodium.h], 771CHECK_WITH_LIB([sodium], [crypto_core_ed25519_scalar_mul], [sodium.h], [HAVE_SODIUM])
830 [AC_CHECK_LIB([sodium], [crypto_core_ed25519_scalar_mul], 772AS_IF([test "x$sodium" = "x0"],
831 [libsodium=1], 773 [AC_MSG_ERROR([GNUnet requires libsodium >= 1.0.18])])
832 [libsodium=0])])
833
834AS_IF([test "x$libsodium" = "x0"],
835 [AC_MSG_ERROR([GNUnet requires libsodium >= 1.0.18])])
836 774
837# check for libextractor 775# check for libextractor
838CHECK_WITH_LIB([extractor], 776CHECK_WITH_LIB([extractor],
@@ -842,6 +780,14 @@ CHECK_WITH_LIB([extractor],
842AS_IF([test "x$extractor" = "x0"], 780AS_IF([test "x$extractor" = "x0"],
843 [AC_MSG_RESULT([GNU libextractor not found, some features disabled])]) 781 [AC_MSG_RESULT([GNU libextractor not found, some features disabled])])
844 782
783# check for cloudflare-quiche
784CHECK_WITH_LIB([quiche],
785 [quiche_header_info],
786 [quiche.h],
787 [HAVE_QUICHE])
788AS_IF([test "x$quiche" = "x0"],
789 [AC_MSG_RESULT([cloudflare-quiche not found, some features disabled])])
790
845# check for libltdl 791# check for libltdl
846CHECK_WITH_LIB([ltdl], [lt_dlopenext], [ltdl.h], [HAVE_LTDL]) 792CHECK_WITH_LIB([ltdl], [lt_dlopenext], [ltdl.h], [HAVE_LTDL])
847AS_IF([test "x$ldtl" = "x0"], 793AS_IF([test "x$ldtl" = "x0"],
@@ -936,9 +882,9 @@ AC_DEFINE_UNQUOTED([HAVE_ZLIB], [$zlib_ok], [Define to 1 if zlib is available])
936AM_ICONV 882AM_ICONV
937 883
938# check for libunistring 884# check for libunistring
939gl_LIBUNISTRING 885CHECK_WITH_LIB([unistring], [u16_strstr], [unistr.h], [HAVE_UNISTRING])
940AS_IF([test "x$HAVE_LIBUNISTRING" != "xyes"], 886AS_IF([test "x$unistring" = "x0"],
941 [AC_MSG_ERROR([GNUnet requires libunistring])]) 887 [AC_MSG_ERROR([GNUnet requires unistring])])
942 888
943# Currently broken on Debian :-( 889# Currently broken on Debian :-(
944# AS_VERSION_COMPARE([$LIBUNISTRING_VERSION], [0.9.1.1], 890# AS_VERSION_COMPARE([$LIBUNISTRING_VERSION], [0.9.1.1],
@@ -958,76 +904,6 @@ AM_CONDITIONAL([HAVE_POSTGRESQL], [test "x$postgres" = "x1"])
958AC_DEFINE_UNQUOTED([HAVE_POSTGRESQL], [$postgres], 904AC_DEFINE_UNQUOTED([HAVE_POSTGRESQL], [$postgres],
959 [Define to 1 if Postgres is available]) 905 [Define to 1 if Postgres is available])
960 906
961# check for mysql
962SAVE_LDFLAGS="$LDFLAGS"
963SAVE_CPPFLAGS="$CPPFLAGS"
964AC_ARG_WITH([mysql],
965 [AS_HELP_STRING([--with-mysql=PFX], [base of mysql installation])],
966 [AS_CASE([$withval],
967 [no],
968 [],
969 [yes|""],
970 [AC_CHECK_HEADERS([mysql/mysql.h],
971 [AC_CHECK_LIB([mysqlclient], [mysql_init],
972 [mysql=true], [mysql=false])])],
973 [LDFLAGS="-L$with_mysql/lib -L$with_mysql/lib/mysql $LDFLAGS $ZLIBS"
974 CPPFLAGS="-I$with_mysql/include $CPPFLAGS"
975 AC_CHECK_HEADERS([mysql/mysql.h],
976 [AC_CHECK_LIB([mysqlclient], [mysql_init],
977 [MYSQL_LDFLAGS="-L$with_mysql/lib -L$with_mysql/lib/mysql"
978 MYSQL_CPPFLAGS="-I$with_mysql/include"
979 mysql=true],
980 [mysql=false])])])],
981 [AS_IF([test -d "/usr/lib64/mysql"],
982 [MYSQL_LIBDIR="/usr/lib64/mysql"],
983 [AS_IF([test -d "/usr/lib/mysql"],
984 [MYSQL_LIBDIR="/usr/lib/mysql"],
985 [MYSQL_LIBDIR="/usr/lib"])])
986 LDFLAGS="-L$MYSQL_LIBDIR $LDFLAGS $ZLIBS"
987 AC_CHECK_LIB([mysqlclient], [mysql_init],
988 [AC_CHECK_HEADERS([mysql/mysql.h],
989 [MYSQL_LDFLAGS="-L$MYSQL_LIBDIR"
990 mysql=true],
991 [mysql=false])],
992 [mysql=false])])
993AC_SUBST(MYSQL_LDFLAGS)
994AC_SUBST(MYSQL_CPPFLAGS)
995
996# additional version checks for mysql
997AS_IF([test "x$mysql" = "xtrue"],
998 [AC_MSG_CHECKING([for mysql version])
999 AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
1000 [[#include <mysql/mysql_version.h>]],
1001 [[#if (MYSQL_VERSION_ID < 40100)
1002#error required at least version 4.1
1003#endif]])],
1004 [mysql=true],
1005 [mysql=false])
1006 AS_IF([test "x$mysql" = "xfalse"],
1007 [AC_MSG_RESULT([< 4.1])
1008 AC_MSG_RESULT([mysql version >= 4.1 required. Will not use MySQL])])
1009 AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
1010 [[#include <mysql/mysql_version.h>]],
1011 [[#if (MYSQL_VERSION_ID < 80000)
1012#error needs at least version 8.0
1013#endif]])],
1014 [mysql8=true],
1015 [mysql8=false])])
1016
1017AS_IF([test "x$mysql" = "xtrue"],
1018 [AS_IF([test "x$mysql8" = "xfalse"],
1019 [AC_MSG_RESULT([between 4.1 and 8.0])],
1020 [AC_MSG_RESULT([> 8.0])
1021 AC_DEFINE([HAVE_MYSQL8], [1],
1022 [Define to 1 if MySQL is at least version 8])])])
1023
1024AM_CONDITIONAL([HAVE_MYSQL], [test "x$mysql" = "xtrue"])
1025AM_CONDITIONAL([HAVE_MYSQLE], [false])
1026
1027AS_IF([test "x$sqlite3" = "x0" && test "x$mysql" = "xfalse" && test "x$postgres" = "x0"],
1028 [AC_MSG_ERROR([GNUnet requires either SQLite, MySQL/MariaDB or PostgreSQL])])
1029
1030LDFLAGS="$SAVE_LDFLAGS"
1031CPPFLAGS="$SAVE_CPPFLAGS" 907CPPFLAGS="$SAVE_CPPFLAGS"
1032 908
1033# check for libmicrohttpd 909# check for libmicrohttpd
@@ -1241,6 +1117,10 @@ AC_ARG_ENABLE([experimental],
1241 [enable_experimental=1])], 1117 [enable_experimental=1])],
1242 [enable_experimental=0]) 1118 [enable_experimental=0])
1243AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "x1"]) 1119AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "x1"])
1120AS_IF([test "x$enable_experimental" = "x1"],
1121 AC_DEFINE([GNUNET_EXPERIMENTAL], 1, [Set to 1 is this is an experimental build]))
1122
1123AC_SUBST([enable_experimental])
1244 1124
1245# check if malicious code should be compiled (for testing) 1125# check if malicious code should be compiled (for testing)
1246AC_ARG_ENABLE([malicious], 1126AC_ARG_ENABLE([malicious],
@@ -1332,9 +1212,10 @@ AC_DEFINE_UNQUOTED([VCS_VERSION], [$vcs_version],
1332 1212
1333AC_CONFIG_FILES([ 1213AC_CONFIG_FILES([
1334Makefile 1214Makefile
1335bin/Makefile
1336contrib/Makefile 1215contrib/Makefile
1337contrib/hellos/Makefile 1216data/Makefile
1217data/hellos/Makefile
1218scripts/Makefile
1338contrib/services/Makefile 1219contrib/services/Makefile
1339contrib/services/openrc/Makefile 1220contrib/services/openrc/Makefile
1340contrib/services/systemd/Makefile 1221contrib/services/systemd/Makefile
@@ -1343,114 +1224,141 @@ contrib/scripts/gnunet-logread/Makefile
1343doc/Makefile 1224doc/Makefile
1344doc/man/Makefile 1225doc/man/Makefile
1345doc/doxygen/Makefile 1226doc/doxygen/Makefile
1346doc/handbook/Makefile
1347doc/tutorial/Makefile
1348m4/Makefile 1227m4/Makefile
1349po/Makefile.in 1228po/Makefile.in
1350src/Makefile 1229src/Makefile
1351src/arm/Makefile 1230src/lib/Makefile
1352src/arm/arm.conf 1231src/lib/util/Makefile
1353src/ats/Makefile 1232src/lib/block/Makefile
1354src/ats/ats.conf 1233src/lib/curl/Makefile
1355src/ats-tool/Makefile 1234src/lib/gnsrecord/Makefile
1356src/auction/Makefile 1235src/lib/json/Makefile
1357src/block/Makefile 1236src/lib/pq/Makefile
1358src/cadet/Makefile 1237src/lib/sq/Makefile
1359src/cadet/cadet.conf 1238src/plugin/Makefile
1360src/core/Makefile 1239src/plugin/block/Makefile
1361src/core/core.conf 1240src/plugin/datacache/Makefile
1362src/consensus/Makefile 1241src/plugin/datastore/Makefile
1363src/consensus/consensus.conf 1242src/plugin/dht/Makefile
1364src/conversation/Makefile 1243src/plugin/dns/Makefile
1365src/conversation/conversation.conf 1244src/plugin/fs/Makefile
1366src/curl/Makefile 1245src/plugin/gns/Makefile
1367src/datacache/Makefile 1246src/plugin/gnsrecord/Makefile
1368src/datastore/Makefile 1247src/plugin/namecache/Makefile
1369src/datastore/datastore.conf 1248src/plugin/namestore/Makefile
1370src/dht/Makefile 1249src/plugin/peerstore/Makefile
1371src/dht/dht.conf 1250src/plugin/reclaim/Makefile
1372src/dhtu/Makefile 1251src/plugin/regex/Makefile
1373src/dns/Makefile 1252src/plugin/revocation/Makefile
1374src/dns/dns.conf 1253src/plugin/seti/Makefile
1375src/exit/Makefile 1254src/plugin/setu/Makefile
1376src/fragmentation/Makefile 1255src/plugin/messenger/Makefile
1377src/fs/Makefile 1256src/service/Makefile
1378src/fs/fs.conf 1257src/service/arm/Makefile
1379src/gns/Makefile 1258src/service/arm/arm.conf
1380src/gns/gns.conf 1259src/service/cadet/Makefile
1381src/gns/nss/Makefile 1260src/service/cadet/cadet.conf
1382src/gnsrecord/Makefile 1261src/service/core/Makefile
1383src/hello/Makefile 1262src/service/core/core.conf
1384src/identity/Makefile 1263src/service/datacache/Makefile
1385src/identity/identity.conf 1264src/service/datastore/Makefile
1265src/service/datastore/datastore.conf
1266src/service/dht/Makefile
1267src/service/dht/dht.conf
1268src/service/dns/Makefile
1269src/service/dns/dns.conf
1270src/service/exit/Makefile
1271src/service/fs/Makefile
1272src/service/fs/fs.conf
1273src/service/gns/Makefile
1274src/service/gns/gns.conf
1275src/service/gns/nss/Makefile
1276src/service/hostlist/Makefile
1277src/service/identity/Makefile
1278src/service/identity/identity.conf
1279src/service/messenger/Makefile
1280src/service/messenger/messenger.conf
1281src/service/namecache/Makefile
1282src/service/namecache/namecache.conf
1283src/service/namestore/Makefile
1284src/service/namestore/namestore.conf
1285src/service/nat/Makefile
1286src/service/nat/nat.conf
1287src/service/nat-auto/Makefile
1288src/service/nat-auto/nat-auto.conf
1289src/service/nse/Makefile
1290src/service/nse/nse.conf
1291src/service/peerstore/Makefile
1292src/service/peerstore/peerstore.conf
1293src/service/pt/Makefile
1294src/service/reclaim/Makefile
1295src/service/regex/Makefile
1296src/service/regex/regex.conf
1297src/service/rest/Makefile
1298src/service/revocation/Makefile
1299src/service/revocation/revocation.conf
1300src/service/seti/Makefile
1301src/service/seti/seti.conf
1302src/service/setu/Makefile
1303src/service/setu/setu.conf
1304src/service/statistics/Makefile
1305src/service/statistics/statistics.conf
1306src/service/testing/Makefile
1307src/service/topology/Makefile
1308src/service/transport/Makefile
1309src/service/transport/transport.conf
1310src/service/util/Makefile
1311src/service/util/resolver.conf
1312src/service/vpn/Makefile
1313src/service/vpn/vpn.conf
1314src/service/zonemaster/Makefile
1315src/service/zonemaster/zonemaster.conf
1316src/cli/Makefile
1317src/cli/arm/Makefile
1318src/cli/cadet/Makefile
1319src/cli/core/Makefile
1320src/cli/datastore/Makefile
1321src/cli/dht/Makefile
1322src/cli/fs/Makefile
1323src/cli/gns/Makefile
1324src/cli/identity/Makefile
1325src/cli/messenger/Makefile
1326src/cli/namecache/Makefile
1327src/cli/namestore/Makefile
1328src/cli/peerstore/Makefile
1329src/cli/nat/Makefile
1330src/cli/nat-auto/Makefile
1331src/cli/nse/Makefile
1332src/cli/reclaim/Makefile
1333src/cli/revocation/Makefile
1334src/cli/statistics/Makefile
1335src/cli/util/Makefile
1336src/cli/vpn/Makefile
1337src/contrib/Makefile
1338src/contrib/service/Makefile
1339src/contrib/service/abd/Makefile
1340src/contrib/service/abd/abd.conf
1341src/contrib/service/auction/Makefile
1342src/contrib/service/consensus/Makefile
1343src/contrib/service/consensus/consensus.conf
1344src/contrib/service/conversation/Makefile
1345src/contrib/service/conversation/conversation.conf
1346src/contrib/service/scalarproduct/Makefile
1347src/contrib/service/scalarproduct/scalarproduct.conf
1348src/contrib/service/secretsharing/Makefile
1349src/contrib/service/secretsharing/secretsharing.conf
1350src/contrib/service/set/Makefile
1351src/contrib/service/set/set.conf
1352src/contrib/service/rps/Makefile
1353src/contrib/service/rps/rps.conf
1354src/contrib/service/template/Makefile
1355src/contrib/cli/Makefile
1356src/contrib/cli/template/Makefile
1357src/lib/hello/Makefile
1386src/include/Makefile 1358src/include/Makefile
1387src/integration-tests/Makefile 1359src/include/gnunet_config.h
1388src/json/Makefile
1389src/hostlist/Makefile
1390src/my/Makefile
1391src/mysql/Makefile
1392src/namecache/Makefile
1393src/namecache/namecache.conf
1394src/namestore/Makefile
1395src/namestore/namestore.conf
1396src/nat/Makefile
1397src/nat/nat.conf
1398src/nat-auto/Makefile
1399src/nat-auto/nat-auto.conf
1400src/nse/Makefile
1401src/nse/nse.conf
1402src/nt/Makefile
1403src/peerinfo/Makefile
1404src/peerinfo/peerinfo.conf
1405src/peerinfo-tool/Makefile
1406src/peerstore/Makefile
1407src/peerstore/peerstore.conf
1408src/pq/Makefile
1409src/pt/Makefile
1410src/regex/Makefile
1411src/regex/regex.conf
1412src/revocation/Makefile
1413src/revocation/revocation.conf
1414src/rps/Makefile
1415src/rps/rps.conf
1416src/secretsharing/Makefile
1417src/secretsharing/secretsharing.conf
1418src/scalarproduct/Makefile
1419src/scalarproduct/scalarproduct.conf
1420src/set/Makefile
1421src/set/set.conf
1422src/seti/Makefile
1423src/seti/seti.conf
1424src/setu/Makefile
1425src/setu/setu.conf
1426src/sq/Makefile
1427src/statistics/Makefile
1428src/statistics/statistics.conf
1429src/template/Makefile
1430src/testbed/Makefile
1431src/testbed/testbed.conf
1432src/testbed-logger/Makefile
1433src/testbed-logger/testbed-logger.conf
1434src/testing/Makefile
1435src/topology/Makefile
1436src/transport/Makefile
1437src/transport/transport.conf
1438src/util/Makefile
1439src/util/resolver.conf
1440src/vpn/Makefile
1441src/vpn/vpn.conf
1442src/zonemaster/Makefile
1443src/zonemaster/zonemaster.conf
1444src/rest/Makefile
1445src/abd/Makefile
1446src/abd/abd.conf
1447src/abe/Makefile
1448src/reclaim/Makefile
1449src/messenger/Makefile
1450src/messenger/messenger.conf
1451pkgconfig/Makefile 1360pkgconfig/Makefile
1452pkgconfig/gnunetarm.pc 1361pkgconfig/gnunetarm.pc
1453pkgconfig/gnunetats.pc
1454pkgconfig/gnunetblock.pc 1362pkgconfig/gnunetblock.pc
1455pkgconfig/gnunetcadet.pc 1363pkgconfig/gnunetcadet.pc
1456pkgconfig/gnunetconsensus.pc 1364pkgconfig/gnunetconsensus.pc
@@ -1460,19 +1368,18 @@ pkgconfig/gnunetdatacache.pc
1460pkgconfig/gnunetdatastore.pc 1368pkgconfig/gnunetdatastore.pc
1461pkgconfig/gnunetdht.pc 1369pkgconfig/gnunetdht.pc
1462pkgconfig/gnunetdns.pc 1370pkgconfig/gnunetdns.pc
1463pkgconfig/gnunetenv.pc
1464pkgconfig/gnunetfragmentation.pc
1465pkgconfig/gnunetfs.pc 1371pkgconfig/gnunetfs.pc
1466pkgconfig/gnunetgns.pc 1372pkgconfig/gnunetgns.pc
1467pkgconfig/gnunethello.pc 1373pkgconfig/gnunethello.pc
1468pkgconfig/gnunetidentity.pc 1374pkgconfig/gnunetidentity.pc
1375pkgconfig/gnunetjson.pc
1376pkgconfig/gnunetmessenger.pc
1469pkgconfig/gnunetmicrophone.pc 1377pkgconfig/gnunetmicrophone.pc
1470pkgconfig/gnunetmysql.pc
1471pkgconfig/gnunetnamestore.pc 1378pkgconfig/gnunetnamestore.pc
1472pkgconfig/gnunetnat.pc 1379pkgconfig/gnunetnat.pc
1473pkgconfig/gnunetnse.pc 1380pkgconfig/gnunetnse.pc
1474pkgconfig/gnunetpeerinfo.pc
1475pkgconfig/gnunetpq.pc 1381pkgconfig/gnunetpq.pc
1382pkgconfig/gnunetreclaim.pc
1476pkgconfig/gnunetregex.pc 1383pkgconfig/gnunetregex.pc
1477pkgconfig/gnunetrevocation.pc 1384pkgconfig/gnunetrevocation.pc
1478pkgconfig/gnunetrps.pc 1385pkgconfig/gnunetrps.pc
@@ -1480,7 +1387,6 @@ pkgconfig/gnunetscalarproduct.pc
1480pkgconfig/gnunetset.pc 1387pkgconfig/gnunetset.pc
1481pkgconfig/gnunetspeaker.pc 1388pkgconfig/gnunetspeaker.pc
1482pkgconfig/gnunetstatistics.pc 1389pkgconfig/gnunetstatistics.pc
1483pkgconfig/gnunettestbed.pc
1484pkgconfig/gnunettesting.pc 1390pkgconfig/gnunettesting.pc
1485pkgconfig/gnunettransport.pc 1391pkgconfig/gnunettransport.pc
1486pkgconfig/gnunetutil.pc 1392pkgconfig/gnunetutil.pc
@@ -1510,23 +1416,15 @@ AS_IF([test "x$libidn_version" = "x2"],
1510 [libidn_msg="libidn2"], 1416 [libidn_msg="libidn2"],
1511 [libidn_msg="libidn"]) 1417 [libidn_msg="libidn"])
1512 1418
1513# texi2mdoc
1514AS_IF([test "x$texi2mdoc_enabled" = "xyes"],
1515 [mdocml_msg="yes"],
1516 [mdocml_msg="no"])
1517AS_IF([test "x$TEXI2MDOC_BINARY" = "xfalse"],
1518 [mdocbin_msg="no"],
1519 [mdocbin_msg="yes"])
1520
1521# mandoc 1419# mandoc
1522AS_IF([test "x$MANDOC_BINARY" = "xfalse"], 1420AS_IF([test "x$MANDOC_BINARY" = "xfalse"],
1523 [mandoc_msg="no"], 1421 [mandoc_msg="no"],
1524 [mandoc_msg="yes"]) 1422 [mandoc_msg="yes"])
1525 1423
1526# texinfo 1424# doxy
1527AS_IF([test "x$documentation" = "xyes"], 1425AS_IF([$DOXY_BINARY],
1528 [texinfo_msg="yes"], 1426 [doxy_msg="yes"],
1529 [texinfo_msg="no"]) 1427 [doxy_msg="no"])
1530 1428
1531# conversation 1429# conversation
1532conversation_msg="no" 1430conversation_msg="no"
@@ -1560,6 +1458,8 @@ AS_IF([test "x$extractor" = "x0"],
1560 AC_MSG_WARN([libextractor not found, but various file-sharing operations require it])], 1458 AC_MSG_WARN([libextractor not found, but various file-sharing operations require it])],
1561 [libextractor_msg="yes"]) 1459 [libextractor_msg="yes"])
1562 1460
1461AC_SUBST([extractor])
1462
1563# libzbar 1463# libzbar
1564AS_IF([test "x$zbar" = "x1"], 1464AS_IF([test "x$zbar" = "x1"],
1565 [libzbar_msg="yes"], 1465 [libzbar_msg="yes"],
@@ -1570,12 +1470,9 @@ AS_IF([test "x$png" = "x1"],
1570 [libpng_msg="yes"], 1470 [libpng_msg="yes"],
1571 [libpng_msg="no"]) 1471 [libpng_msg="no"])
1572 1472
1573# curl or gnurl 1473AS_IF([test "x$curl_gnutls" = "x0"],
1574AS_IF([test "x$gnurl" = "x1"], 1474 [curl_tls_backend="OpenSSL"],
1575 [http_client="gnurl"], 1475 [curl_tls_backend="GnuTLS"])
1576 [AS_IF([test "x$curl_gnutls" = "x1"],
1577 [http_client="curl-gnutls"],
1578 [http_client="curl-openssl"])])
1579 1476
1580# ifconfig 1477# ifconfig
1581AS_IF([test "x$IFCONFIG_BINARY" = "xfalse"], 1478AS_IF([test "x$IFCONFIG_BINARY" = "xfalse"],
@@ -1618,11 +1515,6 @@ AS_IF([test "x$sqlite3" = "x1"],
1618 features_msg="sqlite $features_msg"], 1515 features_msg="sqlite $features_msg"],
1619 [sqlite_msg="no"]) 1516 [sqlite_msg="no"])
1620 1517
1621AS_IF([test "x$mysql" = "xtrue"],
1622 [mysql_msg="yes"
1623 features_msg="mysql $features_msg"],
1624 [mysql_msg="no"])
1625
1626AS_IF([test "x$postgres" = "x1"], 1518AS_IF([test "x$postgres" = "x1"],
1627 [postgres_msg="yes" 1519 [postgres_msg="yes"
1628 features_msg="postgres $features_msg"], 1520 features_msg="postgres $features_msg"],
@@ -1651,10 +1543,9 @@ Build Target: ${build_target}
1651Default Interface: ${interface_msg} 1543Default Interface: ${interface_msg}
1652 1544
1653sqlite3: ${sqlite_msg} 1545sqlite3: ${sqlite_msg}
1654MySQL: ${mysql_msg}
1655PostgreSQL: ${postgres_msg} 1546PostgreSQL: ${postgres_msg}
1656 1547
1657HTTP Client: ${http_client} 1548cURL TLS backend: ${curl_tls_backend}
1658Bluetooth: ${bluetooth_msg} 1549Bluetooth: ${bluetooth_msg}
1659iptables: ${iptables_msg} 1550iptables: ${iptables_msg}
1660ifconfig: ${ifconfig_msg} 1551ifconfig: ${ifconfig_msg}
@@ -1673,7 +1564,7 @@ gstreamer: ${gstreamer_msg}
1673 1564
1674Java: ${java_msg} 1565Java: ${java_msg}
1675 1566
1676texi2mdoc: ${mdocbin_msg} 1567doxygen: ${doxy_msg}
1677mandoc: ${mandoc_msg} 1568mandoc: ${mandoc_msg}
1678 1569
1679GNUnet configuration 1570GNUnet configuration
@@ -1684,12 +1575,11 @@ Conversation: ${conversation_msg}
1684Database Backends ${features_msg} 1575Database Backends ${features_msg}
1685Experimental Code: ${experimental_msg} 1576Experimental Code: ${experimental_msg}
1686 1577
1687Texinfo Manual: ${texinfo_msg}
1688Transpiled mdocml Manual: ${mdocml_msg} 1578Transpiled mdocml Manual: ${mdocml_msg}
1689]) 1579])
1690 1580
1691AS_IF([test "x$MSG_USER_SETUP" != "xfalse"], 1581AS_IF([test "x$MSG_USER_SETUP" != "xfalse"],
1692 [AC_MSG_WARN([Please make sure NOW to create a user and group 'gnunet' and additionall a group 'gnunetdns'. Make sure that '/var/lib/gnunet' is owned (and writable) by user 'gnunet'.]) 1582 [AC_MSG_WARN([Please make sure NOW to create a user and group 'gnunet' and additionally a group 'gnunetdns'. Make sure that '/var/lib/gnunet' is owned (and writable) by user 'gnunet'.])
1693 AS_IF([test "x$HAVE_GNUNET_USER" != "x0"], 1583 AS_IF([test "x$HAVE_GNUNET_USER" != "x0"],
1694 [AC_MSG_NOTICE([To do this on this system, run: 1584 [AC_MSG_NOTICE([To do this on this system, run:
1695# addgroup gnunetdns 1585# addgroup gnunetdns