aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8fb6244f4..105950a0e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -614,7 +614,20 @@ AC_CHECK_HEADERS([fcntl.h math.h errno.h ctype.h limits.h stdio.h stdlib.h strin
614 614
615 615
616# Checks for headers that are only required on some systems or opional (and where we do NOT abort if they are not there) 616# Checks for headers that are only required on some systems or opional (and where we do NOT abort if they are not there)
617AC_CHECK_HEADERS([malloc.h malloc/malloc.h langinfo.h sys/param.h sys/mount.h sys/statvfs.h sys/select.h sockLib.h sys/mman.h sys/msg.h sys/vfs.h arpa/inet.h fcntl.h libintl.h netdb.h netinet/in.h netinet/in_systm.h netinet/ip.h sys/ioctl.h sys/socket.h sys/time.h unistd.h kstat.h sys/sysinfo.h kvm.h sys/file.h sys/resource.h ifaddrs.h mach/mach.h stddef.h sys/timeb.h terminos.h argz.h ucred.h sys/ucred.h endian.h sys/endian.h execinfo.h]) 617AC_CHECK_HEADERS([malloc.h malloc/malloc.h langinfo.h sys/param.h sys/mount.h sys/statvfs.h sys/select.h sockLib.h sys/mman.h sys/msg.h sys/vfs.h arpa/inet.h fcntl.h libintl.h netdb.h netinet/in.h sys/ioctl.h sys/socket.h sys/time.h unistd.h kstat.h sys/sysinfo.h kvm.h sys/file.h sys/resource.h ifaddrs.h mach/mach.h stddef.h sys/timeb.h terminos.h argz.h ucred.h sys/ucred.h endian.h sys/endian.h execinfo.h])
618
619# FreeBSD requires something more funky for netinet/in_systm.h and netinet/ip.h...
620AC_CHECK_HEADERS([sys/types.h netinet/in_systm.h netinet/in.h netinet/ip.h],,,
621[#ifdef HAVE_SYS_TYPES_H
622#include <sys/types.h>
623#endif
624#ifdef HAVE_NETINET_IN_SYSTM_H
625#include <netinet/in_systm.h>
626#endif
627#ifdef HAVE_NETINET_IN_H
628#include <netinet/in.h>
629#endif
630])
618 631
619SAVE_LDFLAGS=$LDFLAGS 632SAVE_LDFLAGS=$LDFLAGS
620SAVE_CPPFLAGS=$CPPFLAGS 633SAVE_CPPFLAGS=$CPPFLAGS