aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9a830320c..fb2d84ebb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -994,7 +994,19 @@ AC_ARG_WITH([ll],
994 ], 994 ],
995 [AC_MSG_RESULT(--with-ll not specified)]) 995 [AC_MSG_RESULT(--with-ll not specified)])
996AM_CONDITIONAL([WITH_LL], [test "x$llapi" = "xtrue"]) 996AM_CONDITIONAL([WITH_LL], [test "x$llapi" = "xtrue"])
997AC_DEFINE_UNQUOTED(WITH_LL, $llapi, [Do we have to use IBM LoadLeveler]) 997if test "x$llapi" = "xtrue"
998then
999 AC_DEFINE_UNQUOTED([WITH_LL], [$llapi], [Do we have to use IBM LoadLeveler])
1000 AC_CHECK_HEADERS([pwd.h],
1001 AC_CHECK_LIB([c],[getpwuid],,
1002 AC_MSG_ERROR(getpwid function not available in libc but is required)),
1003 AC_MSG_ERROR(pwd.h not found but is required),
1004 [[
1005 #ifdef HAVE_SYS_TYPES_H
1006 #include <sys/types.h>
1007 #endif
1008 ]])
1009fi
998 1010
999# should 'make check' run tests? 1011# should 'make check' run tests?
1000AC_MSG_CHECKING(whether to run tests) 1012AC_MSG_CHECKING(whether to run tests)