aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 4f6b69e17..270011a1c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -337,6 +337,7 @@ else
337 AC_DEFINE([DOCUMENTATION],[0],[Not building the documentation]) 337 AC_DEFINE([DOCUMENTATION],[0],[Not building the documentation])
338fi 338fi
339 339
340# FIXME: Something is wrong about this in the output of ./configure runs
340AC_MSG_CHECKING(wether to include generated texi2mdoc output in installation) 341AC_MSG_CHECKING(wether to include generated texi2mdoc output in installation)
341AC_ARG_ENABLE([texi2mdoc-generation], 342AC_ARG_ENABLE([texi2mdoc-generation],
342[AS_HELP_STRING([--disable-texi2mdoc-generation], [do not include generated texi2mdoc output in installation])], 343[AS_HELP_STRING([--disable-texi2mdoc-generation], [do not include generated texi2mdoc output in installation])],
@@ -708,12 +709,12 @@ AM_CONDITIONAL(HAVE_LIBATOMIC, [test "$have_libatomic" = 1])
708LIBS=$SAVE_LIBS 709LIBS=$SAVE_LIBS
709CPPFLAGS=$SAVE_CPPFLAGS 710CPPFLAGS=$SAVE_CPPFLAGS
710 711
711AC_CHECK_HEADERS([glpk.h],[glpk=true],[gplk=false]) 712AC_CHECK_HEADERS([glpk.h],[glpk=true],[glpk=false])
712# GLPK must support glpk_init_env, version >= 4.43 713# GLPK must support glpk_init_env, version >= 4.43
713AC_CHECK_LIB([glpk],[glp_init_env],,[gplk=false]) 714AC_CHECK_LIB([glpk],[glp_init_env],,[glpk=false])
714# GLPK must support atm MLP presolving, version >= 4.32 715# GLPK must support atm MLP presolving, version >= 4.32
715AC_CHECK_MEMBERS(glp_iocp.presolve,,[gplk=false],[[#include <glpk.h>]]) 716AC_CHECK_MEMBERS(glp_iocp.presolve,,[glpk=false],[[#include <glpk.h>]])
716if test x$gplk = xfalse 717if test "x$glpk" = xfalse
717then 718then
718 AM_CONDITIONAL(HAVE_LIBGLPK, false) 719 AM_CONDITIONAL(HAVE_LIBGLPK, false)
719 AC_MSG_WARN([ERROR: GNUnet requires GLPK >= 4.32]) 720 AC_MSG_WARN([ERROR: GNUnet requires GLPK >= 4.32])
@@ -1004,7 +1005,7 @@ AC_HEADER_DIRENT
1004AC_HEADER_STDC 1005AC_HEADER_STDC
1005 1006
1006# Check for headers that are ALWAYS required 1007# Check for headers that are ALWAYS required
1007AC_CHECK_HEADERS([fcntl.h math.h errno.h ctype.h limits.h stdio.h stdlib.h string.h unistd.h stdarg.h signal.h locale.h sys/stat.h sys/types.h],,AC_MSG_ERROR([Compiling GNUnet requires standard UNIX headers files])) 1008AC_CHECK_HEADERS([fcntl.h math.h errno.h ctype.h limits.h stdio.h stdlib.h string.h unistd.h stdarg.h signal.h locale.h sys/stat.h sys/types.h],,AC_MSG_ERROR([Compiling GNUnet requires standard UNIX headers files: fcntl.h math.h errno.h ctype.h limits.h stdio.h stdlib.h string.h unistd.h stdarg.h signal.h locale.h sys/stat.h sys/types.h]))
1008 1009
1009 1010
1010 1011