aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 16 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 699a63d3d..ad5cdaf20 100644
--- a/configure.ac
+++ b/configure.ac
@@ -248,15 +248,22 @@ LIBCURL_CHECK_CONFIG(,7.20.1,,AC_MSG_ERROR([GNUnet requires libcurl >= 7.20.1]))
248LIBS=$SAVE_LIBS 248LIBS=$SAVE_LIBS
249 249
250# glpk 250# glpk
251glpk=0 251#AC_CHECK_HEADERS(glpk.h, glpk=true)
252AC_CHECK_HEADERS([glpk.h]) 252#AM_CONDITIONAL(HAVE_GLPK, test x$glpk = xtrue)
253if test "$ac_cv_header_glpk_h" = yes; then 253#AC_CHECK_LIB([glpk],[glp_create_prob])
254AM_CONDITIONAL(HAVE_GLPK, 1) 254
255AC_DEFINE_UNQUOTED([HAVE_GLPK], test x$glpk = xtrue, [We have GLPK]) 255a=true
256else 256AC_CHECK_HEADERS(glpk.h, ,[a=false])
257AM_CONDITIONAL(HAVE_GLPK, test x$glpk = xtrue) 257AC_CHECK_LIB([glpk],[glp_create_prob], , [a=false])
258AC_MSG_WARN([GLPK not installed.]) 258if test $a == false
259fi 259then
260 AC_MSG_NOTICE([Feature b0rk is missing.])
261 AM_CONDITIONAL(HAVE_GLPK, [test x$a = xtrue])
262else
263 AC_MSG_NOTICE([Feature b0rk is present.])
264 AM_CONDITIONAL(HAVE_GLPK, [test x$a = xtrue])
265 AM_CONDITIONAL(HAVE_LIBGLPK, [test x$a = x$a])
266fi
260 267
261# test for kvm and kstat (for CPU stats under BSD/Solaris) 268# test for kvm and kstat (for CPU stats under BSD/Solaris)
262AC_CHECK_LIB([kvm],[kvm_open]) 269AC_CHECK_LIB([kvm],[kvm_open])