aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8c747d283..6f6e47ea4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -755,6 +755,23 @@ AC_MSG_RESULT($enable_malicious)
755AM_CONDITIONAL([HAVE_MALICIOUS], [test "x$enable_malicious" = "x1"]) 755AM_CONDITIONAL([HAVE_MALICIOUS], [test "x$enable_malicious" = "x1"])
756AC_DEFINE_UNQUOTED([HAVE_MALICIOUS], $enable_malicious, [Compile malicious code]) 756AC_DEFINE_UNQUOTED([HAVE_MALICIOUS], $enable_malicious, [Compile malicious code])
757 757
758# should code be enabled that works around missing OS functionality on Windows?
759# used for test cases
760AC_ARG_ENABLE(windows_workarounds, [AS_HELP_STRING([--enable-windows_workarounds],
761 [enable workarounds used on Windows (only useful for test cases)])])
762if test $build_target = "mingw"
763then
764 workarounds=1
765else
766 if test x$enable_windows_workarounds = "xyes"
767 then
768 workarounds=1
769 else
770 workarounds=0
771 fi
772fi
773AC_DEFINE_UNQUOTED([ENABLE_WINDOWS_WORKAROUNDS], $workarounds, [enable workarounds used on Windows (only useful for test cases)])
774
758# gcov compilation 775# gcov compilation
759use_gcov=no 776use_gcov=no
760AC_ARG_ENABLE([coverage], AS_HELP_STRING([--enable-coverage], 777AC_ARG_ENABLE([coverage], AS_HELP_STRING([--enable-coverage],