aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index e77a20b6b..ae7e04394 100644
--- a/configure.ac
+++ b/configure.ac
@@ -471,7 +471,7 @@ then
471 # need libcurl-gnutls.so, everything else is not acceptable 471 # need libcurl-gnutls.so, everything else is not acceptable
472 AC_CHECK_LIB([curl-gnutls],[curl_easy_getinfo],,[curl=false]) 472 AC_CHECK_LIB([curl-gnutls],[curl_easy_getinfo],,[curl=false])
473 # cURL must support CURLINFO_TLS_SESSION, version >= 7.34 473 # cURL must support CURLINFO_TLS_SESSION, version >= 7.34
474 474
475fi 475fi
476if test x$curl = xfalse 476if test x$curl = xfalse
477then 477then
@@ -824,7 +824,7 @@ AC_ARG_WITH(microhttpd,
824 yes) 824 yes)
825 AC_CHECK_HEADERS([microhttpd.h], 825 AC_CHECK_HEADERS([microhttpd.h],
826 AC_CHECK_DECL(MHD_OPTION_PER_IP_CONNECTION_LIMIT, 826 AC_CHECK_DECL(MHD_OPTION_PER_IP_CONNECTION_LIMIT,
827 AC_CHECK_LIB([microhttpd], [MHD_start_daemon], 827 AC_CHECK_LIB([microhttpd], [MHD_get_fdset2],
828 [AC_MSG_CHECKING([for libmicrohttpd >= 0.9.32]) 828 [AC_MSG_CHECKING([for libmicrohttpd >= 0.9.32])
829 AC_RUN_IFELSE([AC_LANG_SOURCE([ 829 AC_RUN_IFELSE([AC_LANG_SOURCE([
830 #include "$native_srcdir/src/include/platform.h" 830 #include "$native_srcdir/src/include/platform.h"
@@ -832,7 +832,7 @@ AC_ARG_WITH(microhttpd,
832 int main () { return MHD_VERSION >= 0x0093200 ? 0 : 1; } 832 int main () { return MHD_VERSION >= 0x0093200 ? 0 : 1; }
833 ])], [ 833 ])], [
834 AC_MSG_RESULT(ok) 834 AC_MSG_RESULT(ok)
835 lmhd=1],[AC_MSG_RESULT(failed)],lmhd=1)]), 835 lmhd=1],[AC_MSG_RESULT(failed)],lmhd=0)]),
836 [],[#include "$native_srcdir/src/include/platform.h" 836 [],[#include "$native_srcdir/src/include/platform.h"
837 #include <microhttpd.h>]),, 837 #include <microhttpd.h>]),,
838 [#include "$native_srcdir/src/include/platform.h"]) 838 [#include "$native_srcdir/src/include/platform.h"])
@@ -842,7 +842,7 @@ AC_ARG_WITH(microhttpd,
842 CPPFLAGS="-I$with_microhttpd/include $CPPFLAGS" 842 CPPFLAGS="-I$with_microhttpd/include $CPPFLAGS"
843 AC_CHECK_HEADERS(microhttpd.h, 843 AC_CHECK_HEADERS(microhttpd.h,
844 AC_CHECK_DECL(MHD_OPTION_PER_IP_CONNECTION_LIMIT, 844 AC_CHECK_DECL(MHD_OPTION_PER_IP_CONNECTION_LIMIT,
845 AC_CHECK_LIB([microhttpd], [MHD_start_daemon], 845 AC_CHECK_LIB([microhttpd], [MHD_get_fdset2],
846 EXT_LIB_PATH="-L$with_microhttpd/lib $EXT_LIB_PATH" 846 EXT_LIB_PATH="-L$with_microhttpd/lib $EXT_LIB_PATH"
847 [AC_MSG_CHECKING([for libmicrohttpd >= 0.9.32]) 847 [AC_MSG_CHECKING([for libmicrohttpd >= 0.9.32])
848 AC_RUN_IFELSE([AC_LANG_SOURCE([ 848 AC_RUN_IFELSE([AC_LANG_SOURCE([
@@ -851,7 +851,7 @@ AC_ARG_WITH(microhttpd,
851 int main () { return MHD_VERSION >= 0x0093200 ? 0 : 1; } 851 int main () { return MHD_VERSION >= 0x0093200 ? 0 : 1; }
852 ])], [ 852 ])], [
853 AC_MSG_RESULT(ok) 853 AC_MSG_RESULT(ok)
854 lmhd=1],[AC_MSG_RESULT(failed)],lmhd=1)]), 854 lmhd=1],[AC_MSG_RESULT(failed)],lmhd=0)]),
855 [],[#include "$native_srcdir/src/include/platform.h" 855 [],[#include "$native_srcdir/src/include/platform.h"
856 #include <microhttpd.h>]),, 856 #include <microhttpd.h>]),,
857 [#include "$native_srcdir/src/include/platform.h"]) 857 [#include "$native_srcdir/src/include/platform.h"])
@@ -861,7 +861,7 @@ AC_ARG_WITH(microhttpd,
861 [AC_MSG_RESULT([--with-microhttpd not specified]) 861 [AC_MSG_RESULT([--with-microhttpd not specified])
862 AC_CHECK_HEADERS([microhttpd.h], 862 AC_CHECK_HEADERS([microhttpd.h],
863 AC_CHECK_DECL(MHD_OPTION_PER_IP_CONNECTION_LIMIT, 863 AC_CHECK_DECL(MHD_OPTION_PER_IP_CONNECTION_LIMIT,
864 AC_CHECK_LIB([microhttpd], [MHD_start_daemon], 864 AC_CHECK_LIB([microhttpd], [MHD_get_fdset2],
865 [AC_MSG_CHECKING([for libmicrohttpd >= 0.9.32]) 865 [AC_MSG_CHECKING([for libmicrohttpd >= 0.9.32])
866 AC_RUN_IFELSE([AC_LANG_SOURCE([ 866 AC_RUN_IFELSE([AC_LANG_SOURCE([
867 #include "$native_srcdir/src/include/platform.h" 867 #include "$native_srcdir/src/include/platform.h"
@@ -869,7 +869,7 @@ AC_ARG_WITH(microhttpd,
869 int main () { return MHD_VERSION >= 0x0093200 ? 0 : 1; } 869 int main () { return MHD_VERSION >= 0x0093200 ? 0 : 1; }
870 ])], [ 870 ])], [
871 AC_MSG_RESULT(ok) 871 AC_MSG_RESULT(ok)
872 lmhd=1],[AC_MSG_RESULT(failed)],lmhd=1)]), 872 lmhd=1],[AC_MSG_RESULT(failed)],lmhd=0)]),
873 [],[#include "$native_srcdir/src/include/platform.h" 873 [],[#include "$native_srcdir/src/include/platform.h"
874 #include <microhttpd.h>]),, 874 #include <microhttpd.h>]),,
875 [#include "$native_srcdir/src/include/platform.h"])]) 875 [#include "$native_srcdir/src/include/platform.h"])])