aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 22133e07d..b958efc7e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -725,6 +725,18 @@ AC_ARG_ENABLE(experimental,
725AC_MSG_RESULT($enable_experimental) 725AC_MSG_RESULT($enable_experimental)
726AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "xyes"]) 726AM_CONDITIONAL([HAVE_EXPERIMENTAL], [test "x$enable_experimental" = "xyes"])
727 727
728# should malicious code be compiled (code used for testing with malicious peers)
729disable_malicious=yes
730AC_MSG_CHECKING(whether to compile malicious code)
731AC_ARG_ENABLE(malicious,
732 [AS_HELP_STRING([--enable-malicious],
733 [enable compiling malicious code (only for developers for testing)])],
734 [enable_malicious=$enableval],
735 [enable_malicious="no"])
736AC_MSG_RESULT($enable_malicious)
737AM_CONDITIONAL([HAVE_MALICIOUS], [test "x$enable_malicious" = "xyes"])
738AC_DEFINE_UNQUOTED([HAVE_MALICIOUS], $enable_malicious, [Compile malicious code])
739
728# gcov compilation 740# gcov compilation
729use_gcov=no 741use_gcov=no
730AC_ARG_ENABLE([coverage], AS_HELP_STRING([--enable-coverage], 742AC_ARG_ENABLE([coverage], AS_HELP_STRING([--enable-coverage],