aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 86e1f2c72..55ae95c8b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -337,6 +337,7 @@ else
337 AC_DEFINE([DOCUMENTATION],[0],[Not building the documentation]) 337 AC_DEFINE([DOCUMENTATION],[0],[Not building the documentation])
338fi 338fi
339 339
340# FIXME: Something is wrong about this in the output of ./configure runs
340AC_MSG_CHECKING(wether to include generated texi2mdoc output in installation) 341AC_MSG_CHECKING(wether to include generated texi2mdoc output in installation)
341AC_ARG_ENABLE([texi2mdoc-generation], 342AC_ARG_ENABLE([texi2mdoc-generation],
342[AS_HELP_STRING([--disable-texi2mdoc-generation], [do not include generated texi2mdoc output in installation])], 343[AS_HELP_STRING([--disable-texi2mdoc-generation], [do not include generated texi2mdoc output in installation])],
@@ -693,12 +694,12 @@ AM_CONDITIONAL(HAVE_LIBATOMIC, [test "$have_libatomic" = 1])
693LIBS=$SAVE_LIBS 694LIBS=$SAVE_LIBS
694CPPFLAGS=$SAVE_CPPFLAGS 695CPPFLAGS=$SAVE_CPPFLAGS
695 696
696AC_CHECK_HEADERS([glpk.h],[glpk=true],[gplk=false]) 697AC_CHECK_HEADERS([glpk.h],[glpk=true],[glpk=false])
697# GLPK must support glpk_init_env, version >= 4.43 698# GLPK must support glpk_init_env, version >= 4.43
698AC_CHECK_LIB([glpk],[glp_init_env],,[gplk=false]) 699AC_CHECK_LIB([glpk],[glp_init_env],,[glpk=false])
699# GLPK must support atm MLP presolving, version >= 4.32 700# GLPK must support atm MLP presolving, version >= 4.32
700AC_CHECK_MEMBERS(glp_iocp.presolve,,[gplk=false],[[#include <glpk.h>]]) 701AC_CHECK_MEMBERS(glp_iocp.presolve,,[glpk=false],[[#include <glpk.h>]])
701if test x$gplk = xfalse 702if test "x$glpk" = xfalse
702then 703then
703 AM_CONDITIONAL(HAVE_LIBGLPK, false) 704 AM_CONDITIONAL(HAVE_LIBGLPK, false)
704 AC_MSG_WARN([ERROR: GNUnet requires GLPK >= 4.32]) 705 AC_MSG_WARN([ERROR: GNUnet requires GLPK >= 4.32])