aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 10 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index a81e8a9f7..a1a89f944 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2002,7 +2002,9 @@ AS_IF([test "x$enable_java_ports" = "xyes"],
2002#### This could be moved to the checks above, 2002#### This could be moved to the checks above,
2003#### but for now let's keep it here. 2003#### but for now let's keep it here.
2004#### 2004####
2005 2005transport_msg="tcp udp unix"
2006AS_IF([test "x$build_target" = "xlinux" -a "x$enable_experimental" = "xyes"],
2007 [transport_msg="$transport_msg wlan"])
2006# -- print message regarding enabled experimental features 2008# -- print message regarding enabled experimental features
2007experimental_msg="no" 2009experimental_msg="no"
2008AS_IF([test "x$enable_experimental" = "xyes"], 2010AS_IF([test "x$enable_experimental" = "xyes"],
@@ -2070,7 +2072,8 @@ interface_msg=`echo $DEFAULT_INTERFACE | tr -d \"`
2070# -- libmicrohttpd 2072# -- libmicrohttpd
2071AS_IF([test "x$lmhd" = "x0"], 2073AS_IF([test "x$lmhd" = "x0"],
2072 [libmicrohttpd_msg="no (REST service and HTTP transport will not be built)"], 2074 [libmicrohttpd_msg="no (REST service and HTTP transport will not be built)"],
2073 [libmicrohttpd_msg="yes"]) 2075 [libmicrohttpd_msg="yes"
2076 transport_msg="$transport_msg http_server"])
2074# -- jansson 2077# -- jansson
2075AS_IF([test "x$jansson" = "x0"], 2078AS_IF([test "x$jansson" = "x0"],
2076 [jansson_msg="no (REST service will not be built)"], 2079 [jansson_msg="no (REST service will not be built)"],
@@ -2091,7 +2094,8 @@ AS_IF([test "$gnurl" = "0"],
2091 curl_msg="no"], 2094 curl_msg="no"],
2092 [AC_MSG_NOTICE([libgnurl not found, trying to use libcurl-gnutls instead.]) 2095 [AC_MSG_NOTICE([libgnurl not found, trying to use libcurl-gnutls instead.])
2093 curl_msg="yes"])], 2096 curl_msg="yes"])],
2094 [gnurl_msg="yes"]) 2097 [gnurl_msg="yes"
2098 transport_msg="$transport_msg http_client"])
2095# -- ifconfig 2099# -- ifconfig
2096AS_IF([test "$VAR_IFCONFIG_BINARY" = "false"], 2100AS_IF([test "$VAR_IFCONFIG_BINARY" = "false"],
2097 [ifconfig_msg="no (optional, some features will not work)"], 2101 [ifconfig_msg="no (optional, some features will not work)"],
@@ -2107,7 +2111,8 @@ AS_IF([test "$VAR_IPTABLES_BINARY" = "false"],
2107# -- bluetooth 2111# -- bluetooth
2108AS_IF([test "x$bluetooth" = "x0"], 2112AS_IF([test "x$bluetooth" = "x0"],
2109 [bluetooth_msg="no (optional)"], 2113 [bluetooth_msg="no (optional)"],
2110 [bluetooth_msg="yes"]) 2114 [bluetooth_msg="yes"
2115 transport_msg="$transport_msg bluetooth"])
2111# -- gnutls 2116# -- gnutls
2112AS_IF([test x$gnutls != xtrue], 2117AS_IF([test x$gnutls != xtrue],
2113 [AC_MSG_WARN([GnuTLS not found, gnunet-gns-proxy will not be built]) 2118 [AC_MSG_WARN([GnuTLS not found, gnunet-gns-proxy will not be built])
@@ -2188,6 +2193,7 @@ mandoc: ${mandoc_msg}
2188 2193
2189GNUnet configuration: 2194GNUnet configuration:
2190===================== 2195=====================
2196transports: ${transport_msg}
2191reclaimID: ${reclaim_msg} 2197reclaimID: ${reclaim_msg}
2192conversation: ${conversation_msg} 2198conversation: ${conversation_msg}
2193rest: ${rest_msg} 2199rest: ${rest_msg}