aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 6 insertions, 36 deletions
diff --git a/configure.ac b/configure.ac
index 98bd4ca70..23ca78dbb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1026,23 +1026,6 @@ AC_CHECK_LIB([kvm],[kvm_open])
1026AC_CHECK_LIB([kstat],[kstat_open]) 1026AC_CHECK_LIB([kstat],[kstat_open])
1027 1027
1028 1028
1029# should the build process be restricted to the code required
1030# for GNU Taler wallets?
1031AC_MSG_CHECKING(whether to compile GNU Taler Wallet library ONLY)
1032AC_ARG_ENABLE([taler-wallet],
1033 [AS_HELP_STRING([--enable-taler-wallet], [only compile for Taler wallet])],
1034 [taler_only=${enableval}],
1035 [taler_only=no])
1036AC_MSG_RESULT($taler_only)
1037AS_IF([test "x$taler_only" = "xyes"],
1038[
1039 AM_CONDITIONAL([TALER_ONLY],true)
1040 AC_DEFINE([TALER_WALLET_ONLY],[1],[Compiling for Taler wallet])
1041],[
1042 AM_CONDITIONAL([TALER_ONLY],false)
1043 AC_DEFINE([TALER_WALLET_ONLY],[0],[Canonical compilation])
1044])
1045
1046# test for libextractor 1029# test for libextractor
1047extractor=0 1030extractor=0
1048AC_MSG_CHECKING(for libextractor) 1031AC_MSG_CHECKING(for libextractor)
@@ -1081,9 +1064,6 @@ AS_IF([test "$extractor" != 1],
1081 ]) 1064 ])
1082 1065
1083 1066
1084AS_IF([test "$taler_only" != yes],[
1085
1086
1087# Check for libltdl header (#2999) 1067# Check for libltdl header (#2999)
1088ltdl=0 1068ltdl=0
1089AC_MSG_CHECKING(for libltdl) 1069AC_MSG_CHECKING(for libltdl)
@@ -1250,10 +1230,6 @@ AS_IF([test "$enable_shared" = "no"],
1250LIBS=$SAVE_LIBS 1230LIBS=$SAVE_LIBS
1251 1231
1252 1232
1253# end of taler-only being false
1254])
1255
1256
1257# check for iconv 1233# check for iconv
1258AM_ICONV 1234AM_ICONV
1259 1235
@@ -1262,12 +1238,8 @@ gl_LIBUNISTRING
1262AS_IF([test $HAVE_LIBUNISTRING != yes], 1238AS_IF([test $HAVE_LIBUNISTRING != yes],
1263 [AC_MSG_ERROR([GNUnet requires libunistring])]) 1239 [AC_MSG_ERROR([GNUnet requires libunistring])])
1264 1240
1265# under emscripten, $gl_libunistring_hexversion is undefined
1266if test "$taler_only" != yes; then
1267
1268AS_IF([test "x$gl_libunistring_hexversion" = "x" || test "$gl_libunistring_hexversion" -le 2305], 1241AS_IF([test "x$gl_libunistring_hexversion" = "x" || test "$gl_libunistring_hexversion" -le 2305],
1269 [AC_MSG_ERROR([GNUnet requires libunistring >= 0.9.1.1])]) 1242 [AC_MSG_ERROR([GNUnet requires libunistring >= 0.9.1.1])])
1270fi
1271AC_CHECK_HEADERS([unistr.h], 1243AC_CHECK_HEADERS([unistr.h],
1272 , 1244 ,
1273 AC_MSG_ERROR([Compiling GNUnet requires unistr.h (from libunistring) to be installed])) 1245 AC_MSG_ERROR([Compiling GNUnet requires unistr.h (from libunistring) to be installed]))
@@ -1340,14 +1312,12 @@ CPPFLAGS=$SAVE_CPPFLAGS
1340 1312
1341# test for postgres: 1313# test for postgres:
1342postgres=false 1314postgres=false
1343# even running the check for postgres breaks emscripten 1315AX_LIB_POSTGRESQL([9.5],
1344AS_IF([test "$taler_only" != yes], 1316 [CPPFLAGS="$CPPFLAGS $POSTGRESQL_CPPFLAGS"
1345 [AX_LIB_POSTGRESQL([9.5], 1317 AC_CHECK_HEADERS([libpq-fe.h],
1346 [CPPFLAGS="$CPPFLAGS $POSTGRESQL_CPPFLAGS" 1318 postgres=true)
1347 AC_CHECK_HEADERS([libpq-fe.h], 1319 ],
1348 postgres=true) 1320 [AC_MSG_RESULT([no postgres])])
1349 ],
1350 [AC_MSG_RESULT([no postgres])])])
1351 1321
1352AM_CONDITIONAL(HAVE_POSTGRESQL, test x$postgres = xtrue) 1322AM_CONDITIONAL(HAVE_POSTGRESQL, test x$postgres = xtrue)
1353AS_IF([test "x$postgres" = xtrue], 1323AS_IF([test "x$postgres" = xtrue],