aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac45
1 files changed, 29 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 151d76d2d..c1d463a26 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1203,25 +1203,38 @@ fi
1203 1203
1204 1204
1205AC_MSG_NOTICE([******************************************** 1205AC_MSG_NOTICE([********************************************
1206Please make sure that you have created a user and group 'gnunet' 1206Please make sure NOW that you have created a user and group 'gnunet'
1207and additionally a group 'gnunetdns'. Make sure that '/var/lib/gnunet' 1207and additionally a group 'gnunetdns':
1208is owned (and writable) by user 'gnunet'. Then, you can compile GNUnet 1208 addgroup gnunetdns
1209with 1209 adduser gnunet
1210 make 1210
1211Make sure that '/var/lib/gnunet' is owned (and writable) by user
1212'gnunet'. Then, you can compile GNUnet with
1213 make
1214
1211After that, run (if necessary as 'root') 1215After that, run (if necessary as 'root')
1212 make install 1216 make install
1213to install everything. 1217to install everything.
1214Then, in order to start your peer, run as the 'gnunet' user
1215 mkdir ~gnunet/.gnunet/
1216 touch ~gnunet/.gnunet/gnunet.conf
1217 gnunet-arm -s
1218 1218
1219Each GNUnet user should also be added to the 'gnunet' group (may 1219Each GNUnet user should be added to the 'gnunet' group (may
1220require fresh login to come into effect) and create an (at least 1220require fresh login to come into effect):
1221initially) empty configuration file: 1221 adduser $USERNAME gnunet
1222 mkdir $HOME/.gnunet/ 1222(run the above command as root once for each of your users, replacing
1223 touch $HOME/.gnunet/gnunet.conf 1223"$USERNAME" with the respective login names). If you have a global IP
1224address, no further configuration is required.
1224 1225
1225Optionally, download and compile: 1226Optionally, download and compile gnunet-gtk to get a GUI for
1226- gnunet-gtk to get a GUI for file-sharing and configuration. 1227file-sharing and configuration. This is particularly recommended
1228if your network setup is non-trivial, as gnunet-setup can be
1229used to test in the GUI if your network configuration is working.
1230gnunet-setup should be run as the "gnunet" user under X. As it
1231does very little with the network, running it as "root" is likely
1232also harmless. You can also run it as a normal user, but then
1233you have to copy ~/.gnunet/gnunet.conf" over to the "gnunet" user's
1234home directory in the end.
1235
1236Once you have configured your peer, run (as the 'gnunet' user)
1237 gnunet-arm -s
1238to start the peer. You can then run the various GNUnet-tools as
1239your "normal" user (who should only be in the group 'gnunet').
1227********************************************]) 1240********************************************])