aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 15 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 358b06634..c110b97a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -368,31 +368,31 @@ fi # $build = $target
368# check for bluetooth library 368# check for bluetooth library
369bluetooth=0 369bluetooth=0
370AC_CHECK_LIB(bluetooth, ba2str,[AC_CHECK_HEADER([bluetooth/bluetooth.h],bluetooth=1)]) 370AC_CHECK_LIB(bluetooth, ba2str,[AC_CHECK_HEADER([bluetooth/bluetooth.h],bluetooth=1)])
371if test "$bluetooth" = 1
372then
373 AM_CONDITIONAL(HAVE_LIBBLUETOOTH, true)
374 AC_DEFINE([HAVE_LIBBLUETOOTH],[1],[Have bluetooth library])
375else
376 AM_CONDITIONAL(HAVE_LIBBLUETOOTH, false)
377fi
378if test "$build_target" = "mingw" 371if test "$build_target" = "mingw"
379then 372then
380 bluetooth=1 373 bluetooth=1
381fi 374fi
375AM_CONDITIONAL(HAVE_LIBBLUETOOTH, [test "$bluetooth" = 1])
376if test "$bluetooth" = 1
377then
378 AC_DEFINE([HAVE_LIBBLUETOOTH],[1],[Have bluetooth library])
379else
380 AC_DEFINE([HAVE_LIBBLUETOOTH],[0],[Lacking bluetooth library])
381fi
382 382
383 383
384# check for libpulse(audio) library 384# check for libpulse(audio) library
385pulse=0 385pulse=0
386AC_CHECK_LIB(pulse,pa_stream_peek, 386AC_CHECK_LIB(pulse,pa_stream_peek,
387 [AC_CHECK_HEADER([pulse/simple.h],pulse=1)]) 387 [AC_CHECK_HEADER([pulse/simple.h],pulse=1)])
388if test "$pulse" = 1
389then
390 AC_DEFINE([HAVE_PULSE],[1],[Have libpulse(audio) library])
391fi
392if test "$build_target" = "mingw" 388if test "$build_target" = "mingw"
393then 389then
394 pulse=0 390 pulse=0
395fi 391fi
392if test "$pulse" = 1
393then
394 AC_DEFINE([HAVE_PULSE],[1],[Have libpulse(audio) library])
395fi
396 396
397# check for libopus(audio) library 397# check for libopus(audio) library
398opus=0 398opus=0
@@ -442,9 +442,9 @@ then
442 AM_CONDITIONAL(BUILD_PULSE_HELPERS, false) 442 AM_CONDITIONAL(BUILD_PULSE_HELPERS, false)
443 AM_CONDITIONAL(BUILD_GST_HELPERS, false) 443 AM_CONDITIONAL(BUILD_GST_HELPERS, false)
444 else 444 else
445 conversation_backend=gst 445 conversation_backend=gst
446 AM_CONDITIONAL(BUILD_PULSE_HELPERS, false) 446 AM_CONDITIONAL(BUILD_PULSE_HELPERS, false)
447 AM_CONDITIONAL(BUILD_GST_HELPERS, true) 447 AM_CONDITIONAL(BUILD_GST_HELPERS, true)
448 fi 448 fi
449else 449else
450 conversation_backend=pulse 450 conversation_backend=pulse
@@ -460,6 +460,7 @@ then
460 AC_DEFINE([HAVE_LIBGNURL],[1],[Have libgnurl]) 460 AC_DEFINE([HAVE_LIBGNURL],[1],[Have libgnurl])
461else 461else
462 AM_CONDITIONAL(HAVE_LIBGNURL, false) 462 AM_CONDITIONAL(HAVE_LIBGNURL, false)
463 AC_DEFINE([HAVE_LIBGNURL],[0],[Lacking libgnurl])
463fi 464fi
464 465
465SAVE_CPPFLAGS=$CPPFLAGS 466SAVE_CPPFLAGS=$CPPFLAGS