aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac43
1 files changed, 42 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c2d9bbcb5..79e64ca5e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -360,7 +360,7 @@ fi # $build = $target
360 360
361# check for bluetooth library 361# check for bluetooth library
362bluetooth=0 362bluetooth=0
363AC_CHECK_LIB(bluetooth, ba2str, bluetooth=1, bluetooth=0) 363AC_CHECK_LIB(bluetooth, ba2str,[AC_CHECK_HEADER([bluetooth/bluetooth.h],bluetooth=1)])
364if test "$bluetooth" = 1 364if test "$bluetooth" = 1
365then 365then
366 AM_CONDITIONAL(HAVE_LIBBLUETOOTH, true) 366 AM_CONDITIONAL(HAVE_LIBBLUETOOTH, true)
@@ -373,6 +373,34 @@ then
373 bluetooth=1 373 bluetooth=1
374fi 374fi
375 375
376# check for libpulse(audio) library
377pulse=0
378AC_CHECK_LIB(pulse,pa_stream_peak,
379 [AC_CHECK_HEADER([pulse/simple.h],pulse=1)])
380if test "$pulse" = 1
381then
382 AM_CONDITIONAL(HAVE_PULSE, true)
383 AC_DEFINE([HAVE_PULSE],[1],[Have libpulse(audio) library])
384else
385 AM_CONDITIONAL(HAVE_PULSE, false)
386fi
387if test "$build_target" = "mingw"
388then
389 pulse=0
390fi
391
392# check for libopus(audio) library
393opus=0
394AC_CHECK_LIB(opus,opus_decode_float,
395 [AC_CHECK_HEADER([opus/opus.h],opus=1)])
396if test "$opus" = 1
397then
398 AM_CONDITIONAL(HAVE_OPUS, true)
399 AC_DEFINE([HAVE_OPUS],[1],[Have libopus library])
400else
401 AM_CONDITIONAL(HAVE_OPUS, false)
402fi
403
376 404
377# libcurl 405# libcurl
378LIBCURL_CHECK_CONFIG(,7.21.3,curl=1,curl=0) 406LIBCURL_CHECK_CONFIG(,7.21.3,curl=1,curl=0)
@@ -1440,11 +1468,24 @@ then
1440 AC_MSG_NOTICE([NOTICE: opening ports for gnunet-java bindings by default.]) 1468 AC_MSG_NOTICE([NOTICE: opening ports for gnunet-java bindings by default.])
1441fi 1469fi
1442 1470
1471# MHD
1443if test "x$lmhd" != "x1" 1472if test "x$lmhd" != "x1"
1444then 1473then
1445 AC_MSG_NOTICE([NOTICE: libmicrohttpd not found, http transport will not be installed.]) 1474 AC_MSG_NOTICE([NOTICE: libmicrohttpd not found, http transport will not be installed.])
1446fi 1475fi
1447 1476
1477# Pulse Audio
1478if test "x$pulse" != "x1"
1479then
1480 AC_MSG_NOTICE([NOTICE: libpulse(audio) not found, conversation will not be built.])
1481fi
1482
1483# Opus
1484if test "x$opus" != "x1"
1485then
1486 AC_MSG_NOTICE([NOTICE: libopus not found, conversation will not be built.])
1487fi
1488
1448AC_MSG_NOTICE([NOTICE: Database support is set to MySQL: $mysql, SQLite: $sqlite, Postgres: $postgres]) 1489AC_MSG_NOTICE([NOTICE: Database support is set to MySQL: $mysql, SQLite: $sqlite, Postgres: $postgres])
1449 1490
1450if test "$enable_framework_build" = "yes" 1491if test "$enable_framework_build" = "yes"